Menu
Amazon Route 53
API Reference

CloudWatchAlarmConfiguration

A complex type that contains information about the CloudWatch alarm that Amazon Route 53 is monitoring for this health check.

Contents

ComparisonOperator

For the metric that the CloudWatch alarm is associated with, the arithmetic operation that is used for the comparison.

Type: String

Valid Values: GreaterThanOrEqualToThreshold | GreaterThanThreshold | LessThanThreshold | LessThanOrEqualToThreshold

Required: Yes

Dimensions

For the metric that the CloudWatch alarm is associated with, a complex type that contains information about the dimensions for the metric. For information, see Amazon CloudWatch Namespaces, Dimensions, and Metrics Reference in the Amazon CloudWatch User Guide.

Type: Array of Dimension objects

Array Members: Maximum number of 10 items.

Required: No

EvaluationPeriods

For the metric that the CloudWatch alarm is associated with, the number of periods that the metric is compared to the threshold.

Type: Integer

Valid Range: Minimum value of 1.

Required: Yes

MetricName

The name of the CloudWatch metric that the alarm is associated with.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 255.

Required: Yes

Namespace

The namespace of the metric that the alarm is associated with. For more information, see Amazon CloudWatch Namespaces, Dimensions, and Metrics Reference in the Amazon CloudWatch User Guide.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 255.

Required: Yes

Period

For the metric that the CloudWatch alarm is associated with, the duration of one evaluation period in seconds.

Type: Integer

Valid Range: Minimum value of 60.

Required: Yes

Statistic

For the metric that the CloudWatch alarm is associated with, the statistic that is applied to the metric.

Type: String

Valid Values: Average | Sum | SampleCount | Maximum | Minimum

Required: Yes

Threshold

For the metric that the CloudWatch alarm is associated with, the value the metric is compared with.

Type: Double

Required: Yes

See Also

For more information about using this API in one of the language-specific AWS SDKs, see the following:

On this page: