Menu
AWS Database Migration Service
User Guide (Version API Version 2016-01-01)

Targets for AWS Database Migration Service

You can use the following data stores as target endpoints for data migration using AWS Database Migration Service.

On-premises and Amazon EC2 instance databases

  • Oracle versions 10g, 11g, 12c, for the Enterprise, Standard, Standard One, and Standard Two editions

  • Microsoft SQL Server versions 2005, 2008, 2008R2, 2012, 2014, and 2016, for the Enterprise, Standard, Workgroup, and Developer editions. The Web and Express editions are not supported.

  • MySQL, versions 5.5, 5.6, and 5.7

  • MariaDB (supported as a MySQL-compatible data target)

  • PostgreSQL, versions 9.3 and later

  • SAP Adaptive Server Enterprise (ASE) 15.7 and later

Microsoft Azure

  • Azure SQL Database

Amazon RDS instance databases, Amazon Redshift, Amazon DynamoDB, and Amazon S3

  • Oracle versions 11g (versions 11.2.0.3.v1 and later) and 12c, for the Enterprise, Standard, Standard One, and Standard Two editions

  • Microsoft SQL Server versions 2008R2, 2012, and 2014, for the Enterprise, Standard, Workgroup, and Developer editions. The Web and Express editions are not supported.

  • MySQL, versions 5.5, 5.6, and 5.7

  • MariaDB (supported as a MySQL-compatible data target)

  • PostgreSQL, versions 9.3 and later

  • Amazon Aurora with MySQL compatibility

  • Amazon Aurora with PostgreSQL compatibility

  • Amazon Redshift

  • Amazon S3

  • Amazon DynamoDB