メニュー
AWS Elastic Beanstalk
開発者ガイド (API Version 2010-12-01)

Node.js プラットフォーム履歴

このページには、AWS Elastic Beanstalk の Node.js プラットフォームの以前のバージョンと、各バージョンが最新であった日付が一覧表示されます。環境を起動するのに使用したプラットフォームバージョンは、最新でなくなった後もそのまま使用できます。

Elastic Beanstalk でサポートされる各プラットフォームの最新バージョンについては、事前構成済みプラットフォームのページを参照してください。最近のリリースに関する詳細なリリースノートは、aws.amazon.com/releasenotes で参照できます。

Elastic Beanstalk は、2017 年 19 月 5 日から 2017 年 6 月 26 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

AWS X-Ray

Node.js バージョン 4.1.0

Node.js を実行する 64 ビット Amazon Linux 2017.03 v4.1.0

2017.03.0

Node.js 6.10.0、また 7.6.0、6.9.1、5.12.0、4.8.0、4.6.1 もサポートします

NPM 3.9.5

nginx 1.10.2、Apache 2.4.25

2.7.4

2.0.0

Elastic Beanstalk は、2017 年 18 月 5 日から 2017 年 5 月 4 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

AWS X-Ray

Node.js バージョン 4.0.1

Node.js を実行する 64 ビット Amazon Linux 2016.09 v4.0.1

2016.09.0

Node.js 6.10.0、また 7.6.0、6.9.1、5.12.0、4.8.0、4.6.1 もサポートします

NPM 3.9.5

nginx 1.10.1、Apache 2.4.25

2.7.4

1.0.0

Elastic Beanstalk は、2017 年 3 月 8 日から 2017 年 4 月 4 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

AWS X-Ray

Node.js バージョン 4.0.0

Node.js を実行する 64 ビット Amazon Linux 2016.09 v4.0.0

2016.09.0

Node.js 6.10.0、また 7.6.0、6.9.1、5.12.0、4.8.0、4.6.1 もサポートします

NPM 3.9.5

nginx 1.10.1、Apache 2.4.25

2.7.4

1.0.0

Elastic Beanstalk は、2017 年 2 月 9 日から 2017 年 3 月 7 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

AWS X-Ray

Node.js バージョン 3.3.1

Node.js を実行する 64 ビット Amazon Linux 2016.09 v3.3.1

2016.09.0

Node.js 6.9.1。6.2.2、5.12.0、4.6.1、4.4.6、0.12.17、0.12.15、0.10.48、0.10.46 もサポートします

NPM 3.9.5

nginx 1.10.1、Apache 2.4.23

2.7.4

1,0.0

Elastic Beanstalk は、2016 年 12 月 22 日から 2017 年 1 月 8 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

AWS X-Ray

Node.js バージョン 3.3.0

Node.js を実行する 64 ビット Amazon Linux 2016.09 v3.3.0

2016.09.0

Node.js 6.9.1。6.2.2、5.12.0、4.6.1、4.4.6、0.12.17、0.12.15、0.10.48、0.10.46 もサポートします

NPM 3.9.5

nginx 1.10.1、Apache 2.4.23

2.7.4

1.0.0

Elastic Beanstalk は、2016 年 12 月 9 日から 2016 年 12 月 21 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

Node.js バージョン 3.2.0

Node.js を実行する 64 ビット Amazon Linux 2016.09 v3.2.0

2016.09.0

Node.js 6.9.1。6.2.2、5.12.0、4.6.1、4.4.6、0.12.17、0.12.15、0.10.48、0.10.46 もサポートします

NPM 3.10.8*

nginx 1.10.1、Apache 2.4.23

2.7.4

* お使いの Node.js のバージョンによって異なります。

Elastic Beanstalk は、2016 年 10 月 28 日から 2016 年 12 月 8 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

Node.js バージョン 3.1.0

Node.js を実行する 64 ビット Amazon Linux 2016.09 v3.1.0

2016.09.0

Node.js 6.9.1 は、6.9.1、6.2.2、5.12.0、4.6.1、4.4.6、0.12.17、0.12.15、0.10.48、0.10.46 もサポートします

NPM 2.15.5

nginx 1.10.1、Apache 2.4.18

2.7.4

Elastic Beanstalk は、2016 年 6 月 26 日から 2016 年 10 月 27 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

Node.js バージョン 2.1.3

Node.js を実行する 64 ビット Amazon Linux 2016.03 v2.1.3

2016.03.2

Node.js 4.4.6 は、6.2.2、5.12.0、0.12.15、0.10.46、0.8.28 もサポートします

NPM 2.15.5

nginx 1.8.1、Apache 2.4.18

2.7.4

Elastic Beanstalk は、2016 年 9 月 5 日から 2016 年 6 月 26 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

Node.js バージョン 2.1.1

Node.js を実行する 64 ビット Amazon Linux 2016.03 v2.1.1

2016.03

Node.js 4.4.3、0.12.13、0.10.44、0.8.28 もサポートします

NPM 2.15.1

nginx 1.8.1、Apache 2.4.18

2.7.4

Elastic Beanstalk は、2016 年 9 月 7 日から 2016 年 5 月 4 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

プロキシサーバー

Git

Node.js バージョン 2.1.0

Node.js を実行する 64 ビット Amazon Linux 2016.03 v2.1.0

2016.03

Node.js 4.3.0

0.12.10、0.10.42、0.8.28 もサポートします

NPM 2.14.7

nginx 1.8.1 または

Apache 2.4.18

Git 2.7.4

Elastic Beanstalk は、2016 年 2 月 26 日から 2016 年 4 月 7 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

ウェブサーバー

Git

Node.js バージョン 2.0.8

Node.js を実行する 64 ビット Amazon Linux 2015.09 v2.0.8

2015.09

Node.js 4.3.0

0.12.10、0.10.42、0.8.28 もサポートします

NPM 2.14.7

nginx 1.8.0 または

Apache 2.4.16

Git 2.4.3

Elastic Beanstalk は、2016 年 2 月 11 日から 2016 年 2 月 26 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

ウェブサーバー

Git

Node.js バージョン 2.0.7

Node.js を実行する 64 ビット Amazon Linux 2015.09 v2.0.7

2015.09

Node.js 4.2.3

0.12.9、0.10.41、0.8.28 もサポートします

NPM 2.14.7

nginx 1.8.0 または

Apache 2.4.16

Git 2.4.3

Elastic Beanstalk は、2016 年 1 月 11 日から 2016 年 2 月 11 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

ウェブサーバー

Git

Node.js バージョン 2.0.6

Node.js を実行する 64 ビット Amazon Linux 2015.09 v2.0.6

2015.09

Node.js 4.2.3

0.12.9、0.10.41、0.8.28 もサポートします

NPM 2.14.7

nginx 1.8.0 または

Apache 2.4.16

Git 2.1.0

Elastic Beanstalk は、2015 年 12 月 18 日から 2016 年 1 月 11 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

ウェブサーバー

Git

Node.js バージョン 2.0.5

Node.js を実行する 64 ビット Amazon Linux 2015.09 v2.0.5

2015.09

Node.js 4.2.3

0.12.9、0.10.41、0.8.28 もサポートします

NPM 2.14.7

nginx 1.8.0 または

Apache 2.4.16

Git 2.1.0

Elastic Beanstalk は、2015 年 11 月 2 日から 2015 年 12 月 18 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

パッケージマネージャー

ウェブサーバー

Git

Node.js バージョン 2.0.4

Node.js を実行する 64 ビット Amazon Linux 2015.09 v2.0.4

2015.09

Node.js 4.2.1

0.12.7、0.12.6、0.10.39、0.10.38、0.10.31、0.8.28 もサポートします

NPM 2.14.7

nginx 1.8.0 または

Apache 2.4.16

Git 2.1.0

Elastic Beanstalk は、2015 年 9 月 18 日から 2015 年 11 月 2 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

プラットフォーム

ウェブサーバー

Git

Node.js バージョン 2.0.1

Node.js を実行する 64 ビット Amazon Linux 2015.03 v2.0.1

2015.03

Node.js 0.12.6

0.10.39、0.10.38、0.10.31、0.8.28 もサポートします

Nginx 1.6.2 または

Apache 2.4.12

Git 2.1.0

Elastic Beanstalk は、2015 年 8 月 11 日から 2015 年 9 月 18 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前 AMI プラットフォーム ウェブサーバー Git

Node.js バージョン 2.0.0

Node.js を実行する 64 ビット Amazon Linux 2015.03 v2.0.0

2015.03

Node.js 0.12.6

0.10.39、0.10.38、0.10.31、0.8.28 もサポートします

nginx 1.6.2 または

Apache 2.4.12

Git 2.1.0

Elastic Beanstalk は、2015 年 8 月 3 日から 2015 年 8 月 11 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前 AMI プラットフォーム ウェブサーバー Git

Node.js バージョン 1.4.6

Node.js を実行する 64 ビット Amazon Linux 2015.03 v1.4.6

2015.03

Node.js 0.12.6

0.10.39、0.10.38、0.10.31、0.8.28 もサポートします

nginx 1.6.2 または

Apache 2.4.12

Git 2.1.0

Elastic Beanstalk は、2015 年 7 月 7 日から 2015 年 8 月 3 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前 AMI プラットフォーム ウェブサーバー

Node.js バージョン 1.4.4

Node.js を実行する 64 ビット Amazon Linux 2015.03 v1.4.4

2015.03

Node.js 0.12.6

0.10.39、0.10.38、0.10.31、0.8.28 もサポートします

nginx 1.6.2 または

Apache 2.4.12

Elastic Beanstalk は、2015 年 6 月 15 日から 2015 年 7 月 7 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前 AMI プラットフォーム ウェブサーバー

Node.js バージョン 1.4.3

Node.js を実行する 64 ビット Amazon Linux 2015.03 v1.4.3

2015.03

Node.js 0.12.4

0.12.2、0.12.0、0.10.38、0.10.31、0.8.28 もサポートします

nginx 1.6.2 または

Apache 2.4.12

Elastic Beanstalk は、2015 年 27 月 5 日から 2015 年 6 月 15 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2015.03 v1.4.1

2015.03

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

0.10.38

0.12.0

0.12.2

nginx 1.6.2 または Apache 2.4.12

Elastic Beanstalk は、2015 年 26 月 22 日から 2015 年 5 月 4 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2015.03 v1.3.1

2015.03

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

0.10.38

0.12.0

0.12.2

nginx 1.6.2 または Apache 2.4.12

Elastic Beanstalk は、2015 年 4 月 8 日から 2015 年 4 月 21 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2015.03 v1.3.1

2015.03

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

0.10.38

0.12.0

0.12.2

nginx 1.6.2 または Apache 2.4.10

Elastic Beanstalk は、2015 年 3 月 24 日から 2015 年 4 月 7 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2014.09 v1.2.1

2014.09

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

0.12.0

nginx 1.6.2 または Apache 2.4.10

Elastic Beanstalk は、2015 年 2 月 17 日から 2015 年 3 月 23 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2014.09 v1.2.0

2014.09

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

nginx 1.6.2 または Apache 2.4.10

Elastic Beanstalk は、2015 年 1 月 28 日から 2015 年 2 月 16 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2014.09 v1.1.01

2014.09

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

nginx 1.6.2 または Apache 2.4.6

Node.js を実行する 32 ビット Amazon Linux 2014.03 v1.1.01

2014.03

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

nginx 1.4.7 または Apache 2.4.10

Node.js を実行する 64 ビット Amazon Linux 2014.03 v1.1.01

2014.03

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

nginx 1.4.7 または Apache 2.4.10

1CVE-2015-0235 Advisory (Ghost)

Elastic Beanstalk は、2014 年 10 月 16 日から 2015 年 1 月 27 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2014.09 v1.0.91

2014.09

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

nginx 1.6.2 または Apache 2.4.6

Node.js を実行する 32 ビット Amazon Linux 2014.03 v1.0.91

2014.03

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

nginx 1.6.2 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2014.03 v1.0.91

2014.03

JavaScript

0.8.26

0.8.28

0.10.21

0.10.26

0.10.31

nginx 1.6.2 または Apache 2.4.6

1CVE-2014-3566 アドバイザリ

Elastic Beanstalk は、2014 年 10 月 9 日から 2014 年 10 月 15 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2014.09 v1.0.8

2014.09

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

Elastic Beanstalk は、2014 年 9 月 24 日から 2014 年 10 月 8 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux 2014.03 v1.0.71

2014.03

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2014.03 v1.0.71

2014.03

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

1 CVE-2014-6271 アドバイザリおよび ALAS-2014-419

Elastic Beanstalk は、2014 年 6 月 30 日から 2014 年 9 月 23 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 64 ビット Amazon Linux 2014.03 v1.0.4

2014.03

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

Elastic Beanstalk は、2014 年 6 月 5 日から 2014 年 6 月 29 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux 2014.03 v1.0.31

2014.03

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2014.03 v1.0.31

2014.03

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

1 OpenSSL セキュリティアドバイザリ

Elastic Beanstalk は、2014 年 5 月 5 日から 2014 年 6 月 4 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux 2014.03 v1.0.2

2014.03

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2014.03 v1.0.2

2014.03

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.7 または Apache 2.4.6

Elastic Beanstalk は、2014 年 4 月 7 日から 2014 年 5 月 4 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux 2014.02 v1.0.11

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.3 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2014.02 v1.0.11

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.3 または Apache 2.4.6

Node.js を実行する 32 ビット Amazon Linux 2013.09 v1.0.11

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

0.10.21

nginx 1.4.3 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2013.09 v1.0.11

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

0.10.21

nginx 1.4.3 または Apache 2.4.6

1 openssl-1.0.1e-4.58.amzn1

Elastic Beanstalk は、2014 年 3 月 18 日から 2014 年 4 月 6 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux 2014.02

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.3 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2014.02

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.8.26

0.10.10

0.10.21

0.10.26

nginx 1.4.3 または Apache 2.4.6

Node.js を実行する 32 ビット Amazon Linux 2013.09

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

0.10.21

nginx 1.4.3 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2013.09

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

0.10.21

nginx 1.4.3 または Apache 2.4.6

Elastic Beanstalk は、2013 年 10 月 29 日から 2014 年 3 月 17 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux 2013.09

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

0.10.21

nginx 1.4.3 または Apache 2.4.6

Node.js を実行する 64 ビット Amazon Linux 2013.09

2013.09

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

0.10.21

nginx 1.4.3 または Apache 2.4.6

Elastic Beanstalk は、2013 年 8 月 15 日から 2013 年 10 月 28 日までに作成された Node.js 環境については、次のプラットフォーム設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux

2013.03

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

nginx 1.2.9 または Apache 2.4.4

Node.js を実行する 64 ビット Amazon Linux

2013.03

JavaScript

0.8.6~0.8.21

0.8.24

0.10.10

nginx 1.2.9 または Apache 2.4.4

Elastic Beanstalk は、2013 年 8 月 15 日より前に Node.js コンテナで作成された環境に対しては、以下の設定をサポートしています。

Node.js 設定

名前 AMI 言語 Node.js バージョン ウェブサーバー

Node.js を実行する 32 ビット Amazon Linux 2012.09

2012.09

JavaScript

0.8.6~0.8.21

0.8.24

nginx 1.2.6 または Apache 2.4.3

Node.js を実行する 64 ビット Amazon Linux 2012.09

2012.09

JavaScript

0.8.6~0.8.21

0.8.24

nginx 1.2.6 または Apache 2.4.3