メニュー
AWS Elastic Beanstalk
開発者ガイド (API Version 2010-12-01)

PHP プラットフォーム履歴

このページには、AWS Elastic Beanstalk の PHP プラットフォームの以前のバージョンと、各バージョンが最新であった日付が一覧表示されます。環境を起動するのに使用したプラットフォームバージョンは、最新でなくなった後もそのまま使用できます。

Elastic Beanstalk でサポートされる各プラットフォームの最新バージョンについては、事前構成済みプラットフォームのページを参照してください。最近のリリースに関する詳細なリリースノートは、aws.amazon.com/releasenotes で参照できます。

Elastic Beanstalk は、2017 年 1 月 28 日から 2017 年 3 月 7 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 7.0 バージョン 2.3.1

PHP 7.0 を実行する 64 ビット Amazon Linux 2016.09 v2.3.1

2016.09.0

PHP 7.0.11

1.2.0

Apache 2.4.23

PHP 5.6 バージョン 2.3.1

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.09 v2.3.1

2016.09.0

PHP 5.6.26

1.2.0

Apache 2.4.23

PHP 5.5 バージョン 2.3.1

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.09 v2.3.1

2016.09.0

PHP 5.5.38

1.2.0

Apache 2.4.23

PHP 5.4 バージョン 2.3.1

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.09 v2.3.1

2016.09.0

PHP 5.4.45

1.2.0

Apache 2.4.23

Elastic Beanstalk は、2016 年 12 月 22 日から 2017 年 3 月 7 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 7.0 バージョン 2.3.0

PHP 7.0 を実行する 64 ビット Amazon Linux 2016.09 v2.3.0

2016.09.0

PHP 7.0.11

1.2.0

Apache 2.4.23

PHP 5.6 バージョン 2.3.0

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.09 v2.3.0

2016.09.0

PHP 5.6.26

1.2.0

Apache 2.4.23

PHP 5.5 バージョン 2.3.0

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.09 v2.3.0

2016.09.0

PHP 5.5.38

1.2.0

Apache 2.4.23

PHP 5.4 バージョン 2.3.0

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.09 v2.3.0

2016.09.0

PHP 5.4.45

1.2.0

Apache 2.4.23

Elastic Beanstalk は、2016 年 10 月 28 日から 2016 年 12 月 21 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 7.0 バージョン 2.2.0

PHP 7.0 を実行する 64 ビット Amazon Linux 2016.09 v2.2.0

2016.09.0

PHP 7.0.11

1.2.0

Apache 2.4.23

PHP 5.6 バージョン 2.2.0

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.09 v2.2.0

2016.09.0

PHP 5.6.26

1.2.0

Apache 2.4.23

PHP 5.5 バージョン 2.2.0

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.09 v2.2.0

2016.09.0

PHP 5.5.38

1.2.0

Apache 2.4.23

PHP 5.4 バージョン 2.2.0

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.09 v2.2.0

2016.09.0

PHP 5.4.45

1.2.0

Apache 2.4.23

Elastic Beanstalk は、2016 年 9 月 6 日から 2016 年 10 月 27 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 7.0 バージョン 2.1.7

PHP 7.0 を実行する 64 ビット Amazon Linux 2016.03 v2.1.7

2016.03.3

PHP 7.0.9

1.2.0

Apache 2.4.23

PHP 5.6 バージョン 2.1.7

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.7

2016.03.3

PHP 5.6.25

1.2.0

Apache 2.4.23

PHP 5.5 バージョン 2.1.7

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.7

2016.03.3

PHP 5.5.38

1.2.0

Apache 2.4.23

PHP 5.4 バージョン 2.1.7

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.7

2016.03.3

PHP 5.4.45

1.2.0

Apache 2.4.23

Elastic Beanstalk は、2016 年 8 月 24 日から 2016 年 9 月 6 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 7.0 バージョン 2.1.6

PHP 7.0 を実行する 64 ビット Amazon Linux 2016.03 v2.1.6

2016.03.3

PHP 7.0.9

1.2.0

Apache 2.4.23

PHP 5.6 バージョン 2.1.6

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.6

2016.03.3

PHP 5.6.24

1.2.0

Apache 2.4.23

PHP 5.5 バージョン 2.1.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.6

2016.03.3

PHP 5.5.38

1.2.0

Apache 2.4.23

PHP 5.4 バージョン 2.1.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.6

2016.03.3

PHP 5.4.45

1.2.0

Apache 2.4.23

Elastic Beanstalk は、2016 年 8 月 8 日から 2016 年 8 月 24 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 7.0 バージョン 2.1.5

PHP 7.0 を実行する 64 ビット Amazon Linux 2016.03 v2.1.5

2016.03.2

PHP 7.0.9

1.2.0

Apache 2.4.23

PHP 5.6 バージョン 2.1.5

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.5

2016.03.2

PHP 5.6.24

1.2.0

Apache 2.4.23

PHP 5.5 バージョン 2.1.5

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.5

2016.03.2

PHP 5.5.38

1.2.0

Apache 2.4.23

PHP 5.4 バージョン 2.1.5

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.5

2016.03.2

PHP 5.4.45

1.2.0

Apache 2.4.23

Elastic Beanstalk は、2016 年 7 月 18 日から 2016 年 8 月 8 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 5.6 バージョン 2.1.4

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.4

2016.03.2

PHP 5.6.22

1.1.2

Apache 2.4.18

PHP 5.5 バージョン 2.1.4

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.4

2016.03.2

PHP 5.5.36

1.1.2

Apache 2.4.18

PHP 5.4 バージョン 2.1.4

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.4

2016.03.2

PHP 5.4.45

1.1.2

Apache 2.4.18

Elastic Beanstalk は、2016 年 6 月 26 日から 2016 年 7 月 18 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 5.6 バージョン 2.1.3

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.3

2016.03.2

PHP 5.6.22

1.1.2

Apache 2.4.18

PHP 5.5 バージョン 2.1.3

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.3

2016.03.2

PHP 5.5.36

1.1.2

Apache 2.4.18

PHP 5.4 バージョン 2.1.3

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.3

2016.03.2

PHP 5.4.45

1.1.2

Apache 2.4.18

Elastic Beanstalk は、2016 年 5 月 13 日から 2016 年 6 月 26 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 5.6 バージョン 2.1.2

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.2

2016.03

PHP 5.6.21

1.1.0

Apache 2.4.18

PHP 5.5 バージョン 2.1.2

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.2

2016.03

PHP 5.5.35

1.1.0

Apache 2.4.18

PHP 5.4 バージョン 2.1.2

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.2

2016.03

PHP 5.4.45

1.1.0

Apache 2.4.18

Elastic Beanstalk では、2016 年 5 月 9 日から 2016 年 5 月 13 日までに作成された PHP 環境に対して以下のプラットフォーム設定がサポートされています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 5.6 バージョン 2.1.1

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.1

2016.03

PHP 5.6.21

1.1.0-RC

Apache 2.4.18

PHP 5.5 バージョン 2.1.1

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.1

2016.03

PHP 5.5.35

1.1.0-RC

Apache 2.4.18

PHP 5.4 バージョン 2.1.1

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.1

2016.03

PHP 5.4.45

1.1.0-RC

Apache 2.4.18

Elastic Beanstalk では、2016 年 4 月 7 日から 2016 年 5 月 9 日までに作成された PHP 環境に対して以下のプラットフォーム設定がサポートされています。

設定およびソリューションスタックの名前

AMI

言語

Composer

プロキシサーバー

PHP 5.6 バージョン 2.1.0

PHP 5.6 を実行する 64 ビット Amazon Linux 2016.03 v2.1.0

2016.03

PHP 5.6.17

1.0.0-alpha11

Apache 2.4.18

PHP 5.5 バージョン 2.1.0

PHP 5.5 を実行する 64 ビット Amazon Linux 2016.03 v2.1.0

2016.03

PHP 5.5.31

1.0.0-alpha11

Apache 2.4.18

PHP 5.4 バージョン 2.1.0

PHP 5.4 を実行する 64 ビット Amazon Linux 2016.03 v2.1.0

2016.03

PHP 5.4.45

1.0.0-alpha11

Apache 2.4.18

Elastic Beanstalk は、2016 年 2 月 26 日から 2016 年 4 月 7 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

ウェブサーバー

PHP 5.6 バージョン 2.0.8

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.09 v2.0.8

2015.09

PHP 5.6.17

1.0.0-alpha11

Apache 2.4.16

PHP 5.5 バージョン 2.0.8

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.09 v2.0.8

2015.09

PHP 5.5.31

1.0.0-alpha11

Apache 2.4.16

PHP 5.4 バージョン 2.0.8

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.09 v2.0.8

2015.09

PHP 5.4.45

1.0.0-alpha11

Apache 2.4.16

Elastic Beanstalk は、2016 年 2 月 11 日から 2016 年 2 月 26 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

ウェブサーバー

PHP 5.6 バージョン 2.0.7

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.09 v2.0.7

2015.09

PHP 5.6.17

1.0.0-alpha11

Apache 2.4.16

PHP 5.5 バージョン 2.0.7

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.09 v2.0.7

2015.09

PHP 5.5.31

1.0.0-alpha11

Apache 2.4.16

PHP 5.4 バージョン 2.0.7

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.09 v2.0.7

2015.09

PHP 5.4.45

1.0.0-alpha11

Apache 2.4.16

Elastic Beanstalk は、2016 年 1 月 11 日から 2016 年 2 月 11 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

ウェブサーバー

PHP 5.6 バージョン 2.0.6

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.09 v2.0.6

2015.09

PHP 5.6.13

1.0.0-alpha10

Apache 2.4.16

PHP 5.5 バージョン 2.0.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.09 v2.0.6

2015.09

PHP 5.5.29

1.0.0-alpha10

Apache 2.4.16

PHP 5.4 バージョン 2.0.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.09 v2.0.6

2015.09

PHP 5.4.45

1.0.0-alpha10

Apache 2.4.16

Elastic Beanstalk は、2015 年 11 月 2 日から 2016 年 1 月 11 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

ウェブサーバー

PHP 5.6 バージョン 2.0.4

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.09 v2.0.4

2015.09

PHP 5.6.13

1.0.0-alpha10

Apache 2.4.16

PHP 5.5 バージョン 2.0.4

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.09 v2.0.4

2015.09

PHP 5.5.29

1.0.0-alpha10

Apache 2.4.16

PHP 5.4 バージョン 2.0.4

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.09 v2.0.4

2015.09

PHP 5.4.45

1.0.0-alpha10

Apache 2.4.16

Elastic Beanstalk は、2015 年 9 月 18 日から 2015 年 11 月 2 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前

AMI

言語

Composer

ウェブサーバー

PHP 5.6 バージョン 2.0.1

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.03 v2.0.1

2015.03

PHP 5.6.9

1.0.0-alpha10

Apache 2.4.12

PHP 5.5 バージョン 2.0.1

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v2.0.1

2015.03

PHP 5.5.25

1.0.0-alpha10

Apache 2.4.12

PHP 5.4 バージョン 2.0.1

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v2.0.1

2015.03

PHP 5.4.41

1.0.0-alpha10

Apache 2.4.12

Elastic Beanstalk は、2015 年 8 月 11 日から 2015 年 9 月 18 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前 AMI 言語 Composer ウェブサーバー

PHP 5.6 バージョン 2.0.0

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.03 v2.0.0

2015.03

PHP 5.6.9

1.0.0-alpha10

Apache 2.4.12

PHP 5.5 バージョン 2.0.0

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v2.0.0

2015.03

PHP 5.5.25

1.0.0-alpha10

Apache 2.4.12

PHP 5.4 バージョン 2.0.0

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v2.0.0

2015.03

PHP 5.4.41

1.0.0-alpha10

Apache 2.4.12

Elastic Beanstalk は、2015 年 8 月 3 日から 2015 年 8 月 11 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前 AMI 言語 Composer ウェブサーバー

PHP 5.6 バージョン 1.4.6

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.03 v1.4.6

2015.03

PHP 5.6.9

1.0.0-alpha10

Apache 2.4.12

PHP 5.5 バージョン 1.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v1.4.6

2015.03

PHP 5.5.25

1.0.0-alpha10

Apache 2.4.12

PHP 5.4 バージョン 1.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v1.4.6

2015.03

PHP 5.4.41

1.0.0-alpha10

Apache 2.4.12

Elastic Beanstalk は、2015 年 6 月 15 日から 2015 年 8 月 3 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

設定およびソリューションスタックの名前 AMI 言語 Composer ウェブサーバー

PHP 5.6 バージョン 1.4.3

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.03 v1.4.3

2015.03

PHP 5.6.9

1.0.0-alpha10

Apache 2.4.12

PHP 5.5 バージョン 1.4.3

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v1.4.3

2015.03

PHP 5.5.25

1.0.0-alpha10

Apache 2.4.12

PHP 5.4 バージョン 1.4.3

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v1.4.3

2015.03

PHP 5.4.41

1.0.0-alpha10

Apache 2.4.12

Elastic Beanstalk は、2015 年 5 月 29 日から 2015 年 6 月 15 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP 設定

名前 AMI 言語 ウェブサーバー Composer

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.03 v1.4.2

2015.03

PHP 5.6.8

Apache 2.4.12

1.0.0-alpha10

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v1.4.2

2015.03

PHP 5.5.24

Apache 2.4.12

1.0.0-alpha10

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v1.4.2

2015.03

PHP 5.4.40

Apache 2.4.12

1.0.0-alpha10

Elastic Beanstalk は、2015 年 5 月 27 日から 2015 年 5 月 28 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.03 v1.4.1

2015.03

PHP 5.6.8

Apache 2.4.12

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v1.4.1

2015.03

PHP 5.5.24

Apache 2.4.12

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v1.4.1

2015.03

PHP 5.4.40

Apache 2.4.12

Elastic Beanstalk は、2015 年 5 月 1 日から 2015 年 5 月 26 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.6 を実行する 64 ビット Amazon Linux 2015.03 v1.3.2

2015.03

PHP 5.6.8

Apache 2.4.12

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v1.3.2

2015.03

PHP 5.5.24

Apache 2.4.12

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v1.3.2

2015.03

PHP 5.4.40

Apache 2.4.12

Elastic Beanstalk は、2015 年 4 月 22 日から 2015 年 4 月 30 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v1.3.1

2015.03

PHP 5.5.22

Apache 2.4.12

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v1.3.1

2015.03

PHP 5.4.38

Apache 2.4.12

Elastic Beanstalk は、2015 年 4 月 8 日から 2015 年 4 月 21 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 64 ビット Amazon Linux 2015.03 v1.3.0

2015.03

PHP 5.5.22

Apache 2.4.12

PHP 5.4 を実行する 64 ビット Amazon Linux 2015.03 v1.3.0

2015.03

PHP 5.4.38

Apache 2.4.12

Elastic Beanstalk は、2015 年 2 月 17 日から 2015 年 4 月 7 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.09 v1.2.0

2014.09

PHP 5.5.20

Apache 2.4.10

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.09 v1.2.0

2014.09

PHP 5.4.36

Apache 2.4.10

Elastic Beanstalk は、2015 年 1 月 28 日から 2015 年 2 月 16 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.09 v1.1.01

2014.09

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.09 v1.1.01

2014.09

PHP 5.4.20

Apache 2.4.6

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.03 v1.1.01

2014.03

PHP 5.5.14

Apache 2.4.10

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.03 v1.1.01

2014.03

PHP 5.5.14

Apache 2.4.10

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.03 v1.1.01

2014.03

PHP 5.4.30

Apache 2.4.10

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.03 v1.1.01

2014.03

PHP 5.4.30

Apache 2.4.10

1CVE-2015-0235 Advisory (Ghost)

Elastic Beanstalk は、2014 年 10 月 16 日から 2015 年 1 月 27 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.09 v1.0.91

2014.09

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.09 v1.0.91

2014.09

PHP 5.4.20

Apache 2.4.6

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.03 v1.0.91

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.03 v1.0.91

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.03 v1.0.91

2014.03

PHP 5.4.20

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.03 v1.0.91

2014.03

PHP 5.4.20

Apache 2.4.6

1CVE-2014-3566 アドバイザリ

Elastic Beanstalk は、2014 年 10 月 9 日から 2014 年 10 月 15 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.09 v1.0.8

2014.09

PHP 5.5.7

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.09 v1.0.8

2014.09

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.09 v1.0.8

2014.09

PHP 5.4.20

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.09 v1.0.8

2014.09

PHP 5.4.20

Apache 2.4.6

Elastic Beanstalk は、2014 年 9 月 24 日から 2014 年 10 月 8 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.03 v1.0.71

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.03 v1.0.71

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.03 v1.0.71

2014.03

PHP 5.4.20

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.03 v1.0.71

2014.03

PHP 5.4.20

Apache 2.4.6

1 CVE-2014-6271 アドバイザリおよび ALAS-2014-419

Elastic Beanstalk は、2014 年 6 月 30 日から 2014 年 9 月 23 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.03 v1.0.4

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.03 v1.0.4

2014.03

PHP 5.4.20

Apache 2.4.6

Elastic Beanstalk は、2014 年 6 月 5 日から 2014 年 6 月 29 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.03 v1.0.31

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.03 v1.0.31

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.03 v1.0.31

2014.03

PHP 5.4.20

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.03 v1.0.31

2014.03

PHP 5.4.20

Apache 2.4.6

1 OpenSSL セキュリティアドバイザリ

Elastic Beanstalk は、2014 年 5 月 5 日から 2014 年 6 月 4 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.03 v1.0.2

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.03 v1.0.2

2014.03

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.03 v1.0.2

2014.03

PHP 5.4.20

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.03 v1.0.2

2014.03

PHP 5.4.20

Apache 2.4.6

Elastic Beanstalk は、2014 年 4 月 7 日から 2014 年 5 月 4 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.02 v1.0.11

2013.09

PHP 5.5.7

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.02 v1.0.11

2013.09

PHP 5.5.7

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.02 v1.0.11

2013.09

PHP 5.4.20

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.02 v1.0.11

2013.09

PHP 5.4.20

Apache 2.4.6

PHP 5.5 を実行する 32 ビット Amazon Linux 2013.09 v1.0.11

2013.09

PHP 5.5

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2013.09 v1.0.11

2013.09

PHP 5.5

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2013.09 v1.0.11

2013.09

PHP 5.4

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2013.09 v1.0.11

2013.09

PHP 5.4

Apache 2.4.6

PHP 5.3 を実行する 32 ビット Amazon Linux

2013.03

PHP 5.3

Apache 2.4.6

PHP 5.3 を実行する 64 ビット Amazon Linux

2013.03

PHP 5.3

Apache 2.4.6

1 openssl-1.0.1e-4.58.amzn1

Elastic Beanstalk は、2014 年 3 月 18 日から 2014 年 4 月 6 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 32 ビット Amazon Linux 2014.02

2013.09

PHP 5.5.7

Apache 2.2.26

PHP 5.5 を実行する 64 ビット Amazon Linux 2014.02

2013.09

PHP 5.5.7

Apache 2.2.26

PHP 5.4 を実行する 32 ビット Amazon Linux 2014.02

2013.09

PHP 5.4.20

Apache 2.2.26

PHP 5.4 を実行する 64 ビット Amazon Linux 2014.02

2013.09

PHP 5.4.20

Apache 2.2.26

PHP 5.5 を実行する 32 ビット Amazon Linux 2013.09

2013.09

PHP 5.5

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2013.09

2013.09

PHP 5.5

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2013.09

2013.09

PHP 5.4

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2013.09

2013.09

PHP 5.4

Apache 2.4.6

PHP 5.3 を実行する 32 ビット Amazon Linux

2013.03

PHP 5.3

Apache 2.4.6

PHP 5.3 を実行する 64 ビット Amazon Linux

2013.03

PHP 5.3

Apache 2.4.6

Elastic Beanstalk は、2013 年 10 月 30 日から 2014 年 3 月 17 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.5 を実行する 32 ビット Amazon Linux 2013.09

2013.09

PHP 5.5

Apache 2.4.6

PHP 5.5 を実行する 64 ビット Amazon Linux 2013.09

2013.09

PHP 5.5

Apache 2.4.6

PHP 5.4 を実行する 32 ビット Amazon Linux 2013.09

2013.09

PHP 5.4

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux 2013.09

2013.09

PHP 5.4

Apache 2.4.6

PHP 5.3 を実行する 32 ビット Amazon Linux

2013.03

PHP 5.3

Apache 2.4.6

PHP 5.3 を実行する 64 ビット Amazon Linux

2013.03

PHP 5.3

Apache 2.4.6

Elastic Beanstalk は、2013 年 8 月 29 日から 2013 年 10 月 29 日までに作成された PHP 環境については、次のプラットフォーム設定をサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.4 を実行する 32 ビット Amazon Linux

2013.03

PHP 5.4

Apache 2.4.6

PHP 5.4 を実行する 64 ビット Amazon Linux

2013.03

PHP 5.4

Apache 2.4.6

Elastic Beanstalk は、2013 年 8 月 29 日より前に PHP コンテナで作成された環境に対しては、以下のコンテナタイプをサポートしています。

PHP コンテナタイプ

名前 AMI 言語 ウェブサーバー

PHP 5.4 を実行する 32 ビット Amazon Linux 2012.09

2012.09

PHP 5.4

Apache 2.4.3

PHP 5.4 を実行する 64 ビット Amazon Linux 2012.09

2012.09

PHP 5.4

Apache 2.4.3

PHP 5.3 を実行する 32 ビット Amazon Linux 2012.09

2012.09

PHP 5.3

Apache 2.4.3

PHP 5.3 を実行する 64 ビット Amazon Linux 2012.09

2012.09

PHP 5.3

Apache 2.4.3