메뉴
AWS Command Line Interface
사용 설명서

AWS Command Line Interface 설치

Linux, Windows및 macOS에서 AWS CLI를 배포하는 기본 방법은 pip입니다. 이는 Python 패키지 및 해당 종속 항목을 쉽게 설치, 업그레이드 및 제거하는 방법을 제공하는 Python용 패키지 관리자입니다.

현재 AWS CLI 버전

AWS CLI는 새로운 서비스 및 명령에 대한 지원으로 자주 업데이트됩니다. 최신 버전을 사용하는지 확인하려면 GitHub의 릴리스 페이지를 참조하십시오.

요구 사항

  • Python 2 버전 2.6.5+ 또는 Python 3 버전 3.3+

  • Windows, Linux, macOS, or Unix

참고

Python 구 버전은 일부 AWS 서비스를 지원하지 않을 수 있습니다. AWS CLI를 설치하거나 사용할 때 InsecurePlatformWarning 또는 운영 중단 공지가 표시되는 경우, 최신 버전으로 업데이트하십시오.

pip 및 지원되는 버전의 Python이 이미 있는 경우 다음 명령을 사용하여 AWS CLI를 설치할 수 있습니다.

$ pip install awscli --upgrade --user

--upgrade 옵션은 pip에게 이미 설치된 요구 사항을 업그레이드하라고 지시합니다. --user 옵션은 운영 체제에서 사용한 라이브러리를 수정하지 않도록 사용자 디렉터리의 하위 디렉터리에 프로그램을 설치할 것을 pip에게 지시합니다.

pip를 사용하여 AWS CLI를 설치할 때 문제가 발생할 경우 가상 환경에 AWS CLI를 설치하여 도구 및 해당 종속 항목을 격리하거나 일반적으로 사용하는 것과 다른 버전의 Python을 사용할 수 있습니다.

독립 실행형 설치 관리자

Linux, macOS, or Unix에서 오프라인 또는 자동 설치하는 경우 번들 설치 관리자를 사용하십시오. 이 번들 설치 관리자에는 AWS CLI 및 해당 종속 항목과 대신 설치를 수행하는 셸 스크립트가 포함되어 있습니다.

Windows에서는 MSI 설치 관리자를 사용할 수도 있습니다. 두 방법 모두 최초 설치는 간단하지만, 대신 새 버전의 AWS CLI가 릴리스되었을 경우 업그레이드는 더 어렵습니다.

AWS CLI를 설치한 후 실행 파일에 대한 경로를 PATH 변수에 추가해야 할 수 있습니다. 플랫폼별 지침은 다음 주제를 참조하십시오.

aws --version을 실행하여 AWS CLI가 올바르게 설치되었는지 확인합니다.

$ aws --version
aws-cli/1.11.84 Python/3.5.2 Linux/4.4.0-59-generic botocore/1.5.47

AWS CLI는 정기적으로 업데이트되어 새로운 서비스 및 명령에 대한 지원을 추가합니다. 최신 버전의 AWS CLI로 업데이트하려면 설치 명령을 다시 실행합니다.

$ pip install awscli --upgrade --user

AWS CLI를 제거해야 하는 경우 pip uninstall을 사용합니다.

$ pip uninstall awscli

Python 및 pip가 없는 경우 운영 체제에 해당하는 절차를 사용합니다.