You are viewing documentation for version 3 of the AWS SDK for Ruby. Version 2 documentation can be found here.

Class: Aws::IAM::Types::SetDefaultPolicyVersionRequest

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-iam/lib/aws-sdk-iam/types.rb

Overview

Note:

When making an API call, you may pass SetDefaultPolicyVersionRequest data as a hash:

{
  policy_arn: "arnType", # required
  version_id: "policyVersionIdType", # required
}

Instance Attribute Summary collapse

Instance Attribute Details

#policy_arnString

The Amazon Resource Name (ARN) of the IAM policy whose default version you want to set.

For more information about ARNs, see Amazon Resource Names (ARNs) and AWS Service Namespaces in the AWS General Reference.

Returns:

  • (String)


7325
7326
7327
7328
7329
# File 'gems/aws-sdk-iam/lib/aws-sdk-iam/types.rb', line 7325

class SetDefaultPolicyVersionRequest < Struct.new(
  :policy_arn,
  :version_id)
  include Aws::Structure
end

#version_idString

The version of the policy to set as the default (operative) version.

For more information about managed policy versions, see Versioning for Managed Policies in the IAM User Guide.

Returns:

  • (String)


7325
7326
7327
7328
7329
# File 'gems/aws-sdk-iam/lib/aws-sdk-iam/types.rb', line 7325

class SetDefaultPolicyVersionRequest < Struct.new(
  :policy_arn,
  :version_id)
  include Aws::Structure
end