You are viewing documentation for version 3 of the AWS SDK for Ruby. Version 2 documentation can be found here.

Class: Aws::SSM::Types::GetPatchBaselineForPatchGroupRequest

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-ssm/lib/aws-sdk-ssm/types.rb

Overview

Note:

When making an API call, you may pass GetPatchBaselineForPatchGroupRequest data as a hash:

{
  patch_group: "PatchGroup", # required
  operating_system: "WINDOWS", # accepts WINDOWS, AMAZON_LINUX, UBUNTU, REDHAT_ENTERPRISE_LINUX
}

Instance Attribute Summary collapse

Instance Attribute Details

#operating_systemString

Returns he operating system rule specified for patch groups using the patch baseline.

Returns:

  • (String)


5172
5173
5174
5175
5176
# File 'gems/aws-sdk-ssm/lib/aws-sdk-ssm/types.rb', line 5172

class GetPatchBaselineForPatchGroupRequest < Struct.new(
  :patch_group,
  :operating_system)
  include Aws::Structure
end

#patch_groupString

The name of the patch group whose patch baseline should be retrieved.

Returns:

  • (String)


5172
5173
5174
5175
5176
# File 'gems/aws-sdk-ssm/lib/aws-sdk-ssm/types.rb', line 5172

class GetPatchBaselineForPatchGroupRequest < Struct.new(
  :patch_group,
  :operating_system)
  include Aws::Structure
end