AWS SDK Version 2 for .NET
API Reference

AWS services or capabilities described in AWS Documentation may vary by region/location. Click Getting Started with Amazon AWS to see specific differences applicable to the China (Beijing) Region.

.NET Framework 3.5
 
Deletes the specified Lambda function code and configuration.

If you are using the versioning feature and you don't specify a function version in your DeleteFunction request, AWS Lambda will delete the function, including all its versions, and any aliases pointing to the function versions. To delete a specific function version, you must provide the function version via the Qualifier parameter. For information about function versioning, see AWS Lambda Function Versioning and Aliases.

When you delete a function the associated resource policy is also deleted. You will need to delete the event source mappings explicitly.

This operation requires permission for the lambda:DeleteFunction action.

Namespace: Amazon.Lambda
Assembly: AWSSDK.dll
Version: (assembly version)

Syntax

C#
public virtual DeleteFunctionResponse DeleteFunction(
         DeleteFunctionRequest request
)

Parameters

request
Type: Amazon.Lambda.Model.DeleteFunctionRequest

Container for the necessary parameters to execute the DeleteFunction service method.

Return Value
Type: Amazon.Lambda.Model.DeleteFunctionResponse
The response from the DeleteFunction service method, as returned by Lambda.

Exceptions

ExceptionCondition
InvalidParameterValueException One of the parameters in the request is invalid. For example, if you provided an IAM role for AWS Lambda to assume in the CreateFunction or the UpdateFunctionConfiguration API, that AWS Lambda is unable to assume you will get this exception.
ResourceConflictException The resource already exists.
ResourceNotFoundException The resource (for example, a Lambda function or access policy statement) specified in the request does not exist.
ServiceException The AWS Lambda service encountered an internal error.
TooManyRequestsException

Version Information

.NET Framework:
Supported in: 4.5, 4.0, 3.5