AWS SDK Version 2 for .NET
API Reference

AWS services or capabilities described in AWS Documentation may vary by region/location. Click Getting Started with Amazon AWS to see specific differences applicable to the China (Beijing) Region.

.NET Framework 3.5
 
Associates the specified SSM document with the specified instances.

When you associate an SSM document with an instance, the configuration agent on the instance processes the document and configures the instance as specified.

If you associate a document with an instance that already has an associated document, the system throws the AssociationAlreadyExists exception.

Namespace: Amazon.SimpleSystemsManagement
Assembly: AWSSDK.dll
Version: (assembly version)

Syntax

C#
public abstract CreateAssociationBatchResponse CreateAssociationBatch(
         CreateAssociationBatchRequest request
)

Parameters

request
Type: Amazon.SimpleSystemsManagement.Model.CreateAssociationBatchRequest

Container for the necessary parameters to execute the CreateAssociationBatch service method.

Return Value
Type: Amazon.SimpleSystemsManagement.Model.CreateAssociationBatchResponse
The response from the CreateAssociationBatch service method, as returned by SimpleSystemsManagement.

Exceptions

ExceptionCondition
AssociationLimitExceededException You can have at most 2,000 active associations.
DuplicateInstanceIdException You cannot specify an instance ID in more than one association.
InternalServerErrorException An error occurred on the server side.
InvalidDocumentException The specified document does not exist.
InvalidInstanceIdException The instance is not in valid state. Valid states are: Running, Pending, Stopped, Stopping. Invalid states are: Shutting-down and Terminated.
InvalidParametersException You must specify values for all required parameters in the SSM document. You can only supply values to parameters defined in the SSM document.
UnsupportedPlatformTypeException The document does not support the platform type of the given instance ID(s).

Version Information

.NET Framework:
Supported in: 4.5, 4.0, 3.5