AWS SDK Version 3 for .NET
API Reference

AWS services or capabilities described in AWS Documentation may vary by region/location. Click Getting Started with Amazon AWS to see specific differences applicable to the China (Beijing) Region.

Creates or updates a policy for an Auto Scaling group. To update an existing policy, use the existing policy name and set the parameters you want to change. Any existing parameter not changed in an update to an existing policy is not changed in this update request.

If you exceed your maximum limit of step adjustments, which by default is 20 per region, the call fails. For information about updating this limit, see AWS Service Limits in the Amazon Web Services General Reference.

Note:

For PCL this operation is only available in asynchronous form. Please refer to PutScalingPolicyAsync.

Namespace: Amazon.AutoScaling
Assembly: AWSSDK.AutoScaling.dll
Version: 3.x.y.z

Syntax

C#
public virtual PutScalingPolicyResponse PutScalingPolicy(
         PutScalingPolicyRequest request
)
Parameters
request
Type: Amazon.AutoScaling.Model.PutScalingPolicyRequest

Container for the necessary parameters to execute the PutScalingPolicy service method.

Return Value
The response from the PutScalingPolicy service method, as returned by AutoScaling.

Exceptions

ExceptionCondition
LimitExceededException You have already reached a limit for your Auto Scaling resources (for example, groups, launch configurations, or lifecycle hooks). For more information, see DescribeAccountLimits.
ResourceContentionException You already have a pending update to an Auto Scaling resource (for example, a group, instance, or load balancer).

Examples

This example adds the specified policy to the specified Auto Scaling group.

To add a scaling policy to an Auto Scaling group


var response = client.PutScalingPolicy(new PutScalingPolicyRequest 
{
    AdjustmentType = "ChangeInCapacity",
    AutoScalingGroupName = "my-auto-scaling-group",
    PolicyName = "ScaleIn",
    ScalingAdjustment = -1
});

string policyARN = response.PolicyARN;

            

Version Information

.NET Framework:
Supported in: 4.5, 4.0, 3.5

Portable Class Library:
Supported in: Windows Store Apps
Supported in: Windows Phone 8.1
Supported in: Xamarin Android
Supported in: Xamarin iOS (Unified)
Supported in: Xamarin.Forms

See Also