AWS SDK for .NET Documentation
AmiVersion Property
AmazonAmazon.ElasticMapReduce.ModelRunJobFlowRequestAmiVersion Did this page help you?   Yes   No    Tell us about it...
Gets and sets the property AmiVersion.

The version of the Amazon Machine Image (AMI) to use when launching Amazon EC2 instances in the job flow. The following values are valid:

If the AMI supports multiple versions of Hadoop (for example, AMI 1.0 supports both Hadoop 0.18 and 0.20) you can use the JobFlowInstancesConfig

CopyC#
HadoopVersion
parameter to modify the version of Hadoop from the defaults shown above.

For details about the AMI versions currently supported by Amazon Elastic MapReduce, go to AMI Versions Supported in Elastic MapReduce in the Amazon Elastic MapReduce Developer's Guide.

Declaration Syntax
C#
public string AmiVersion { get; set; }

Assembly: AWSSDK (Module: AWSSDK) Version: 1.5.60.0 (1.5.60.0)