You are viewing documentation for version 2 of the AWS SDK for Ruby. Version 3 documentation can be found here.

Class: Aws::RDS::Types::UpgradeTarget

Inherits:
Struct
  • Object
show all
Defined in:
(unknown)

Overview

The version of the database engine that a DB instance can be upgraded to.

Instance Attribute Summary collapse

Instance Attribute Details

#auto_upgradeBoolean

A value that indicates whether the target version will be applied to any source DB instances that have AutoMinorVersionUpgrade set to true.

Returns:

  • (Boolean)

    A value that indicates whether the target version will be applied to any source DB instances that have AutoMinorVersionUpgrade set to true.

#descriptionString

The version of the database engine that a DB instance can be upgraded to.

Returns:

  • (String)

    The version of the database engine that a DB instance can be upgraded to.

#engineString

The name of the upgrade target database engine.

Returns:

  • (String)

    The name of the upgrade target database engine.

#engine_versionString

The version number of the upgrade target database engine.

Returns:

  • (String)

    The version number of the upgrade target database engine.

#is_major_version_upgradeBoolean

A value that indicates whether a database engine will be upgraded to a major version.

Returns:

  • (Boolean)

    A value that indicates whether a database engine will be upgraded to a major version.