You are viewing documentation for version 2 of the AWS SDK for Ruby. Version 3 documentation can be found here.

Class: Aws::SSM::Types::GetPatchBaselineForPatchGroupRequest

Inherits:
Struct
  • Object
show all
Defined in:
(unknown)

Overview

Note:

When passing GetPatchBaselineForPatchGroupRequest as input to an Aws::Client method, you can use a vanilla Hash:

{
  patch_group: "PatchGroup", # required
  operating_system: "WINDOWS", # accepts WINDOWS, AMAZON_LINUX, UBUNTU, REDHAT_ENTERPRISE_LINUX
}

Instance Attribute Summary collapse

Instance Attribute Details

#operating_systemString

Returns he operating system rule specified for patch groups using the patch baseline.

Possible values:

  • WINDOWS
  • AMAZON_LINUX
  • UBUNTU
  • REDHAT_ENTERPRISE_LINUX

Returns:

  • (String)

    Returns he operating system rule specified for patch groups using the patch baseline.

#patch_groupString

The name of the patch group whose patch baseline should be retrieved.

Returns:

  • (String)

    The name of the patch group whose patch baseline should be retrieved.