Aurora machine learning - Amazon Aurora

Aurora machine learning

By using Amazon Aurora machine learning, you can integrate your Aurora DB cluster with Amazon Comprehend or Amazon SageMaker, depending on your needs. Amazon Comprehend and SageMaker each support different machine learning use cases. Amazon Comprehend is a natural language processing (NLP) service that's used to extract insights from documents. By using Aurora machine learning with Amazon Comprehend, you can determine the sentiment of text in your database tables. SageMaker is a full-featured machine learning service. Data scientists use Amazon SageMaker to build, train, and test machine learning models for a variety of inference tasks, such as fraud detection. By using Aurora machine learning with SageMaker, database developers can invoke the SageMaker functionality in SQL code.

Not all AWS Regions support both Amazon Comprehend and SageMaker, and only certain AWS Regions support Aurora machine learning and thus provide access to these services from an Aurora DB cluster. The integration process for Aurora machine learning also differs by database engine. For more information, see Using Amazon Aurora machine learning.

Aurora machine learning with Aurora MySQL

Aurora machine learning is supported for Aurora MySQL in the AWS Regions listed in the table. In addition to having your version of Aurora MySQL available, the AWS Region must also support the service that you want to use. For a list of AWS Regions where Amazon SageMaker is available, see Amazon SageMaker endpoints and quotas in the Amazon Web Services General Reference. For a list of AWS Regions where Amazon Comprehend is available, see Amazon Comprehend endpoints and quotas in the Amazon Web Services General Reference.

Region Aurora MySQL version 3 Aurora MySQL version 2
US East (Ohio) Version 3.01.0 and higher Version 2.07 and higher
US East (N. Virginia) Version 3.01.0 and higher Version 2.07 and higher
US West (N. California) Version 3.01.0 and higher Version 2.07 and higher
US West (Oregon) Version 3.01.0 and higher Version 2.07 and higher
Africa (Cape Town)
Asia Pacific (Hong Kong) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Hyderabad) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Jakarta) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Melbourne) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Mumbai) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Osaka) Version 3.01.0 and higher Version 2.07.3 and higher
Asia Pacific (Seoul) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Singapore) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Sydney) Version 3.01.0 and higher Version 2.07 and higher
Asia Pacific (Tokyo) Version 3.01.0 and higher Version 2.07 and higher
Canada (Central) Version 3.01.0 and higher Version 2.07 and higher
Canada West (Calgary) Version 3.01.0 and higher Version 2.07 and higher
China (Beijing) Version 3.01.0 and higher Version 2.07 and higher
China (Ningxia) Version 3.01.0 and higher Version 2.07 and higher
Europe (Frankfurt) Version 3.01.0 and higher Version 2.07 and higher
Europe (Ireland) Version 3.01.0 and higher Version 2.07 and higher
Europe (London) Version 3.01.0 and higher Version 2.07 and higher
Europe (Milan)
Europe (Paris) Version 3.01.0 and higher Version 2.07 and higher
Europe (Spain) Version 3.01.0 and higher Version 2.07 and higher
Europe (Stockholm) Version 3.01.0 and higher Version 2.07 and higher
Europe (Zurich) Version 3.01.0 and higher Version 2.07 and higher
Israel (Tel Aviv) Version 3.01.0 and higher Version 2.07 and higher
Middle East (Bahrain) Version 3.01.0 and higher Version 2.07 and higher
Middle East (UAE) Version 3.01.0 and higher Version 2.07 and higher
South America (São Paulo) Version 3.01.0 and higher Version 2.07 and higher
AWS GovCloud (US-East) Version 3.01.0 and higher Version 2.07 and higher
AWS GovCloud (US-West) Version 3.01.0 and higher Version 2.07 and higher

Aurora machine learning with Aurora PostgreSQL

Aurora machine learning is supported for Aurora PostgreSQL in the AWS Regions listed in the table. In addition to having your version of Aurora PostgreSQL available, the AWS Region must also support the service that you want to use. For a list of AWS Regions where Amazon SageMaker is available, see Amazon SageMaker endpoints and quotas in the Amazon Web Services General Reference. For a list of AWS Regions where Amazon Comprehend is available, see Amazon Comprehend endpoints and quotas in the Amazon Web Services General Reference.

The following Regions and engine versions are available for Aurora machine learning with Aurora PostgreSQL.

Region Aurora PostgreSQL 16 Aurora PostgreSQL 15 Aurora PostgreSQL 14 Aurora PostgreSQL 13 Aurora PostgreSQL 12 Aurora PostgreSQL 11
US East (Ohio) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
US East (N. Virginia) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
US West (N. California) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
US West (Oregon) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Africa (Cape Town)
Asia Pacific (Hong Kong) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Hyderabad) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Jakarta) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Melbourne) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Mumbai) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Osaka) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Seoul) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Singapore) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Sydney) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Asia Pacific (Tokyo) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Canada (Central) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Canada West (Calgary) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
China (Beijing) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
China (Ningxia) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Europe (Frankfurt) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Europe (Ireland) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Europe (London) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Europe (Milan)
Europe (Paris) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Europe (Spain) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Europe (Stockholm) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Europe (Zurich) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Israel (Tel Aviv) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Middle East (Bahrain) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
Middle East (UAE) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
South America (São Paulo) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
AWS GovCloud (US-East) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher
AWS GovCloud (US-West) Version 16.1 and higher Version 15.2 and higher Version 14.3 Version 13.3 and higher Version 12.4 and higher Version 11.9, 11.12 and higher