SecurityPolicyProtocol

class aws_cdk.aws_cloudfront.SecurityPolicyProtocol(value)

Bases: enum.Enum

The minimum version of the SSL protocol that you want CloudFront to use for HTTPS connections.

CloudFront serves your objects only to browsers or devices that support at least the SSL version that you specify.

Attributes

SSL_V3 = 'SSL_V3'
TLS_V1 = 'TLS_V1'
TLS_V1_1_2016 = 'TLS_V1_1_2016'
TLS_V1_2016 = 'TLS_V1_2016'
TLS_V1_2_2018 = 'TLS_V1_2_2018'
TLS_V1_2_2019 = 'TLS_V1_2_2019'