Installing, updating, and uninstalling the AWS CLI version 2 - AWS Command Line Interface

Python 2.7, 3.4, and 3.5 are being deprecated for the AWS CLI version 1. For more information see the AWS CLI version 1 section of About the AWS CLI versions.

Installing, updating, and uninstalling the AWS CLI version 2

This topic provides links to information about how to install, update, and uninstall version 2 of the AWS Command Line Interface (AWS CLI) on the supported operating systems. For information on the latest releases of AWS CLI version 2, see the AWS CLI version 2 change notes on GitHub.

AWS CLI version 2 installation instructions: