PackageVersionDescription - CodeArtifact

PackageVersionDescription

Details about a package version.

Contents

displayName

The name of the package that is displayed. The displayName varies depending on the package version's format. For example, if an npm package is named ui, is in the namespace vue, and has the format npm, then the displayName is @vue/ui.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 255.

Required: No

format

The format of the package version. The valid package formats are:

  • npm: A Node Package Manager (npm) package.

  • pypi: A Python Package Index (PyPI) package.

  • maven: A Maven package that contains compiled code in a distributable format, such as a JAR file.

Type: String

Valid Values: npm | pypi | maven

Required: No

homePage

The homepage associated with the package.

Type: String

Required: No

licenses

Information about licenses associated with the package version.

Type: Array of LicenseInfo objects

Required: No

namespace

The namespace of the package. The package component that specifies its namespace depends on its type. For example:

  • The namespace of a Maven package is its groupId.

  • The namespace of an npm package is its scope.

  • A Python package does not contain a corresponding component, so Python packages do not have a namespace.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 255.

Pattern: [^!#/\s]+

Required: No

packageName

The name of the requested package.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 255.

Pattern: [^!#/\s]+

Required: No

publishedTime

A timestamp that contains the date and time the package version was published.

Type: Timestamp

Required: No

revision

The revision of the package version.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 50.

Pattern: \S+

Required: No

sourceCodeRepository

The repository for the source code in the package version, or the source code used to build it.

Type: String

Required: No

status

A string that contains the status of the package version. It can be one of the following:

  • Published

  • Unfinished

  • Unlisted

  • Archived

  • Disposed

Type: String

Valid Values: Published | Unfinished | Unlisted | Archived | Disposed | Deleted

Required: No

summary

A summary of the package version. The summary is extracted from the package. The information in and detail level of the summary depends on the package version's format.

Type: String

Required: No

version

The version of the package.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 255.

Pattern: [^!#/\s]+

Required: No

See Also

For more information about using this API in one of the language-specific AWS SDKs, see the following: