PackageVersionError - CodeArtifact

PackageVersionError

An error associated with package.

Contents

errorCode

The error code associated with the error. Valid error codes are:

  • ALREADY_EXISTS

  • MISMATCHED_REVISION

  • MISMATCHED_STATUS

  • NOT_ALLOWED

  • NOT_FOUND

  • SKIPPED

Type: String

Valid Values: ALREADY_EXISTS | MISMATCHED_REVISION | MISMATCHED_STATUS | NOT_ALLOWED | NOT_FOUND | SKIPPED

Required: No

errorMessage

The error message associated with the error.

Type: String

Required: No

See Also

For more information about using this API in one of the language-specific AWS SDKs, see the following: