Ruby platform history - AWS Elastic Beanstalk

Ruby platform history

This page lists the previous versions of AWS Elastic Beanstalk's Ruby platforms and the dates that each version was current. Platform versions that you used to launch or update an environment in the last 30 days remain available (to the using account, in the used region) even after they are no longer current.

See the Supported platforms page for information on the latest version of each platform supported by Elastic Beanstalk. Detailed release notes are available for recent releases at AWS Elastic Beanstalk Release Notes.

The following Elastic Beanstalk platform versions for Ruby were current between October 6, 2020 and October 6, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.1.2

64bit Amazon Linux 2 v3.1.2 running Ruby 2.7

2.0.20200928

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.6

3.2.0

nginx 1.18.0

Ruby 2.6 AL2 version 3.1.2

64bit Amazon Linux 2 v3.1.2 running Ruby 2.6

2.0.20200928

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.6

3.2.0

nginx 1.18.0

Ruby 2.5 AL2 version 3.1.2

64bit Amazon Linux 2 v3.1.2 running Ruby 2.5

2.0.20200928

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.6

3.2.0

nginx 1.18.0

Ruby 2.6 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between September 10, 2020 and October 5, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.7

2.0.20200827

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.6

2.0.20200827

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.5 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.5

2.0.20200827

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between September 3, 2020 and September 9, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.7

2.0.20200827

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.6

2.0.20200827

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.5 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.5

2.0.20200827

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between August 7, 2020 and September 2, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.1.0

64bit Amazon Linux 2 v3.1.0 running Ruby 2.7

2.0.20200723

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 AL2 version 3.1.0

64bit Amazon Linux 2 v3.1.0 running Ruby 2.6

2.0.20200723

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.5 AL2 version 3.1.0

64bit Amazon Linux 2 v3.1.0 running Ruby 2.5

2.0.20200723

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.9

64bit Amazon Linux 2018.03 v2.11.9 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between August 4, 2020 and August 6, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.1.0

64bit Amazon Linux 2 v3.1.0 running Ruby 2.7

2.0.20200723

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 AL2 version 3.1.0

64bit Amazon Linux 2 v3.1.0 running Ruby 2.6

2.0.20200723

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.5 AL2 version 3.1.0

64bit Amazon Linux 2 v3.1.0 running Ruby 2.5

2.0.20200723

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between July 6, 2020 and August 3, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.0.3

64bit Amazon Linux 2 v3.0.3 running Ruby 2.7

2.0.20200603

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 AL2 version 3.0.3

64bit Amazon Linux 2 v3.0.3 running Ruby 2.6

2.0.20200603

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.5 AL2 version 3.0.3

64bit Amazon Linux 2 v3.0.3 running Ruby 2.5

2.0.20200603

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.8

64bit Amazon Linux 2018.03 v2.11.8 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between June 23, 2020 and July 5, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.0.3

64bit Amazon Linux 2 v3.0.3 running Ruby 2.7

2.0.20200603

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 AL2 version 3.0.3

64bit Amazon Linux 2 v3.0.3 running Ruby 2.6

2.0.20200603

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.5 AL2 version 3.0.3

64bit Amazon Linux 2 v3.0.3 running Ruby 2.5

2.0.20200603

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between June 5, 2020 and June 22, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.0.2

64bit Amazon Linux 2 v3.0.2 running Ruby 2.7

2.0.20200520

Ruby 2.7.1-p83

RubyGems 3.1.3

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 AL2 version 3.0.2

64bit Amazon Linux 2 v3.0.2 running Ruby 2.6

2.0.20200520

Ruby 2.6.6-p146

RubyGems 3.1.3

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.5 AL2 version 3.0.2

64bit Amazon Linux 2 v3.0.2 running Ruby 2.5

2.0.20200520

Ruby 2.5.8-p224

RubyGems 3.1.3

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.7

64bit Amazon Linux 2018.03 v2.11.7 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between June 3, 2020 and June 4, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.0.2

64bit Amazon Linux 2 v3.0.2 running Ruby 2.7

2.0.20200520

Ruby 2.7.1-p83

RubyGems 3.1.3

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 AL2 version 3.0.2

64bit Amazon Linux 2 v3.0.2 running Ruby 2.6

2.0.20200520

Ruby 2.6.6-p146

RubyGems 3.1.3

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.5 AL2 version 3.0.2

64bit Amazon Linux 2 v3.0.2 running Ruby 2.5

2.0.20200520

Ruby 2.5.8-p224

RubyGems 3.1.3

Puma 4.3.5

3.2.0

nginx 1.16.1

Ruby 2.6 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between May 6, 2020 and June 2, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.0.1

64bit Amazon Linux 2 v3.0.1 running Ruby 2.7

2.0.20200430

Ruby 2.7.1-p83

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.6 AL2 version 3.0.1

64bit Amazon Linux 2 v3.0.1 running Ruby 2.6

2.0.20200430

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.5 AL2 version 3.0.1

64bit Amazon Linux 2 v3.0.1 running Ruby 2.5

2.0.20200430

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.6 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between May 4, 2020 and May 5, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.0.0

64bit Amazon Linux 2 v3.0.0 running Ruby 2.7

2.0.20200406

Ruby 2.7.1-p83

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.6 AL2 version 3.0.0

64bit Amazon Linux 2 v3.0.0 running Ruby 2.6

2.0.20200406

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.5 AL2 version 3.0.0

64bit Amazon Linux 2 v3.0.0 running Ruby 2.5

2.0.20200406

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.6 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.6

64bit Amazon Linux 2018.03 v2.11.6 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between April 30, 2020 and May 3, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.7 AL2 version 3.0.0

64bit Amazon Linux 2 v3.0.0 running Ruby 2.7

2.0.20200406

Ruby 2.7.1-p83

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.6 AL2 version 3.0.0

64bit Amazon Linux 2 v3.0.0 running Ruby 2.6

2.0.20200406

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.5 AL2 version 3.0.0

64bit Amazon Linux 2 v3.0.0 running Ruby 2.5

2.0.20200406

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 4.3.3

3.2.0

nginx 1.16.1

Ruby 2.6 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between March 27, 2020 and April 29, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.6 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.4

64bit Amazon Linux 2018.03 v2.11.4 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between February 28, 2020 and March 26, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.6 with Puma version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.3

64bit Amazon Linux 2018.03 v2.11.3 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between January 21, 2020 and February 27, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.6 with Puma version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.2

64bit Amazon Linux 2018.03 v2.11.2 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between November 25, 2019 and January 20, 2020:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.6 with Puma version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.5-p62

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.7-p157

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.9-p354

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.1

64bit Amazon Linux 2018.03 v2.11.1 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between October 17, 2019 and November 24, 2019:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.6 with Puma version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.5-p114

RubyGems 3.0.3

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.5-p114

RubyGems 3.0.3

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.7-p206

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.7-p206

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.9-p362

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.9-p362

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.3 with Puma version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.3 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.2 with Puma version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.2 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.1 with Puma version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.1 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.0 with Puma version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.0 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 1.9 with Passenger version 2.11.0

64bit Amazon Linux 2018.03 v2.11.0 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.16.1

The following Elastic Beanstalk platform versions for Ruby were current between September 18, 2019 and October 16, 2019:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.6 with Puma version 2.10.1

64bit Amazon Linux 2018.03 v2.10.1 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.3-p62

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.6 with Passenger version 2.10.1

64bit Amazon Linux 2018.03 v2.10.1 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.3-p62

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.5 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.6-p201

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.5 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.6-p201

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.4 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.7-p357

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.4 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.7-p357

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.3 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.3 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.2 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.2 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.1 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.1 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.0 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.0 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 1.9 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

The following Elastic Beanstalk platform versions for Ruby were current between September 6, 2019 and September 17, 2019:

Platform Version and Solution Stack Name

AMI

Language

Package Manager

Application Server

AWS X‑Ray

Proxy Server

Ruby 2.6 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.4-p104

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.6 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.4-p104

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.5 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.6-p201

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.5 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.6-p201

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.4 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.7-p357

RubyGems 2.7.9

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.4 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.7-p357

RubyGems 2.7.9

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.3 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.3 (Puma)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.3 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.3 (Passenger Standalone)

2018.03.0

Ruby 2.3.8-p459

RubyGems 2.7.7

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.2 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.2 (Puma)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.2 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.2 (Passenger Standalone)

2018.03.0

Ruby 2.2.10-p489

RubyGems 2.7.6

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.1 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.1 (Puma)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.1 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.1 (Passenger Standalone)

2018.03.0

Ruby 2.1.10-p492

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 2.0 with Puma version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.0 (Puma)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Puma 2.16.0

3.1.0

nginx 1.14.1

Ruby 2.0 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 2.0 (Passenger Standalone)

2018.03.0

Ruby 2.0.0-p648

RubyGems 2.6.13

Passenger 4.0.60

3.1.0

nginx 1.14.1

Ruby 1.9 with Passenger version 2.10.2

64bit Amazon Linux 2018.03 v2.10.2 running Ruby 1.9.3

2018.03.0

Ruby 1.9.3-p551

RubyGems 2.6.13