Downgrading from Version 2.17 - AWS Elemental Conductor File

This is version 2.17 of the AWS Elemental Conductor File documentation. This is the latest version. For prior versions, see the Archive section of AWS Elemental Conductor File and AWS Elemental Server Documentation.

Downgrading from Version 2.17

Downgrade from version 2.17 of Conductor File is not supported because version 2.17 runs on a different version of the CentOS or RHEL operating system. To downgrade from version 2.17, you must perform a clean install. See the instructions in AWS Elemental Conductor File Installation Guide.

Follow these recommendations:

  • Downgrade back to the version that you were using before upgrading to version 2.17. Copy back the database that you should have made when you upgraded from your original version.

  • If you performed a multi-step upgrade, such as from 2.13.0 to 2.15.0 and then upgraded to 2.17.x with a kickstart, you still only perform a one-step downgrade as a clean installation of your original (target) version. For example, if your original version was 2.13, you stored the database backup from 2.13 on an external system. You upgraded from version 2.13 to 2.15, exported the database from 2.15, and performed a clean installation of 2.17 while importing the 2.15 database. When you downgrade, you can go straight from version 2.17 to version 2.13. To do this, perform a clean install back to version 2.13. Then copy over the 2.13 database that you made when you upgraded from that version.