Actualizaciones del motor de base de datos de Aurora MySQL del 07/09/2022 (versión 3.02.1 compatible con MySQL 8.0.23). El soporte estándar finaliza el 15 de enero de 2024. No se admiten actualizaciones a esta versión. - Amazon Aurora

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

Actualizaciones del motor de base de datos de Aurora MySQL del 07/09/2022 (versión 3.02.1 compatible con MySQL 8.0.23). El soporte estándar finaliza el 15 de enero de 2024. No se admiten actualizaciones a esta versión.

Versión: 3.02.1

La versión 3.02.1 de Aurora MySQL ya está disponible con carácter general. Las versiones 3.02 de Aurora MySQL son compatibles con MySQL 8.0.23, las versiones 2.x de Aurora MySQL son compatibles con MySQL 5.7 y las versiones 1.x de Aurora MySQL son compatibles con MySQL 5.6.

Para obtener más información sobre las nuevas características de Aurora MySQL versión 3 y las diferencias entre Aurora MySQL versión 3 y Aurora MySQL versión 2 o Community MySQL 8.0, consulte Comparación de Aurora MySQL versión 2 y Aurora MySQL versión 3 en la Guía del usuario de Amazon Aurora.

Las versiones de Aurora MySQL compatibles actualmente son: 1.19.5, 1.19.6, 1.22.*, 1.23.*, 2.04.*, 2.07.*, 2.08.*, 2,09.*, 2.10.*, 3.01.* y 3.02.*.

Para obtener información sobre cómo planificar una actualización a Aurora MySQL versión 3, consulte Planificación de actualizaciones para Aurora MySQL versión 3 en la Guía del usuario de Amazon Aurora. Para obtener información sobre el procedimiento de actualización propiamente dicho, consulte Actualización a Aurora MySQL versión 3 en la Guía del usuario de Amazon Aurora. Para obtener información general sobre las actualizaciones de Aurora MySQL, consulte Actualización de clústeres de base Amazon Aurora MySQL en la Guía del usuario de Amazon Aurora.

Para obtener información sobre cómo solucionar problemas, consulte Solución de problemas de actualización con Aurora MySQL versión 3.

Si tiene alguna pregunta o duda, el servicio de AWS asistencia está disponible en los foros de la comunidad y a través de AWS Support. Para obtener más información, consulte Mantenimiento de un clúster de base de datos de Amazon Aurora en la Guía del usuario de Amazon Aurora.

Mejoras

La versión 3.02.1 de Aurora MySQL suele estar disponible y ser compatible con Community MySQL 8.0.23.

Se han corregido los problemas de seguridad y las CVE que se indican a continuación:

Correcciones y otras mejoras para ajustar la administración en un entorno administrado. Correcciones adicionales de CVE a continuación:

Mejoras de disponibilidad:

  • Se ha corregido un problema que podía provocar un error de conexión y alta latencia cuando se conectaban varias réplicas de registro binario (binlog) de MySQL a un nodo de escritor de Aurora o cuando había un gran número de consultas simultáneas de larga ejecución junto con un aumento de nuevas solicitudes de conexión.

  • Se ha corregido un problema que provocaba el reinicio de la base de datos cuando estaba activada la auditoría avanzada de eventos CONNECT.

  • Se ha corregido un problema que podía provocar el reinicio de la base de datos en las instancias de réplica de lectura de Aurora MySQL cuando las tablas temporales internas agotaban el tamaño asignado en la memoria y los archivos mmap estaban establecidos como valores predeterminados o configurados por el cliente.

  • Se ha corregido un problema que podía provocar que una réplica de lectura se reiniciara repetidamente durante operaciones de DDL simultáneas en procedimientos almacenados.

  • La inserción rápida no está habilitada en esta versión de Aurora MySQL debido a un problema que puede provocar incoherencias al ejecutar consultas como INSERT INTOSELECT, y. FROM Para obtener más información sobre la optimización de inserción rápida, consulte Mejoras en el rendimiento de Amazon Aurora MySQL.

Mejoras generales:

  • Se ha añadido compatibilidad con instancias R6i.

Información adicional:

  • Aurora MySQL versión 3.02.1 no admite actualizaciones de la versión principal directamente de Aurora MySQL versión 2 (compatible con MySQL 5.7). Para realizar una actualización de la versión principal a esta versión, primero realice una actualización de la versión principal a la versión 3.02.0 de Aurora MySQL y, a continuación, realice una actualización local de la versión secundaria a la versión 3.02.1 de Aurora MySQL.