Fuentes de AWS DMS - AWS Database Migration Service

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

Fuentes de AWS DMS

Puede utilizar distintos almacenes de datos de origen en distintas AWS DMS funciones. Las siguientes secciones contienen las listas de los bancos de datos de origen compatibles para cada AWS DMS función.

Puntos de conexión de origen para la migración de datos

Puede utilizar los siguientes almacenes de datos como puntos de enlace de origen para migrar datos con AWS DMS.

Bases de datos locales y de instancia EC2
  • Versiones de Oracle 10.2 y superiores (para las versiones 10.x), 11g y hasta 12.2, 18c y 19c para las ediciones Enterprise, Standard, Standard One y Standard Two

  • Versiones de Microsoft SQL Server 2005, 2008, 2008R2, 2012, 2014, 2016, 2017, 2019 y 2022.

    • Las ediciones Enterprise, Standard, Workgroup, Developer y Web admiten la replicación a plena carga.

    • Las ediciones Enterprise, Standard (versión 2016 y superior) y Developer admiten la replicación CDC (continua) además de la carga completa.

    • La edición Express no es compatible.

  • Versiones de MySQL 5.5, 5.6, 5.7 y 8.0

    nota

    Support para MySQL 8.0 como fuente está disponible en AWS DMS las versiones 3.4.0 y posteriores, excepto cuando la carga útil de la transacción está comprimida. Support para Google Cloud for MySQL 8.0 como fuente está disponible en AWS DMS las versiones 3.4.6 y superiores.

  • MariaDB (se admite como origen de datos compatible con MySQL) versiones 10.0 (solo versiones 10.0.24 y superiores), 10.2, 10.3, 10.4, 10.5 y 10.6.

    nota

    El soporte para MariaDB como fuente está disponible en todas AWS DMS las versiones compatibles con MySQL.

  • PostgreSQL versión 9.4 y superiores (para las versiones 9.x), 10.x, 11.x, 12.x, 13.x, 14.x y 15.x.

    nota

    AWS DMS solo es compatible con la versión 15.x de PostgreSQL en las versiones 3.5.1 y superiores.

  • MongoDB versiones 3.x, 4.0, 4.2, 4.4, 5.0 y 6.0

    nota

    AWS DMS las versiones 3.5.0 y superiores no admiten las versiones de MongoDB anteriores a la 3.6.

  • SAP Adaptive Server Enterprise (ASE) versiones 12.5, 15, 15.5, 15.7, 16 y superiores

  • Versiones IBM Db2 para Linux, UNIX y Windows (Db2 LUW):

    • Versión 9.7, todos los paquetes de correcciones

    • Versión 10.1, todos los paquetes de correcciones

    • Versión 10.5, se admiten todos los paquetes de correcciones excepto Fix Pack 5

    • Versión 11.1, todos los paquetes de correcciones

    • Versión 11.5, Mods (0-8) con solo Fix Pack Zero

  • IBM Db2 para z/OS, versión 12

Servicios de bases de datos administradas por terceros:
  • Microsoft Azure SQL Database

  • Microsoft Azure PostgreSQL Flexible Server versiones 11.2, 12.15, 13.11, 14.8 y 15.3.

  • Microsoft Azure MySQL Flexible Server versiones 5.7 y 8.

  • Google Cloud para versiones de MySQL 5.6, 5.7 y 8.0.

  • Google Cloud para PostgreSQL, versiones 9.6, 10, 11, 12, 13, 14 y 15.

  • OCI MySQL Heatwave versión 8.0.34.

Bases de datos de instancias de Amazon RDS y Amazon Simple Storage Service (Amazon S3)
  • Versiones de Oracle 11g (versiones 11.2.0.4 y superiores) y hasta 12.2, 18c y 19c para las ediciones Enterprise, Standard, Standard One y Standard Two

  • Versiones de Microsoft SQL Server 2012, 2014, 2016, 2017, 2019 y 2022 para las ediciones Enterprise, Standard, Workgroup y Developer

    nota

    AWS DMS no es compatible con SQL Server Express. La edición web solo se admite para la replicación exclusiva de carga completa.

  • Versiones de MySQL 5.5, 5.6, 5.7 y 8.0

    nota

    Support para MySQL 8.0 como fuente está disponible en AWS DMS las versiones 3.4.0 y posteriores, excepto cuando la carga útil de la transacción está comprimida.

  • MariaDB versiones 10.0.24 a 10.0.28, 10.2, 10.3, 10.4, 10.5 y 10.6 (se admite como origen de datos compatible con MySQL).

    nota

    El soporte para MariaDB como fuente está disponible en todas AWS DMS las versiones compatibles con MySQL.

  • PostgreSQL versión 10.x, 11.x, 12.x, 13.x, 14.x y 15.x.

    nota

    AWS DMS solo es compatible con PostgreSQL 15.x en las versiones 3.5.1 y superiores.

  • Amazon Aurora con compatibilidad con MySQL (se admite como un origen de datos compatible con MySQL)

  • Amazon Aurora con compatibilidad con PostgreSQL (se admite como un origen de datos compatible con PostgreSQL)

  • Amazon S3

  • Amazon DocumentDB (compatible con MongoDB), versiones 3.6, 4.0 y 5.0.

  • Amazon RDS para IBM Db2 LUW.

Para obtener información sobre cómo trabajar con una fuente específica, consulte Trabajar con puntos de enlace. AWS DMS

Para obtener información acerca de los puntos de conexión de destino admitidos, consulte Puntos de conexión de destino para la migración de datos.

Bases de datos de origen para DMS Fleet Advisor

DMS Fleet Advisor es compatible con las siguientes bases de datos de origen.

  • Microsoft SQL Server versión 2012 y superior hasta 2019

  • MySQL versión 5.6 y hasta la 8

  • Oracle versión 11g, versión 2 y versiones posteriores hasta 12c, 19c y 21c

  • PostgreSQL versión 9.6 y hasta 13

Para obtener información sobre cómo trabajar con un origen específico, consulte Creación de usuarios de bases de datos para AWS DMS Fleet Advisor.

Para ver la lista de bases de datos que DMS Fleet Advisor utiliza para generar recomendaciones de destino, consulte Destinos para DMS Fleet Advisor.

Proveedores de datos de origen para la conversión de esquemas del DMS

La conversión de esquemas del DMS admite los siguientes proveedores de datos como orígenes para los proyectos de migración.

  • Microsoft SQL Server versión 2008 R2, 2012, 2014, 2016, 2017 y 2019

  • Oracle versión 10.2 y superior, 11g y hasta 12.2, 18c y 19c, y Oracle Data Warehouse

  • PostgreSQL 9.2 y superior

  • MySQL versión 5.5 y superior

El proveedor de datos de origen puede ser un motor autoadministrado que se ejecute en las instalaciones o en una instancia de Amazon Elastic Compute Cloud (Amazon EC2).

Para obtener información sobre cómo trabajar con un origen específico, consulte Creación de proveedores de datos de origen para la conversión de esquemas del DMS.

Para obtener información acerca de las bases de datos de destino compatibles, consulte Proveedores de datos de destino para la conversión de esquemas del DMS.

El AWS Schema Conversion Tool (AWS SCT) admite más bases de datos de origen y destino que DMS Schema Conversion. Para obtener información sobre las bases de datos AWS SCT compatibles, consulte Qué es. AWS Schema Conversion Tool

Proveedores de datos de origen para migraciones de datos homogéneas de DMS

Puede utilizar los siguientes proveedores de datos como orígenes para migraciones de datos homogéneas.

  • MySQL versión 5.7 y superiores

  • MariaDB versión 10.2 y superiores

  • PostgreSQL versión 10.4 hasta 14.x.

  • MongoDB versión 4.x, 5.x, 6.0

  • Amazon DocumentDB versiones 3.6, 4.0 y 5.0

El proveedor de datos de origen puede ser un motor autoadministrado que se ejecute en las instalaciones o en una instancia de Amazon EC2. Además, puede utilizar una instancia de base de datos de Amazon RDS como proveedor de datos de origen.

Para obtener información sobre cómo trabajar con un origen específico, consulte Creación de proveedores de datos de origen para migraciones de datos homogéneas en AWS DMS.

Para obtener información acerca de las bases de datos de destino compatibles, consulte Proveedores de datos de destino para migraciones de datos homogéneas de DMS.