Introducción a la Animation Editor - Guía del usuario de Lumberyard

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

Introducción a la Animation Editor

Esta característica está en versión preliminar y está sujeta a cambios.

Consulte los siguientes procedimientos para comenzar a utilizar el Animation Editor.

En este procedimiento, debe hacer lo siguiente:

  • Importe el archivo de actor y cree un conjunto de movimientos para especificar los movimientos que para tu personaje.

  • Cree un gráfico de animación básico con los nodos.

  • Crear un árbol de combinación para combinar los movimientos y utilizar un control deslizante para controlar el carácter el movimiento desde el ralentí hasta caminar y luego correr.

Puede utilizar el proyecto de ejemplos para encontrar los archivos utilizados en este procedimiento. Para más información información, consulte Proyecto de ejemplos.

Los archivos de este procedimiento se encuentran en el siguiente directorio:

lumberyard_version\dev\SamplesProject\AnimationSamples\Simple_JackLocomotion

Paso 1: Creación de un movimiento Establecer

En el siguiente procedimiento, importe el personaje, Jack el robot, seleccione el botón los movimientos que desee y, a continuación, añada esos movimientos a un conjunto de movimientos.

Para crear un conjunto de movimientos

  1. En Lumberyard Editor, elige Herramientas, Animation Editor.

  2. En Animation Editor, elige Diseños, Gráfico de animación.

  3. En la pestaña Animation Editor, elige [EMPTY]de Actor abierto y navegue hasta el AnimationSamples\Simple_JackLocomotion del directorio.

  4. Seleccione la opción JackBind_ZUp.fbx y haz clic en correcto.

    El personaje de Jack aparece en el campo Animation Editor.

    
                        Importar el JackBind_ZUp.fbx en el archivo
                                Animation Editor.
  5. En la Conjuntos de movimientos , en Conjunto de movimientos Dirección, haz clic en el botón + icono para añadir un movimiento establezca.

  6. Seleccione la opción ConjuntoDeMovimiento0 del nodo.

  7. En la pestaña Conjunto de movimientos haz clic en el icono de la carpeta para añadir movimientos.

  8. Ve a la pestaña AnimationSamples/Simple_JackLocomotion y seleccione los siguientes archivos:

    • Jack_Idle_ZUp.fbx

    • Jack_Strafe_Run_Forwards_ZUp.fbx

    • Jack_Strafe_Walk_Forwards_ZUp.fbx

  9. Haga clic en correcto.

  10. En la pestaña Gestión de conjunto de movimientos , haz clic en el botón [EMPTY] icono.

  11. Ve a la pestaña /SamplesProject/AnimationSamples/Simple_JackLocomotion del directorio. Para el nombre del archivo, escriba quickstart y luego haz clic en [EMPTY] para guardar quickstart.motionset del archivo.

    
                        Cree un conjunto de movimientos y añada archivos de movimiento en la
                                Animation Editor.

Paso 2: Creación de un Gráfico de animación

En el siguiente procedimiento, cree un gráfico de animación y nodos.

Para crear un gráfico de animación

  1. En la Gráfico de animación haz clic en la pestaña + para crear un gráfico de animación.

  2. Haz clic en el botón [EMPTY] icono.

  3. Ve a la pestaña /SamplesProject/AnimationSamples/Simple_JackLocomotion del directorio. Para el nombre del archivo, escriba quickstart y luego haz clic en [EMPTY] para guardar quickstart.animgraph del archivo.

  4. En la Gráfico de animación , haga clic con el botón derecho en la cuadrícula y, a continuación, seleccionar Crear nodode Fuentes, Movimiento.

    
                        Cree un nodo de movimiento en el gráfico de animación.
  5. Seleccione la opción Movimiento0 y en el nodo Atributos , haz clic en Seleccionar movimientos. En el cuadro de diálogo, seleccione Jack_Idle_ZUp.fbx y luego elige correcto.

  6. Haga clic con el botón derecho en la cuadrícula y, a continuación, elija Crear nodo, Fuentesde Árbol de combinación.

  7. Desde la pestaña Movimiento0 haz clic en una línea y arrástrala al Árbol de combinación0 del nodo. Una línea de transición con una flecha conecta los nodos.

  8. Desde la pestaña Árbol de combinación0 haz clic en una línea y arrástrala al Movimiento0 del nodo.

    
                        Conectar el movimiento y mezclar nodos de árbol en la animación
                            gráfico.
  9. En la pestaña Parámetros , haz clic en el botón + para crear un parámetro.

    1. Deja el botón Tipo de valor al parámetro predeterminado, Flotador (control deslizante).

    2. Para Nombre, cambiar nombre Parameter0 de speed.

    3. Haga clic en [EMPTY].

  10. En el gráfico de animación, seleccione la línea de transición que comienza en el campo Movimiento0 y se conecta al nodo Árbol de combinación0 del nodo.

    1. En la pestaña Atributos , haz clic en [EMPTY] condición.

    2. En la pestaña Seleccionar una condición , selecciona Condición del parámetro y luego haz clic en Añadir condición.

    3. En la pestaña Atributos , debajo de Parámetro Condición, haga clic en Seleccionar parámetro y selecciona speed.

    4. Para Función de prueba, deje el valor predeterminado de parámetro > valor de prueba. Esto significa que si la velocidad es mayor que cero, el movimiento de ralentí pasa al árbol de combinación, y el personaje comienza a moverse.

      
                                Añada condiciones de parámetro para especificar cuándo el carácter
                                    comienza a moverse.
  11. En el gráfico de animación, seleccione la línea de transición que comienza en el campo Árbol de combinación0 y se conecta al nodo Movimiento0 del nodo.

    1. En la pestaña Atributos , haz clic en [EMPTY] condición.

    2. En la pestaña Seleccionar una condición , selecciona Condición del parámetro y luego haz clic en Añadir condición.

    3. En la pestaña Atributos , debajo de Parámetro Condición, haga clic en Seleccionar parámetro. Seleccionar speed y luego haz clic en correcto.

    4. Para Función de prueba, selecciona parámetro == Valor de prueba. Esto significa que si la velocidad es igual a cero, el movimiento vuelve a estar inactivo y el personaje se detiene moviendo.

      
                                Añada condiciones de parámetro para especificar cuándo se detiene el carácter
                                    moviendo.

Paso 3: Mezcla de la Animaciones

En el siguiente procedimiento, se utiliza el nodo de árbol de combinación para crear el árbol de combinación, que combina las animaciones de caminar y ejecutar.

Para combinar las animaciones

  1. En el gráfico de animación, haga doble clic en el icono Árbol de combinación0 del nodo.

  2. Haz clic con el botón derecho en la cuadrícula y selecciona Crear nodo, Fuentesde Movimiento.

  3. Seleccione la opción Movimiento1 del nodo.

    1. En la pestaña Atributos selecciona Seleccionar movimientos.

    2. En la pestaña Ventana Selección de movimiento, selecciona jack_strafe_walk_forwards_zup y luego haz clic en correcto.

      Los atributos para el Movimiento1 el nodo debe tener un aspecto como esta:

      
                                Añada el archivo de movimiento de caminata al Movimiento1
                                    del nodo.
  4. En el gráfico de animación, haga clic con el botón derecho en la cuadrícula y elija [EMPTY] [EMPTY]de Fuentesde Movimiento.

  5. Seleccione la opción Movimiento2 del nodo.

    1. En la pestaña Atributos , haz clic en Seleccionar movimientos.

    2. En el cuadro de diálogo, seleccione jack_strafe_run_forwards_zup y luego haz clic en correcto.

      Los atributos para el Movimiento2 el nodo debe tener un aspecto como esta:

      
                                Añada el archivo de movimiento de ejecución al Movimiento2
                                    del nodo.
  6. Haz clic con el botón derecho en la cuadrícula y selecciona Crear nodo, Mezclade Mezcla dos.

  7. Seleccione la opción MezclarDos0 del nodo.

    1. En la pestaña Atributos panel, para Sincronización Modo, selecciona Basado en clip completo.

  8. Para Movimiento1 , seleccione el Salida [EMPTY] y arrastre el conector al [EMPTY] [EMPTY] la entrada de la MezclarDos0 del nodo.

  9. Para Movimiento2 , seleccione el Salida [EMPTY] y arrastre el conector al [EMPTY] 2 la entrada de la MezclarDos0 del nodo.

  10. Para el MezclarDos0 , seleccione el Salida [EMPTY] y arrastre el conector al Entrada [EMPTY] de NodoFinal0 del nodo.

    El árbol de combinación debe tener el siguiente aspecto:

    
                        Cree su árbol de combinación en el gráfico de animación.
  11. Haz clic con el botón derecho en la cuadrícula y selecciona Crear nodo, Fuentesde Parámetros.

  12. Haz clic con el botón derecho en la cuadrícula y selecciona Crear nodo, Matemáticasde Suavizado.

  13. Para Parámetros0 , seleccione el velocidad y arrastre el conector al cuadro de diálogo [EMPTY] del cuadro de entrada de la Suavizado0 del nodo.

  14. Para el Suavizado0 , seleccione el Resultado y arrastre el conector al cuadro de diálogo Peso del cuadro de entrada de la MezclarDos0 del nodo.

    El árbol de combinación debe tener el siguiente aspecto:

    
                        Cree un árbol de combinación para el gráfico de animación.
  15. En la pestaña Animation Editor, elige [EMPTY]de Guardar todo. Luego, en el cuadro de diálogo haz clic en correcto.

  16. Ve a la pestaña /SamplesProject/AnimationSamples/Simple_JackLocomotion del directorio. Para el nombre del archivo, escriba quickstart y luego haz clic en [EMPTY] para guardar el espacio de trabajo.

  17. En la pestaña Gráfico de animación haz clic en la pestaña Play botón. El personaje debe animarse en el modo inactivo.

  18. En la pestaña Parámetros , mueve el botón velocidad desliza el control hacia la derecha para que Jack camine. Mueva el control deslizante más hacia la derecha para que Jack corra.

    
                        Animar a Jack el robot en el
                                Animation Editor.