UpdateDashboardPublishedVersion -

Las traducciones son generadas a través de traducción automática. En caso de conflicto entre la traducción y la version original de inglés, prevalecerá la version en inglés.

UpdateDashboardPublishedVersion

Actualiza la versión publicada de un panel.

Sintaxis de la solicitud

PUT /accounts/AwsAccountId/dashboards/DashboardId/versions/VersionNumber HTTP/1.1

Parámetros de solicitud URI

La solicitud utiliza los siguientes parámetros URI.

AwsAccountId

El ID de la cuenta de AWS que contiene el panel que está actualizando.

Restricciones: Longitud fija de 12.

Patrón: ^[0-9]{12}$

: obligatorio Sí

DashboardId

El identificador del panel.

Restricciones: Longitud mínima de 1. La longitud máxima es de 2048 caracteres.

Patrón: [\w\-]+

: obligatorio Sí

VersionNumber

Número de versión del panel.

Rango válido Valor mínimo de 1.

: obligatorio Sí

Cuerpo de la solicitud

La solicitud no tiene un cuerpo de la solicitud.

Sintaxis de la respuesta

HTTP/1.1 Status Content-type: application/json { "DashboardArn": "string", "DashboardId": "string", "RequestId": "string" }

Elementos de respuesta

Si la acción se realiza correctamente, el servicio devuelve la respuesta HTTP siguiente.

Estado

El estado HTTP de la solicitud.

El servicio devuelve los datos siguientes en formato JSON.

DashboardArn

El nombre de recurso de Amazon (ARN) del panel de control.

Tipo: Cadena

DashboardId

El identificador del panel.

Tipo: Cadena

Restricciones: Longitud mínima de 1. La longitud máxima es de 2048 caracteres.

Patrón: [\w\-]+

RequestId

ID de solicitud de AWS de esta operación.

Tipo: Cadena

Errors

Para obtener información sobre errores que son comunes a todas las acciones, consulteErrores comunes.

ConflictExcepción

La actualización o eliminación de un recurso puede provocar un estado incoherente.

Código de estado HTTP: 409

InternalFailureException

Se produjo un error interno.

Código de estado HTTP: 500

InvalidParameterValueException

Uno o más parámetros tienen un valor que no es válido.

Código de estado HTTP: 400

ResourceNotFoundException

No se encuentran uno o varios recursos.

Código de estado HTTP: 404

ThrottlingException

El acceso está limitado.

Código de estado HTTP: 429

UnsupportedUserEditionException

Este error indica que está llamando a una operación en una suscripción de Amazon QuickSight en la que la edición no admite esa operación. Las ediciones actuales de Amazon QuickSight son Standard Edition y Enterprise Edition. No todas las operaciones y funciones están disponibles en todas las ediciones.

Código de estado HTTP: 403

Véase también

Para obtener más información sobre el uso de esta API en un SDK de AWS de un lenguaje específico, consulte: