Sistemas operativos compatibles - AWS Systems Manager

Sistemas operativos compatibles

Puede administrar instancias de Amazon Elastic Compute Cloud (Amazon EC2) y servidores en las instalaciones y máquinas virtuales (VM), además de VM alojadas en otros proveedores de nube, utilizando AWS Systems Manager. Estos nodos deben ejecutar uno de los siguientes sistemas operativos.

nota

Si planea administrar y configurar dispositivos de núcleo de AWS IoT Greengrass mediante Systems Manager, estos dispositivos deben cumplir los requisitos de AWS IoT Greengrass. Para obtener más información, consulte Configuración de dispositivos de núcleo de AWS IoT Greengrass en la Guía para desarrolladores de AWS IoT Greengrass Version 2.

Si planea administrar y configurar dispositivos de borde de AWS IoT y que no son de AWS, estos dispositivos deben cumplir los requisitos enumerados aquí y se deben configurar como nodos administrados locales para Systems Manager. Para obtener más información, consulte Configuración de AWS Systems Manager para dispositivos de borde .

importante

Patch Manager, una capacidad de Systems Manager, podría no ser compatible con todas las versiones del sistema operativo (SO) que se enumeran en este tema. Para ver una lista de las versiones del sistema operativo compatibles con Patch Manager, consulte Requisitos previos de Patch Manager.

Linux

Amazon Linux
Versiones x86 x86_64 ARM64
2012.03 – 2018.03
nota

A partir de la versión 2015.03, Amazon Linux se lanza en versiones de x86_64.

Amazon Linux 2
Versiones x86 x86_64 ARM64
Versiones 2.0 y todas las posteriores
CentOS
Versiones x86 x86_64 ARM64
6.x¹
Versiones 7.1 y 7.x posteriores.
Versiones 8.0-8.5

¹ Para usar estas versiones, debe usar una versión 3.0.x de SSM Agent. Le recomendamos que utilice la última versión 3.0.x disponible de SSM Agent. Las versiones posteriores de SSM Agent (3.1 o posterior) no son compatibles.

CentOS Stream
Versiones x86 x86_64 ARM64
8
Servidor Debian
Versiones x86 x86_64 ARM64
Jessie (8)
Stretch (9)
Buster (10)
Bullseye (11)
Oracle Linux
Versiones x86 x86_64 ARM64
7.5-7.8
8.1-8.5
Red Hat Enterprise Linux (RHEL)
Versiones x86 x86_64 ARM64
6.x¹
7.0-7.5
7.6-8.6

¹ Para usar estas versiones, debe usar una versión 3.0.x de SSM Agent. Le recomendamos que utilice la última versión 3.0.x disponible de SSM Agent. Las versiones posteriores de SSM Agent (3.1 o posterior) no son compatibles.

Rocky Linux
Versiones x86 x86_64 ARM64
8.4-8.5
SUSE Linux Enterprise Server (SLES)
Versiones x86 x86_64 ARM64
Versiones 12 y 12.x posteriores.
15 y versiones posteriores a la 15. Versionesx
Servidor Ubuntu
Versiones x86 x86_64 ARM64
12.04 LTS y 14.04 LTS
16.04 LTS y 18.04 LTS
20.04 LTS y 20.10 STR

macOS

Versión x86 x86_64 ARM64
10.14.x (Mojave)
10.15.x (Catalina)
11.x (BigSur)
12.x (Monterrey)
nota

La compatibilidad con macOS se limita a las siguientes Regiones de AWS:

  • EE.UU. Este (Norte de Virginia) (us-east-1)

  • EE.UU. Este (Ohio) (us-east-2)

  • EE.UU. Oeste (Oregón) (us-west-2)

  • Europa (Irlanda) (eu-west-1)

  • Asia Pacífico (Singapur) (ap-southeast-1)

Para obtener más información acerca de la compatibilidad de Amazon EC2 para macOS, consulte Instancias Mac para Amazon EC2 en la Guía del usuario de Amazon EC2 para instancias de Linux.

Raspberry Pi OS (anteriormente Raspbian)

Versión ARM32
8 (Jessie)
9 (Stretch)

Windows Server

SSM Agent requiere Windows PowerShell 3.0 o una versión posterior para ejecutar determinados documentos de AWS Systems Manager (documentos de SSM) en instancias de Windows Server (por ejemplo, el documento AWS-ApplyPatchBaseline heredado). Compruebe que las instancias de Windows Server estén ejecutando Windows Management Framework 3.0 o una versión posterior. Este marco contiene Windows PowerShell. Para obtener más información, consulte Windows Management Framework 3.0 .

Versión x86 x86_64 ARM64
2008¹
2008 R2¹
2012 y 2012 R2
2016
2019
2022

¹ A partir del 14 de enero de 2020, Windows Server 2008 ya no es compatible para obtener actualizaciones de características o seguridad de Microsoft. Amazon Machine Images heredadas (AMIs) para Windows Server 2008 y 2008 R2 aún incluyen la versión 2 de SSM Agent preinstalada, pero Systems Manager ya no admite oficialmente las versiones 2008 ni actualiza el agente para estas versiones de Windows Server. Además, es posible que SSM Agent versión 3.0 no sea compatible con todas las operaciones en Windows Server 2008 y 2008 R2. La versión final oficialmente admitida de SSM Agent para las versiones Windows Server 2008 es 2.3.1644.0.