pgtle.set_default_version - Amazon Relational Database Service

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

pgtle.set_default_version

La fonction set_default_version vous permet de spécifier une valeur default_version pour votre extension TLE. Vous pouvez utiliser cette fonction pour définir un chemin de mise à niveau et désigner la version comme étant la version par défaut pour votre extension TLE. Lorsque les utilisateurs de la base de données spécifient votre extension TLE dans les commandes CREATE EXTENSION et ALTER EXTENSION ... UPDATE, cette version de votre extension TLE est créée dans la base de données pour cet utilisateur.

Cette fonction renvoie true en cas de réussite. Si l'extension TLE spécifiée dans l'argument name n'existe pas, la fonction renvoie une erreur. De même, si la version de l'extension TLE n'existe pas, elle renvoie une erreur.

Prototype de fonction

pgtle.set_default_version(name text, version text)

Rôle

pgtle_admin

Arguments

  • name : nom de l'extension TLE. Cette valeur est utilisée lors d'un appel de CREATE EXTENSION.

  • version : version de l'extension TLE à définir par défaut.

Sortie

  • true : lorsque la définition de la version par défaut réussit, la fonction renvoie true.

  • ERROR : renvoie un message d'erreur si une extension TLE avec le nom ou la version spécifiés n'existe pas.

Exemple d'utilisation

SELECT * FROM pgtle.set_default_version('my-extension', '1.1');