Version : mises à jour de la plateforme AMI Amazon Linux pour Elastic Beanstalk le 10 septembre 2020 - AWS Elastic Beanstalk

Les traductions sont fournies par des outils de traduction automatique. En cas de conflit entre le contenu d'une traduction et celui de la version originale en anglais, la version anglaise prévaudra.

Version : mises à jour de la plateforme AMI Amazon Linux pour Elastic Beanstalk le 10 septembre 2020

Cette version fournit de nouvelles versions pour les plateformes AWS Elastic Beanstalk basées sur l'AMI Amazon Linux. La version inclut des mises à jour de sécurité. Elle inclut également des mises à jour pour Apache, Multicontainer Docker, Go, PHP et Python.

Date de parution : 10 septembre 2020

Modifications

Le tableau suivant répertorie les modifications incluses dans cette version.

Note

Sachez qu'au moment de la publication de ces notes de mise à jour, les nouvelles versions de plateforme peuvent ne pas encore être disponibles dans toutes les régions AWS prises en charge par Elastic Beanstalk. Plusieurs heures peuvent encore être nécessaires pour terminer la version.

Catégorie Description

Mises à jour de sécurité

Application de toutes les mises à jour de sécurité publiées dans le centre de sécurité Amazon Linux au plus tard le 4 septembre 2020 dans toutes les plateformes AMI Amazon Linux.

Les versions Apache, Go, PHP et Python incluent des correctifs de sécurité. Pour de plus amples informations, consultez Mises à jour multiplateformes et Mises à jour spécifiques à une plateforme dans ce tableau.

Mises à jour multiplateformes

Application de ces mises à jour multiplateformes :

Composant Mettre à jour

Apache

Mise à jour des plateformes prenant en charge Apache HTTP Server 2.4 vers la version 2.4.46. Pour de plus amples informations, veuillez consulter Modifications avec Apache 2.4.x sur le site web Apache Software Foundation.

La version 2.4.46 d'Apache inclut des correctifs de sécurité.

Mises à jour spécifiques aux plateformes

Application de ces mises à jour spécifiques aux plateformes :

Plateforme Mettre à jour

Docker multi-conteneurs

Mise à jour de l'agent ECS vers la version 1.44.3.

Go

Mise à jour de Go vers la version 1.15.1. Pour de plus amples informations, veuillez consulter go1.15 dans Historique des versions du langage de programmation Go.

La version Go 1.15.1 inclut des correctifs de sécurité.

PHP

Mise à jour de PHP 7.3 et 7.2 vers les versions 7.3.21 et 7.2.33, respectivement.

Ces versions incluent des correctifs de sécurité.

Python

Mise à jour de Python 3.6 vers Python 3.6.12.

La version Python 3.6.12 inclut des correctifs de sécurité.

Nouvelles versions de plateforme

Note

Les tableaux suivants répertorient toutes les branches de plateforme prises en charge pour chaque plateforme. Seules les branches de la plateforme AMI Amazon Linux sont mises à jour.

Docker

Version de plateforme et Nom de la pile de solutions

AMI

Version de Docker

Serveur proxy

Docker AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Docker

2.0.20200827

19.03.6-ce

nginx 1.18.0

Single Container Docker version 2.15.4

64bit Amazon Linux 2018.03 v2.15.4 running Docker 19.03.6-ce

2018.03.0

19.03.6-ce

nginx 1.16.1

Docker multi-conteneurs

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Version de Docker

Agent ECS

Multicontainer Docker version 2.22.0

64bit Amazon Linux 2018.03 v2.22.0 running Multi-container Docker 19.03.6-ce (Generic)

2018.03.0

19.03.6-ce

1.44.3

Docker préconfiguré

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Plateforme

Système d'exploitation conteneur

Langage

Serveur proxy

Serveur d'application

Image Docker

Glassfish 5.0 (Docker) version 2.15.4

64bit Amazon Linux v2.15.4 running GlassFish 5.0 Java 8 (Preconfigured - Docker)

2018.03.0

Docker 19.03.6-ce

Amazon Linux 2018.03

Java 8

nginx 1.16.1

GlassFish 5.0

amazon/aws-eb-glassfish:5.0-al-onbuild-2.11.1

Go

Version de plateforme et Nom de la pile de solutions

AMI

Langage

AWS X‑Ray

Serveur proxy

Go 1 AL2 version 3.1.2

64bit Amazon Linux 2 v3.1.2 running Go 1

2.0.20200827

Go 1.15.1

3.2.0

nginx 1.18.0

Go 1.14 version 2.16.0

64bit Amazon Linux 2018.03 v2.16.0 running Go 1.15.1

2018.03.0

Go 1.15.1

3.1.0

nginx 1.16.1

Java SE

Version de plateforme et Nom de la pile de solutions

AMI

Langage

Outils

AWS X‑Ray

Serveur proxy

Corretto 11 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Corretto 11

2.0.20200827

Corretto 11.0.8.10.1

Ant 1.10.7, Gradle 5.6.2, Maven 3.6.2

3.2.0

nginx 1.18.0

Corretto 8 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Corretto 8

2.0.20200827

Corretto 8.265.01.1

Ant 1.10.7, Gradle 5.6.2, Maven 3.6.2

3.2.0

nginx 1.18.0

Java 8 version 2.10.11

64bit Amazon Linux 2018.03 v2.10.11 running Java 8

2018.03.0

Java 1.8.0_252

Ant 1.9.6, Gradle 2.7, Maven 3.3.3

3.1.0

nginx 1.16.1

Java 7 version 2.10.11

64bit Amazon Linux 2018.03 v2.10.11 running Java 7

2018.03.0

Java 1.7.0_261

Ant 1.9.6, Gradle 2.7, Maven 3.3.3

3.1.0

nginx 1.16.1

Tomcat

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

AWS X‑Ray

Serveur d'application

Serveur proxy

Corretto 11 with Tomcat 8.5 AL2 version 4.1.1

64bit Amazon Linux 2 v4.1.1 running Tomcat 8.5 Corretto 11

2.0.20200827

Corretto 11.0.8.10.1

3.2.0

Tomcat 8.5.56

nginx 1.18.0 (par défaut), Apache 2.4.43

Corretto 8 with Tomcat 8.5 AL2 version 4.1.1

64bit Amazon Linux 2 v4.1.1 running Tomcat 8.5 Corretto 8

2.0.20200827

Corretto 8.265.01.1

3.2.0

Tomcat 8.5.56

nginx 1.18.0 (par défaut), Apache 2.4.43

Corretto 11 with Tomcat 7 AL2 version 4.1.1

64bit Amazon Linux 2 v4.1.1 running Tomcat 7 Corretto 11

2.0.20200827

Corretto 11.0.8.10.1

3.2.0

Tomcat 7.0.76

nginx 1.18.0 (par défaut), Apache 2.4.43

Corretto 8 with Tomcat 7 AL2 version 4.1.1

64bit Amazon Linux 2 v4.1.1 running Tomcat 7 Corretto 8

2.0.20200827

Corretto 8.265.01.1

3.2.0

Tomcat 7.0.76

nginx 1.18.0 (par défaut), Apache 2.4.43

Java 8 with Tomcat 8.5 version 3.3.10

64bit Amazon Linux 2018.03 v3.3.10 running Tomcat 8.5 Java 8

2018.03.0

Java 1.8.0_252

3.1.0

Tomcat 8.5.57

Apache 2.4.46 (par défaut), Apache 2.2.34, Nginx 1.16.1

Java 7 with Tomcat 7 version 3.3.10

64bit Amazon Linux 2018.03 v3.3.10 running Tomcat 7 Java 7

2018.03.0

Java 1.7.0_261

3.1.0

Tomcat 7.0.104

Apache 2.4.46 (par défaut), Apache 2.2.34, Nginx 1.16.1

Node.js

Version de plateforme et Nom de la pile de solutions

AMI

Versions Node.js (versions npm)

Serveur proxy

Git

AWS X‑Ray

Node.js 12 AL2 version 5.2.1

64bit Amazon Linux 2 v5.2.1 running Node.js 12

2.0.20200827

12.18.3 (6.14.6), 12.18.2 (6.14.5), 12.18.1 (6.14.5), 12.17.0 (6.14.4), 12.16.3 (6.14.4), 12.16.2 (6.14.4), 12.16.1 (6.13.4), 12.16.0 (6.13.4), 12.15.0 (6.13.4), 12.14.1 (6.13.4), 12.14.0 (6.13.4), 12.13.1 (6.12.1), 12.13.0 (6.12.0), 12.12.0 (6.11.3), 12.11.1 (6.11.3), 12.11.0 (6.11.3), 12.10.0 (6.10.3), 12.9.1 (6.10.2), 12.9.0 (6.10.2), 12.8.1 (6.10.2), 12.8.0 (6.10.2), 12.7.0 (6.10.0), 12.6.0 (6.9.0), 12.5.0 (6.9.0), 12.4.0 (6.9.0), 12.3.1 (6.9.0), 12.3.0 (6.9.0), 12.2.0 (6.9.0), 12.1.0 (6.9.0), 12.0.0 (6.9.0)

Version par défaut : 12.18.3

nginx 1.18.0 (par défaut), Apache 2.4.43

2.23.3

3.2.0

Node.js 10 AL2 version 5.2.1

64bit Amazon Linux 2 v5.2.1 running Node.js 10

2.0.20200827

10.22.0 (6.14.6), 10.21.0 (6.14.4), 10.20.1 (6.14.4), 10.20.0 (6.14.4), 10.19.0 (6.13.4), 10.18.1 (6.13.4), 10.18.0 (6.13.4), 10.17.0 (6.11.3), 10.16.3 (6.13.4), 10.16.2 (6.9.0), 10.16.1 (6.9.0), 10.16.0 (6.9.0), 10.15.3 (6.4.1), 10.15.2 (6.4.1), 10.15.1 (6.4.1), 10.15.0 (6.4.1), 10.14.2 (6.4.1), 10.14.1 (6.4.1), 10.14.0 (6.4.1), 10.13.0 (6.4.1), 10.12.0 (6.4.1), 10.11.0 (6.4.1), 10.10.0 (6.4.1), 10.9.0 (6.2.0), 10.8.0 (6.2.0), 10.7.0 (6.1.0), 10.6.0 (6.1.0), 10.5.0 (6.1.0), 10.4.1 (6.1.0), 10.4.0 (6.1.0), 10.3.0 (6.1.0), 10.2.1 (5.6.0), 10.2.0 (5.6.0), 10.1.0 (5.6.0), 10.0.0 (5.6.0)

Version par défaut : 10.22.0

nginx 1.18.0 (par défaut), Apache 2.4.43

2.23.3

3.2.0

Node.js version 4.15.2

64bit Amazon Linux 2018.03 v4.15.2 running Node.js

2018.03.0

12.18.3 (6.14.6), 12.18.2 (6.14.5), 12.18.1 (6.14.5), 12.18.0 (6.14.4), 12.16.3 (6.14.4), 12.16.2 (6.14.4), 12.16.1 (6.13.4), 12.15.0 (6.13.4), 12.14.1 (6.13.4), 12.14.0 (6.13.4), 10.22.0 (6.14.6), 10.21.0 (6.14.4), 10.20.1 (6.14.4), 10.20.0(6.14.4), 10.19.0 (6.13.4), 10.18.1 (6.13.4), 10.18.0 (6.13.4), 10.17.0 (6.11.3), 10.16.3 (6.9.0), 10.16.2 (6.9.0), 10.16.1 (6.9.0), 10.16.0 (6.9.0), 10.15.3 (6.4.1), 10.15.1 (6.4.1), 10.15.0 (6.4.1), 10.14.1 (6.4.1), 8.17.0 (6.13.4), 8.16.2 (6.4.1), 8.16.1 (6.4.1), 8.16.0 (6.4.1), 8.15.1 (6.4.1), 8.15.0 (6.4.1), 8.14.0 (6.4.1), 7.10.1 (4.2.0), 6.17.1 (3.10.10), 6.17.0 (3.10.10), 6.16.0 (3.10.10), 6.15.1 (3.10.10), 5.12.0 (3.8.6), 4.9.1 (2.15.11), 4.8.7 (2.15.11)

Version par défaut : 12.18.3

nginx 1.16.1, Apache 2.4.43

2.18.4

3.1.0

PHP

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

Composer

Serveur proxy

PHP 7.4 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running PHP 7.4

2.0.20200827

PHP 7.4.7

1.9.3

nginx 1.18.0 (par défaut), Apache 2.4.43

PHP 7.3 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running PHP 7.3

2.0.20200827

PHP 7.3.19

1.9.3

nginx 1.18.0 (par défaut), Apache 2.4.43

PHP 7.2 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running PHP 7.2

2.0.20200827

PHP 7.2.31

1.9.3

nginx 1.18.0 (par défaut), Apache 2.4.43

PHP 7.3 version 2.9.10

64bit Amazon Linux 2018.03 v2.9.10 running PHP 7.3

2018.03.0

PHP 7.3.21

1.9.0

Apache 2.4.46

PHP 7.2 version 2.9.10

64bit Amazon Linux 2018.03 v2.9.10 running PHP 7.2

2018.03.0

PHP 7.2.33

1.9.0

Apache 2.4.46

Python

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

Gestionnaire de package

Outil de création de package

meld3

AWS X‑Ray

Serveur proxy

Python 3.7 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Python 3.7

2.0.20200827

Python 3.7.8

pipenv 2020.8.13

3.2.0

nginx 1.18.0 (par défaut), Apache 2.4.43

Python 3.6 version 2.9.14

64bit Amazon Linux 2018.03 v2.9.14 running Python 3.6

2018.03.0

Python 3.6.12

pip 9.0.3

setuptools 28.8.0

meld3 1.0.2

3.1.0

Apache 2.4.46 avec mod_wsgi 3.5

Ruby

Version de plateforme et Solution Stack Name (Nom de la pile de solutions)

AMI

Langage

Gestionnaire de package

Serveur d'application

AWS X‑Ray

Serveur proxy

Ruby 2.7 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.7

2.0.20200827

Ruby 2.7.1-p83

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.6

2.0.20200827

Ruby 2.6.6-p146

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.5 AL2 version 3.1.1

64bit Amazon Linux 2 v3.1.1 running Ruby 2.5

2.0.20200827

Ruby 2.5.8-p224

RubyGems 3.1.4

Puma 4.3.5

3.2.0

nginx 1.18.0

Ruby 2.6 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.6 (Puma)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.6 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.6 (Passenger Standalone)

2018.03.0

Ruby 2.6.6-p146

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.5 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.5 (Puma)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.5 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.5 (Passenger Standalone)

2018.03.0

Ruby 2.5.8-p224

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1

Ruby 2.4 with Puma version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.4 (Puma)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Puma 2.16.0

3.1.0

nginx 1.16.1

Ruby 2.4 with Passenger version 2.11.10

64bit Amazon Linux 2018.03 v2.11.10 running Ruby 2.4 (Passenger Standalone)

2018.03.0

Ruby 2.4.10-p364

RubyGems 3.1.2

Passenger 4.0.60

3.1.0

nginx 1.16.1