Systèmes d'exploitation pris en charge - AWS Systems Manager

Systèmes d'exploitation pris en charge

Vous pouvez gérer les instances Amazon Elastic Compute Cloud (Amazon EC2) et les serveurs et machines virtuelles (VM) sur site, y compris les VM hébergées par d'autres fournisseurs de services cloud, en utilisant Systems Manager. Ces nœuds doivent exécuter l'un des systèmes d'exploitation suivants.

Note

Si vous envisagez de gérer et de configurer des appareils Core AWS IoT Greengrass à l'aide de Systems Manager, ces appareils doivent répondre aux exigences de AWS IoT Greengrass. Pour plus d'informations, consultez Configuration des appareils Core AWS IoT Greengrass dans le Guide du développeur AWS IoT Greengrass Version 2.

Si vous envisagez de gérer et de configurer AWS IoT et des appareils de périphérie non-AWS, ces appareils doivent répondre aux exigences répertoriées ici et être configurés en tant que nœuds gérés sur site pour Systems Manager. Pour plus d'informations, consultez Configuration de AWS Systems Manager pour les appareils de périphérie.

Linux

Amazon Linux
Versions x86 x86_64 ARM64
2012.03 – 2018.03
Note

À partir de la version 2015.03, Amazon Linux est publié en versions x86_64.

Amazon Linux 2
Versions x86 x86_64 ARM64
2.0 et toutes les versions ultérieures
CentOS
Versions x86 x86_64 ARM64
6.x¹
7.1 et versions 7.x ultérieures
Versions 8.0-8.5

¹ Pour utiliser ces versions, vous devez utiliser une version 3.0.x de SSM Agent. Nous recommandons d'utiliser la dernière version disponible 3.0.x de SSM Agent. Les versions ultérieures de SSM Agent (3.1 ou version ultérieure) ne sont pas prises en charge.

CentOS Stream
Versions x86 x86_64 ARM64
8
Debian Server
Versions x86 x86_64 ARM64
Jessie (8)
Stretch (9)
Buster (10)
Bullseye (11)
Oracle Linux
Versions x86 x86_64 ARM64
7.5 à 7.8
8.1 à 8.5
Red Hat Enterprise Linux (RHEL)
Versions x86 x86_64 ARM64
6.x¹
7.0 à 7.5
7.6 à 8.5

¹ Pour utiliser ces versions, vous devez utiliser une version 3.0.x de SSM Agent. Nous recommandons d'utiliser la dernière version disponible 3.0.x de SSM Agent. Les versions ultérieures de SSM Agent (3.1 ou version ultérieure) ne sont pas prises en charge.

Rocky Linux
Versions x86 x86_64 ARM64
8.4 à 8.5
SUSE Linux Enterprise Server (SLES)
Versions x86 x86_64 ARM64
12 et versions 12.x ultérieures
15 et versions 15.x ultérieures
Ubuntu Server
Versions x86 x86_64 ARM64
12.04 LTS et 14.04 LTS
16.04 LTS et 18.04 LTS
20.04 LTS et 20.10 STR

macOS

Version x86 x86_64 ARM64
10.14.x (Mojave)
10.15.x (Catalina)
11.x (BigSur)
12.x (Monterey)
Note

La prise en charge macOS est limitée aux Régions AWS suivantes :

  • USA Est (Virginie du Nord) (us-east-1)

  • USA Est (Ohio) (us-east-2)

  • USA Ouest (Oregon) (us-west-2)

  • Europe (Irlande) (eu-west-1)

  • Asie-Pacifique (Singapour) (ap-southeast-1)

Pour obtenir de plus amples informations sur la prise en charge d'Amazon EC2 pour macOS, veuillez consulter Instances Mac Amazon EC2 dans le Guide de l'utilisateur Amazon EC2 pour instances Linux.

Raspberry Pi OS (anciennement Raspbian)

Version ARM32
8 (Jessie)
9 (Stretch)

Windows Server

L'SSM Agent a besoin de Windows PowerShell 3.0 ou version ultérieure pour exécuter certains documents AWS Systems Manager (documents SSM) sur des instances Windows Server (par exemple, le document AWS-ApplyPatchBaseline hérité). Vérifiez que votre instance Windows Server exécute actuellement Windows Management Framework 3.0 ou une version ultérieure. Ce cadre inclut Windows PowerShell. Pour plus d'informations, consultez Windows Management Framework 3.0.

Version x86 x86_64 ARM64
2008¹
2008 R2¹
2012 et 2012 R2
2016
2019
2022

¹ À compter du 14 janvier 2020, Windows Server2008 n'est plus pris en charge pour les mises à jour de fonctions ou de sécurité de Microsoft. Les Amazon Machine Images (AMIs) héritées, pour Windows Server 2008 et 2008 R2, incluent toujours la version 2 de l'SSM Agent, mais Systems Manager ne prend plus officiellement en charge les versions 2008 et ne met plus à jour l'agent pour ces versions de Windows Server. En outre,SSM Agent version 3.0 peut ne pas être compatible avec toutes les opérations sur Windows Server2008 et 2008 R2. La version finale officiellement prise en charge de l'SSM Agent pour les versions Windows Server 2008 est 2.3.1644.0.