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Résolution des problèmes AWS Client VPN : l'accès à un Amazon S3VPC, à un service pair ou à Internet est intermittent
Problème
Je rencontre des problèmes de connectivité intermittents lorsque je me connecte à un réseau VPC pair, à Amazon S3 ou à Internet, mais l'accès aux sous-réseaux associés n'est pas affecté. Je dois me déconnecter et me reconnecter afin de résoudre les problèmes de connexion.
Cause
Les clients se connectent à un point de VPN terminaison client selon l'algorithme DNS Round-Robin. Cela signifie que leur trafic peut être acheminé par l'un des sous-réseaux associés lorsqu'ils établissent une connexion. Par conséquent, les clients peuvent rencontrer des problèmes de connexion s'ils accèdent à un sous-réseau associé qui ne possède pas les entrées d'itinéraire requises.
Solution
Vérifiez que le point de VPN terminaison du client possède les mêmes entrées de route avec des cibles pour chaque réseau associé. Cela garantit que les clients ont accès à toutes les routes, quel que soit le sous-réseau associé via lequel leur trafic est acheminé.
Supposons, par exemple, que votre point de VPN terminaison client possède trois sous-réseaux associés (sous-réseaux A, B et C) et que vous souhaitez permettre à vos clients d'accéder à Internet. Pour y arriver, vous devez ajouter trois routes 0.0.0.0/0
, chacune ciblant chaque sous-réseau associé:
-
Acheminement 1 :
0.0.0.0/0
pour le sous-réseau A -
Acheminement 2 :
0.0.0.0/0
pour le sous-réseau B -
Acheminement 3 :
0.0.0.0/0
pour le sous-réseau C