PackageVulnerabilityDetails - Inspector

PackageVulnerabilityDetails

Information about a package vulnerability finding.

Contents

cvss

An object that contains details about the CVSS score of a finding.

Type: Array of CvssScore objects

Required: No

referenceUrls

One or more URLs that contain details about this vulnerability type.

Type: Array of strings

Length Constraints: Minimum length of 1.

Required: No

relatedVulnerabilities

One or more vulnerabilities related to the one identified in this finding.

Type: Array of strings

Length Constraints: Minimum length of 1. Maximum length of 128.

Required: No

source

The source of the vulnerability information.

Type: String

Length Constraints: Minimum length of 1.

Required: Yes

sourceUrl

A URL to the source of the vulnerability information.

Type: String

Length Constraints: Minimum length of 1.

Required: No

vendorCreatedAt

The date and time that this vulnerability was first added to the vendor's database.

Type: Timestamp

Required: No

vendorSeverity

The severity the vendor has given to this vulnerability type.

Type: String

Length Constraints: Minimum length of 1.

Required: No

vendorUpdatedAt

The date and time the vendor last updated this vulnerability in their database.

Type: Timestamp

Required: No

vulnerabilityId

The ID given to this vulnerability.

Type: String

Length Constraints: Minimum length of 1. Maximum length of 128.

Required: Yes

vulnerablePackages

The packages impacted by this vulnerability.

Type: Array of VulnerablePackage objects

Required: No

See Also

For more information about using this API in one of the language-specific AWS SDKs, see the following: