

Le traduzioni sono generate tramite traduzione automatica. In caso di conflitto tra il contenuto di una traduzione e la versione originale in Inglese, quest'ultima prevarrà.

# Protocolli e cifrari supportati tra visualizzatori e CloudFront
<a name="secure-connections-supported-viewer-protocols-ciphers"></a>

Quando [ richiedi l'HTTPS tra gli spettatori e la tua CloudFront distribuzione](DownloadDistValuesCacheBehavior.md#DownloadDistValuesViewerProtocolPolicy), devi scegliere una politica di [ sicurezza che determini le ](DownloadDistValuesGeneral.md#DownloadDistValues-security-policy) seguenti impostazioni:
+ Il SSL/TLS protocollo minimo CloudFront utilizzato per comunicare con gli spettatori.
+ I cifrari che è CloudFront possibile utilizzare per crittografare la comunicazione con gli spettatori.

Per scegliere una policy di sicurezza, specifica il valore applicabile per [Politica di sicurezza ( SSL/TLS versione minima)](DownloadDistValuesGeneral.md#DownloadDistValues-security-policy). La tabella seguente elenca i protocolli e i codici che è CloudFront possibile utilizzare per ciascuna politica di sicurezza.

Un visualizzatore deve supportare almeno una delle crittografie supportate con cui stabilire una connessione HTTPS. CloudFront CloudFront sceglie un codice nell'ordine elencato tra i cifrari supportati dal visualizzatore. Consulta anche [Nomi di cifratura OpenSSL, s2n e RFC](#secure-connections-openssl-rfc-cipher-names).


<table>
<thead>
  <tr><th></th><th colspan="9">Policy di sicurezza</th></tr>
  <tr><th></th><th>SSLv3</th><th>TLSv1</th><th>TLSv1_2016</th><th>TLSv1.1_2016</th><th>TLSv1.2_2018</th><th>TLSv1.2_2019</th><th>TLSv1.2_2021</th><th>TLSv1.2_2025</th><th>TLSv1.3_2025</th></tr>
</thead>
<tbody>
  <tr><td colspan="10"><b>Protocolli supportati SSL/TLS </b></td></tr>
  <tr><td>TLSv1.3</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLSv1.2</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td></tr>
  <tr><td>TLSv1.1</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>TLSv1</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>SSLv3</td><td>♦</td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td colspan="10"><b> TLSv1.3 Cifrari supportati </b></td></tr>
  <tr><td>TLS_AES_128_GCM_SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_AES_256_GCM_SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_CHACHA20_POLY1305_SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td>♦</td></tr>
  <tr><td colspan="10"><b>Crittografie ECDSA supportate</b></td></tr>
  <tr><td>ECDHE-ECDSA-AES128-GCM-SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td></tr>
  <tr><td>ECDHE-ECDSA-AES128-SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td></tr>
  <tr><td>ECDHE-ECDSA-AES128-SHA</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>ECDHE-ECDSA-AES256-GCM-SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td></tr>
  <tr><td>ECDHE-ECDSA-CHACHA20-POLY1305</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td></tr>
  <tr><td>ECDHE-ECDSA-AES256-SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td></tr>
  <tr><td>ECDHE-ECDSA-AES256-SHA</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td colspan="10"><b>Crittografie RSA supportate</b></td></tr>
  <tr><td>ECDHE-RSA-AES128-GCM-SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td></tr>
  <tr><td>ECDHE-RSA-AES128-SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td></tr>
  <tr><td>ECDHE-RSA-AES128-SHA</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>ECDHE-RSA-AES256-GCM-SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td></tr>
  <tr><td>ECDHE-RSA-CHACHA20-POLY1305</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td></tr>
  <tr><td>ECDHE-RSA-AES256-SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td></tr>
  <tr><td>ECDHE-RSA-AES256-SHA</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>AES128-GCM-SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td></tr>
  <tr><td>AES256-GCM-SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td></tr>
  <tr><td>AES128-SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td></tr>
  <tr><td>AES256-SHA</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>AES128-SHA</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>DES-CBC3-SHA</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>RC4-MD5</td><td>♦</td><td></td><td></td><td></td><td></td><td></td><td></td><td></td><td></td></tr>
</tbody>
</table>


## Nomi di cifratura OpenSSL, s2n e RFC
<a name="secure-connections-openssl-rfc-cipher-names"></a>

OpenSSL e [s2n](https://github.com/awslabs/s2n) utilizzano nomi diversi per i cifrari rispetto agli standard TLS ([RFC 2246](https://tools.ietf.org/html/rfc2246), [RFC 4346](https://tools.ietf.org/html/rfc4346), [RFC 5246](https://tools.ietf.org/html/rfc5246) e [RFC 8446](https://tools.ietf.org/html/rfc8446)). La tabella seguente mappa i nomi OpenSSL e s2n al nome RFC per ogni crittografia.

CloudFront supporta lo scambio di chiavi classico e quantistico. Per gli scambi di chiavi classici che utilizzano curve ellittiche, supporta quanto segue: CloudFront 
+ `prime256v1`
+ `X25519`
+ `secp384r1`

Per gli scambi di chiavi sicuri dal punto di vista quantistico, supporta quanto segue: CloudFront 
+ `X25519MLKEM768`
+ `SecP256r1MLKEM768`
**Nota**  
Quantum-safe gli scambi di chiavi sono supportati solo con TLS 1.3. TLS 1.2 e versioni precedenti non supportano gli scambi di chiavi sicuri dal punto di vista quantistico.

  Per ulteriori informazioni, consulta i seguenti argomenti:
  + [Post-Quantum Crittografia ](https://aws.amazon.com/security/post-quantum-cryptography/)
  + [Algoritmi di crittografia e Servizi AWS](https://docs.aws.amazon.com/prescriptive-guidance/latest/encryption-best-practices/aws-cryptography-services.html#algorithms)
  + [Scambio di chiavi ibrido in TLS 1.3](https://datatracker.ietf.org/doc/draft-ietf-tls-hybrid-design/)

Per ulteriori informazioni sui requisiti dei certificati per CloudFront, vedere. [Requisiti per l'utilizzo SSL/TLS dei certificati con CloudFront](cnames-and-https-requirements.md)


<table>
<thead>
  <tr><th>Nome cifrato OpenSSL e s2n</th><th>Nome crittografia RFC</th></tr>
</thead>
<tbody>
  <tr><td colspan="2"><b> TLSv1.3 Cifrari supportati </b></td></tr>
  <tr><td>TLS_AES_128_GCM_SHA256</td><td>TLS_AES_128_GCM_SHA256</td></tr>
  <tr><td>TLS_AES_256_GCM_SHA384</td><td>TLS_AES_256_GCM_SHA384</td></tr>
  <tr><td>TLS_CHACHA20_POLY1305_SHA256</td><td>TLS_CHACHA20_POLY1305_SHA256</td></tr>
  <tr><td colspan="2"><b>Crittografie ECDSA supportate</b></td></tr>
  <tr><td>ECDHE-ECDSA-AES128-GCM-SHA256</td><td>TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256</td></tr>
  <tr><td>ECDHE-ECDSA-AES128-SHA256</td><td>TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256</td></tr>
  <tr><td>ECDHE-ECDSA-AES128-SHA</td><td>TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA</td></tr>
  <tr><td>ECDHE-ECDSA-AES256-GCM-SHA384</td><td>TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384</td></tr>
  <tr><td>ECDHE-ECDSA-CHACHA20-POLY1305</td><td>TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256</td></tr>
  <tr><td>ECDHE-ECDSA-AES256-SHA384</td><td>TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384</td></tr>
  <tr><td>ECDHE-ECDSA-AES256-SHA</td><td>TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA</td></tr>
  <tr><td colspan="2"><b>Crittografie RSA supportate</b></td></tr>
  <tr><td>ECDHE-RSA-AES128-GCM-SHA256</td><td>TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256</td></tr>
  <tr><td>ECDHE-RSA-AES128-SHA256</td><td>TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256 </td></tr>
  <tr><td>ECDHE-RSA-AES128-SHA</td><td>TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA</td></tr>
  <tr><td>ECDHE-RSA-AES256-GCM-SHA384</td><td>TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 </td></tr>
  <tr><td>ECDHE-RSA-CHACHA20-POLY1305</td><td>TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256</td></tr>
  <tr><td>ECDHE-RSA-AES256-SHA384</td><td>TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384 </td></tr>
  <tr><td>ECDHE-RSA-AES256-SHA</td><td>TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA</td></tr>
  <tr><td>AES128-GCM-SHA256</td><td>TLS_RSA_WITH_AES_128_GCM_SHA256</td></tr>
  <tr><td>AES256-GCM-SHA384</td><td>TLS_RSA_WITH_AES_256_GCM_SHA384</td></tr>
  <tr><td>AES128-SHA256</td><td>TLS_RSA_WITH_AES_128_CBC_SHA256</td></tr>
  <tr><td>AES256-SHA</td><td>TLS_RSA_WITH_AES_256_CBC_SHA</td></tr>
  <tr><td>AES128-SHA</td><td>TLS_RSA_WITH_AES_128_CBC_SHA</td></tr>
  <tr><td>DES-CBC3-SHA </td><td>TLS_RSA_WITH_3DES_EDE_CBC_SHA </td></tr>
  <tr><td>RC4-MD5</td><td>TLS_RSA_WITH_RC4_128_MD5</td></tr>
</tbody>
</table>


## Schemi di firma supportati tra visualizzatori e CloudFront
<a name="secure-connections-viewer-signature-schemes"></a>

CloudFront supporta i seguenti schemi di firma per le connessioni tra visualizzatori e. CloudFront


<table>
<thead>
  <tr><th></th><th colspan="9">Policy di sicurezza</th></tr>
  <tr><th>Schemi di firma</th><th>SSLv3</th><th>TLSv1</th><th>TLSv1_2016</th><th>TLSv1.1_2016</th><th>TLSv1.2_2018</th><th>TLSv1.2_2019</th><th> TLSv1.2_2021</th><th>TLSv1.2_2025</th><th>TLSv1.3_2025</th></tr>
</thead>
<tbody>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PSS_PSS_SHA512</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PSS_RSAE_SHA512</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA512</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA224</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_ECDSA_SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_ECDSA_SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_ECDSA_SHA512</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_ECDSA_SHA224</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_ECDSA_SECP256R1_SHA256</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_ECDSA_SECP384R1_SHA384</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_RSA_PKCS1_SHA1</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
  <tr><td>TLS_SIGNATURE_SCHEME_ECDSA_SHA1</td><td>♦</td><td>♦</td><td>♦</td><td>♦</td><td></td><td></td><td></td><td></td><td></td></tr>
</tbody>
</table>
