Correzioni - Note di rilascio di Lumberyard

Correzioni

Lumberyard Beta 1.1 include le seguenti correzioni:

Asset Processor (Elaboratore asset)

  • È stato risolto un problema che causava l'uscita del batch della funzionalità Asset Processor (Elaboratore asset) (Elaboratore asset) prima dello svuotamento della coda.

  • È stato risolto un problema che causava l'arresto anomalo del batch della funzionalità Asset Processor (Elaboratore asset) e l'annullamento di AZ::Environment.

  • È stato risolto un problema con il messaggio di errore del batch della funzionalità Asset Processor (Elaboratore asset) (Elaboratore asset) che impediva il ritorno del controllo al processo principale.

  • È stato risolto un problema che impediva l'uscita immediata dalla funzionalità Asset Processor (Elaboratore asset) (Elaboratore asset).

  • È stato risolto un problema relativo al file system virtuale (VFS) che causava l'arresto anomalo della funzionalità Asset Processor (Elaboratore asset) (Elaboratore asset).

  • È stato risolto un problema relativo all'elaborazione prematura di file che causava errori nella funzionalità Asset Processor (Elaboratore asset) (Elaboratore asset).

  • La funzionalità Asset Processor (Elaboratore asset) (Elaboratore asset) è stata modificata in modo da essere eseguita in background finché l'applicazione non vi accede.

  • Il programma di avvio di Lumberyard (ora denominato Setup Assistant (Assistente configurazione)) è stato aggiornato in modo che non si verifichi più l'arresto anomalo quando viene eseguito il programma di avvio del progetto Samples prima della funzionalità Asset Processor (Elaboratore asset).

Audio

  • È stato corretto un bug relativo al plugin Perforce che impediva di contrassegnare i file per l'eliminazione durante l'eliminazione delle librerie audio nella finestra Audio Controls Editor (Editor controlli audio).

  • È stato corretto un bug che impediva la corretta impostazione dei valori OcclusionObstructionCalculationType.

  • È stato corretto un bug che impediva alle forme dell'area audio di impostare il valore OcclusionObstructionCalculationType corretto in fase di inizializzazione.

  • È stato risolto un problema di serializzazione degli stati dei parametri nella finestra Audio Controls Editor (Editor controlli audio) che causava la duplicazione degli stati.

  • È stato risolto un problema con le entità audio che causava la riproduzione continua di suoni in loop durante il caricamento dei livelli.

Cinematica

  • È stato risolto un problema nella funzionalità Track View che impediva alle funzionalità Add/Delete Nodes (Aggiungi/Elimina nodi) e Add/Delete/Modify Track Events (Aggiungi/Elimina/Modifica eventi traccia) di contrassegnare correttamente un livello come livello da salvare.

  • È stato risolto un problema nella finestra di dialogo Render Output (Output di rendering) che causava il rendering continuo dei fotogrammi delle sequenze con il parametro Out of Range (Fuori intervallo) impostato su Constant (Costante).

  • È stato risolto un problema nella funzionalità Track View (Editor visualizzazione tracce) che visualizzava in modo errato la disattivazione audio di tracce il cui audio non era disattivabile.

Cloud Canvas

  • Il flag Apply (Applica) è stato rimosso dai nodi Cloud Canvas ConfigureProxy e SetDefaultRegion.

  • Le porte Success (Operazione riuscita) duplicate sono state rimosse dai nodi che ereditano da BaseMaglevFlowNode, compresi i nodi Cloud Canvas SetConfigurationVariable e GetConfigurationVariable.

  • Il nodo di scansione di Amazon DynamoDB è stato aggiornato in modo che utilizzi la stessa chiamata StringLabel della query.

  • Il valore di default del modello di caratteristica per le tabelle DynamoDB è stato aggiornato a 1 per la capacità di lettura/scrittura. I valori della tabella per il progetto Don't Die (Non morire) sono impostati su 2 tramite la sostituzione nel file project-settings.json.

  • Le barre rovesciate dell'espressione regolare sono state aggiornate a \\ nel nodo di flusso SNSSubscribe.

  • È stato risolto un problema di deallocazione della memoria che causava l'arresto anomalo dell'editor o un'istruzione Assert durante la fase di arresto.

  • L'integrazione dell'SDK C++ AWS in Lumberyard è stata rielaborata per evitare l'utilizzo del concetto di "caratteristica", che creava inclusioni non necessarie durante la compilazione e il collegamento.

  • Per il nodo di flusso SNSParseMessage è stato eseguito il debug in modo da notificare l'operazione riuscita e l'errore e la conformità con gli schemi correnti mediante una porta di attivazione esplicita e un'unica porta di errore. Lo strumento di polling SQS ora attiva il segnale di operazione riuscita alla ricezione del messaggio.

  • È stato risolto un problema che causava l'errato annullamento della registrazione di CBreakPointsTreeCtrl dal debugger del grafico dei flussi e il conseguente arresto anomalo durante l'aggiunta di un punto di interruzione a un flusso di nodo.

  • È stato risolto un problema nella funzionalità Flow Graph (Grafico flussi) che causava l'inversione dei nodi di input e output e conseguentemente collisioni errate. Ciò si verificava durante il caricamento e il controllo dei collegamenti duplicati.

Flow Graph (Grafico flussi)

  • È stato rimosso un grafico dei flussi non valido che veniva visualizzato quando veniva caricato un nuovo livello durante la modifica di un grafico dei flussi.

  • È stato corretto il menu contestuale nella visualizzazione della struttura ad albero. Ora le operazioni disponibili sono rappresentate correttamente.

  • È stato risolto un problema a causa del quale il tasto Delete (Canc) eliminava il nodo selezionato durante la modifica dei commenti o la ridenominazione dei nodi.

Pacchetti gem

  • Ora tutti i pacchetti gem, compreso il codice, vengono inclusi quando distribuisci le build monolitiche.

  • È stata rimossa una dipendenza errata dal pacchetto gem Rain (Pioggia) in EmptyTemplate.

  • I vari miglioramenti implementati nel sistema di compilazione dei sistemi di pacchetti gem includono:

    • Refactoring del gestore di pacchetti gem per convalidare la dipendenza dei pacchetti gem di un progetto durante l'uso di lmbr_waf configure invece del runtime.

    • Aggiunta di convalide per il tipo di formato dei file.

    • Aggiunta della gestione degli errori per stringhe di UUID con formato non valido.

Geppetto

  • È stato risolto un problema relativo all'aggiornamento del filtro di animazione per un file chrparams, che impediva il ripopolamento dell'elenco del browser di file nello strumento.

  • L'opzione Show in Explorer (Mostra in Explorer) del menu contestuale è stata corretta.

  • È stato risolto un problema che impediva l'aggiornamento della visualizzazione della funzionalità File Explorer (Esplora file) in caso di aggiunta di un file i_caf.

  • È stato risolto un problema che permetteva la cancellazione dell'assegnazione dell'alias della struttura scheletrica per un file i_caf durante l'elaborazione degli asset.

  • È stato risolto un problema che impediva l'aggiunta di asset di pacchetti gem alla visualizzazione della funzionalità File Explorer (Esplora file).

  • È stato risolto un problema che causava l'arresto anomalo della funzionalità Lumberyard Editor (Editor Lumberyard) (Editor Lumberyard) in caso di passaggio al livello superiore alla radice del motore nel browser di file.

Lumberyard Editor (Editor Lumberyard)

  • È stato risolto un problema relativo all'esportazione FBX dalla funzionalità Lumberyard Editor (Editor Lumberyard) (Editor Lumberyard). Tale processo di esportazione risultava non riuscito in modo invisibile all'utente.

  • È stato risolto un problema nella finestra Terrain Texture Layers (Livelli texture terreno) che impediva alla funzionalità Rollup Bar (Barra rollup) di rilevare eventuali modifiche di nome applicate ai livelli.

  • Non si verifica più l'arresto anomalo dell'editor:

    • Durante l'avvio di un progetto per la prima volta e la chiusura della finestra Lumberyard Editor (Editor Lumberyard) (Editor Lumberyard).

    • Durante la selezione di file da altre ramificazioni all'interno dell'elenco Recent Files (File recenti).

    • Durante il processo di uscita se stai creando un nuovo livello utilizzando un nuovo progetto creato.

    • Quando fai clic su Smooth Terrain (Uniforma terreno) nella finestra Terrain Editor (Editor terreno), a causa di sovrascritture di memoria.

    • Quando apri la visualizzazione del database.

    • Dopo aver eseguito Move Area (Sposta area) due volte con l'opzione Hold (Blocca).

    • Quando cerchi di impostare il livello di dettaglio di origine senza prima impostare un file CGF di origine.

    • Quando utilizzi determinati comandi della console.

    • In modalità di debug durante la configurazione del layout per più viewport.

    • Durante la modifica degli oggetti in un gruppo di elementi di vegetazione uniti automaticamente.

    • Quando abiliti il terreno con ombra automatica.

    • Durante la creazione di una nuova entità.

  • È stato risolto un problema che causava il salvataggio dei livelli in una posizione errata.

  • È stato risolto un problema che impediva l'inserimento di commenti nella visualizzazione 3D.

  • È stato risolto un problema che impediva la visualizzazione dei livelli recentemente aperti nel menu File.

  • È stato risolto un problema che causava l'errato dimensionamento degli oggetti durante lo spostamento tra le caselle di testo XYZ mediante il tasto Tab.

  • È stato risolto un problema che impediva l'aggiornamento delle caselle di testo XYZ quando un oggetto nella scena veniva spostato, dimensionato o ruotato.

  • È stato risolto un problema che impediva il dimensionamento uniforme durante l'immissione manuale di un valore di scala per un oggetto impostato per il blocco dei valori XYZ.

  • È stato risolto un problema relativo al caricamento iniziale del livello Camera_Sample che faceva sì che palloncini volassero in cielo mentre la sfera a cui erano collegati rimaneva immobile.

  • È stato risolto un problema che causava il funzionamento errato dell'anteprima del campione della sonda ambientale.

  • È stato risolto un problema che causava il rendering in colore nero dell'opzione di anteprima della sonda ambientale.

  • È stato risolto un problema relativo all'apertura del riquadro Sun Trajectory (Traiettoria sole) che causava lo spostamento automatico della posizione del sole.

  • È stato risolto un problema relativo all'apertura della finestra Texture Browser (Browser texture) che causava il mancato rilevamento di blocchi estesi e più file.

  • È stato risolto un problema che impediva il corretto ricaricamento delle texture di piccole dimensioni (32x32 o meno) e faceva sì che le texture venissero visualizzate in nero.

Programma di avvio di Lumberyard (ora Assistente configurazione)

  • La funzionalità è stata migliorata grazie a numerosi aggiornamenti dell'esperienza utente.

  • Per l'esecuzione della funzionalità Lumberyard Editor (Editor Lumberyard) (Editor Lumberyard) ora è necessario disporre di Python.

  • Clang è stato rimosso dalla cartella3rdParty. Per compilare lo strumento di generazione del codice, devi scaricare Clang dalla pagina di download di Amazon Lumberyard.

Material Editor

  • È stato risolto un problema che causava una riduzione significativa della frequenza dei fotogrammi nel viewport.

  • È stato risolto un problema che impediva il rendering dei campioni se Material Editor era aperto durante lo spostamento tra livelli.

Strumenti Lumberyard in Maya

  • È stato corretto un bug che impediva a Maya di scrivere file MTL nei percorsi di cartella non esistenti.

  • È stato corretto un bug relativo all'aggiornamento che faceva sì che i vecchi dati di animazione Maya aggiornassero il fotogramma finale impostandolo su un valore pari a zero anziché sul valore originale.

Reti

  • È stato risolto un problema che impediva la corretta connessione dei client a una sessione Amazon GameLift.

  • È stato risolto un problema che causava l'arresto anomalo del secondo client durante l'esecuzione di mphost su un computer client con un altro client già ospitato.

  • È stato risolto un problema che causava la creazione di entità GameRules duplicate da parte di GridMate durante la connessione a un server.

Particle Editor (Editor di particelle)

  • È stato risolto un problema che causava l'errato funzionamento della funzionalità di ricerca di smart file nella finestra Import (Importa), anche in presenza di file memorizzati nella directory \Libs\Particles.

  • È stato risolto un problema che generava un messaggio di errore durante la creazione di un elemento in Particle Editor (Editor di particelle).

  • È stato risolto un problema che causava l'aggiunta di set di impostazioni duplicati quando una libreria di gradienti veniva caricata più volte in Gradient Editor (Editor gradienti).

  • È stato risolto un problema che causava l'errato funzionamento della funzionalità Orient To Velocity (Orientamento in base a velocità).

  • È stato risolto un problema relativo a Particle Editor (Editor di particelle), ovvero la perdita di 3 MB di memoria ogni volta che viene aperto e chiuso.

  • È stato risolto un problema che impediva la corretta importazione di una libreria di particelle esportata. Il file XML ora può essere importati come previsto.

  • È stato risolto un problema che impediva il corretto funzionamento della clip alfa.

  • È stato risolto un problema che impediva la corretta attivazione degli emettitori di particelle continui con l'opzione Remain While Visible (Visualizza quando visibile) abilitata.

  • È stato risolto un problema di ridenominazione degli emettitori di particelle nella libreria in cui non era possibile utilizzare 0 nel nome.

  • È stata rimossa l'opzione Focus (Stato attivo) dal menu File perché non funzionava.

  • È stato risolto un problema che impediva il salvataggio delle librerie di particelle vuote.

  • È stato risolto un problema che impediva il corretto caricamento delle librerie di particelle se tali librerie non erano presenti nella directory \Libs\Particles.

  • È stato risolto un problema che impediva ai nomi delle opzioni del menu View (Visualizza) di riportare lo stato del riquadro quando il riquadro veniva chiuso mediante un altro menu.

  • È stato risolto un problema che causava la visualizzazione di un messaggio di errore durante il tentativo di importazione di una libreria di particelle in modalità Normal (Normale).

Project Configurator (Configuratore progetto)

  • La funzionalità è stata migliorata grazie a numerosi aggiornamenti dell'esperienza utente.

  • La funzionalità Project Configurator (Configuratore progetto) è stata aggiornata in modo che venga creato un file user_settings.options vuoto se non ne è stato ancora creato uno. Ad esempio questa situazione si verifica se esegui la funzionalità Project Configurator (Configuratore progetto) prima di eseguire lmbr_waf configure.

Twitch ChatPlay

  • È stata aggiunta la logica di selezione del nuovo server IRC Twitch per risolvere un problema che causava il malfunzionamento di Twitch ChatPlay per determinati canali con traffico elevato.

UI Editor (Editor IU)

  • È stato risolto un problema a causa del quale se premevi Ctrl+Z le operazioni venivano annullate sia in UI Editor (Editor IU) sia nell'editor Flow Graph (Grafico flussi).

  • È stato risolto un problema che causava il tentativo da parte di UI Editor (Editor IU) di annullare le modifiche anche in assenza di modifiche.

  • È stato risolto un problema che faceva sì che le funzionalità Undo (Annulla) e Redo (Ripeti) erroneamente aggiungessero gli elementi selezionati.

  • È stato risolto un problema di ritardo con lo strumento di selezione delle aree.

  • È stato risolto un problema di visualizzazione nello sprite Border Editor (Editor bordi) che rendeva quasi invisibili le linee superiori e a sinistra.

  • È stato risolto un problema che consentiva il salvataggio dei prefab con estensioni o posizioni non valide.

  • È stato risolto un problema che causava la visualizzazione di avvisi del lettore XML dopo l'apertura del livello UiDemo. Gli avvisi del lettore XML veicolavano erroneamente il messaggio relativo all'incapacità di individuare i file sprite, ovvero file facoltativi.

  • Sono state corrette la combinazione Ctrl+trascinamento e la funzionalità di selezione in modo che funzionino in modo identico in UI Editor (Editor IU) e Lumberyard Editor (Editor Lumberyard).

  • È stato modificato UI Editor (Editor IU) in modo che le istruzioni di esempio relative all'interfaccia utente non rimangano visualizzate in caso di caricamento consecutivo dei livelli.

  • È stata impostata la visualizzazione compressa di tutti gli elementi del livello radice in caso di caricamento dei canvas.

Varie

  • Sono stati modificati i flag di runtime per risolvere i problemi riscontrati in caso di tentativo di compilazione di un progetto con bld.LumberyardApp(…). I runtime non sono compatibili e generano errori se usi una libreria statica Lumberyard.

  • È stato risolto un arresto anomalo nella modalità di profiling.

  • È stato risolto un problema che impediva la ricompilazione di una compilazione di texture non riuscita.

  • Sono stati corretti gli adeguamenti del percorso fisso invisibile quando lavori esternamente al progetto corrente.

  • È stato risolto un problema relativo alla restituzione di percorsi non normalizzati da parte di Path::GamePathToFullPath.

  • È stato risolto un problema che impediva l'abilitazione della modalità di gioco durante la creazione di una mappa per la prima volta.

  • È stato risolto un problema a livello di script Python che causava l'apertura della finestra Show in Explorer (Mostra in Explorer) nella cartella utente anziché nella posizione dello script.

  • È stato risolto un problema che impediva alla modalità stereo e all'interfaccia utente di output di impostare valori qualsiasi. In passato solo variabili della console potevano impostare valori qualsiasi.

  • È stato risolto un problema che causava l'arresto anomalo di Game SDK Launcher (GameSDKLauncher.exe) se il livello Woodland (Area boschiva) veniva caricato due volte di seguito.

  • È stato risolto un problema che causava un errore di simbolo ambiguo in caso di utilizzo dello spazio dei nomi AZ.

  • È stato risolto un problema che causava l'arresto anomalo della funzionalità Debug Editor (Editor debug) quando ancoravi una finestra al viewport.

  • È stato risolto un problema che impediva l'esecuzione del rendering della griglia e dell'asse in OpreviewModelCtrl.

  • È stato corretto un problema che causava la visualizzazione del seguente errore quando un client multiplayer si connetteva a un server dedicato: "[Error] some merged meshes failed to prepare properly" ([Errore] Impossibile preparare correttamente alcune mesh unite).