Miglioramenti e modifiche - Note di rilascio di Lumberyard

Miglioramenti e modifiche

Questa release di Lumberyard include numerosi aggiornamenti a livello di sistemi e caratteristiche:

Audio

  • Gli aggiornamenti del programma di installazione di Wwise LTX includono l'aggiunta di un componente SDK Windows per vc140 e la rimozione dello strumento FilePackager non necessario dagli esempi.

Personaggi e animazioni

  • FBX Settings (Impostazioni FBX)

    • Lumberyard ora supporta l'importazione di più mesh FBX come singola mesh CGF e la generazione di gruppi di materiali che compongono un file CGF multimesh da FBX Settings (Impostazioni FBX).

    • Ora puoi includere colori dei vertici nelle mesh CGF generate tramite la pipeline FBX Settings (Impostazioni FBX).

    • Ora puoi impostare la posizione e la rotazione di mesh e mesh secondarie CGF in relazione al mondo o a nodi specifici in una scena FBX.

    • Viene visualizzata la reportistica sull'avanzamento durante l'importazione di asset mediante l'opzione FBX Settings (Impostazioni FBX).

    • L'esperienza di selezione dei nodi per la scelta di mesh in FBX Settings (Impostazioni FBX) è stata migliorata.

  • Ricaricamento in tempo reale delle animazioni

    • Lumberyard ora supporta il ricarico completo in tempo reale delle animazioni CAF in Geppetto in modo da poter visualizzare subito le nuove animazioni nella modalità di gioco di Lumberyard Editor (Editor Lumberyard), nonché giochi per PC creati utilizzando Lumberyard.

Cloud Canvas

  • Il concetto di feature (caratteristica) tipico di Cloud Canvas Resource Manager (Gestore risorse di Cloud Canvas) ora è denominato resource group (gruppo di risorse).

Modello vuoto

  • Il comportamento della procedura di arresto per i giochi creati utilizzando un modello vuoto è stato migliorato.

  • Varie funzioni in IActor ora dispongono di documentazione.

  • Le funzioni di stile GameInit() e GameShutdown() non sono più incluse in EmptyTemplate.

  • I file di prototipo non utilizzati non sono più inclusi in EmptyTemplate.

Grafica e rendering

  • La qualità dell'effetto mosso è stata migliorata mediante uno schema di ponderazione di esempio avanzato che migliora la qualità delle sagome. La quantità dell'effetto mosso ora è controllata mediante le impostazioni della velocità dell'otturatore reale, ad esempio 1/125s.

  • Maggiore levigatezza, ruvidità e lucidità mediante una funzione quadratica per mappare i valori. Ciò permette di ottenere risultati più lineari e di utilizzare dati di ruvidità scansionati.

  • È stata migliorata la modalità di esposizione automatico che funziona con EV. Puoi abilitare questa modalità utilizzando r_HDREyeAdaptationMode.

  • È stata aggiornata l'intensità solare da specificare in lux e in modo da garantire che il colore del sole non influenzi l'intensità. La compatibilità con le versioni precedenti è supportata e i valori esistenti vengono convertiti automaticamente.

  • È stato ridotto l'effetto dell'ombreggiatura Fresnel quando la riflettanza superficiale è minore del due percento. Ciò risulta utile per l'occlusione speculare e consente di ridurre manualmente l'effetto speculare su terreno e vegetazione, laddove appare troppo evidente.

  • La funzionalità glow (bagliore) è stata rimossa e sostituita con la funzionalità emittance (emittanza) per l'illuminazione delle scene:

    • L'illuminazione emissiva è stata aggiunta all'illuminazione diffusa e speculare per una superficie.

    • Il colore di emissività è un moltiplicatore delle mappe di emissività.

    • Il controllo gamma permette un intervallo maggiore di valori per le mappe di emittanza.

    • I materiali che precedentemente utilizzavano la funzionalità glow (bagliore) verranno automaticamente convertiti nella modalità emissive (emissività), che può modificare il colore del bagliore.

  • Sono state rimosse le seguenti variabili della console obsolete: r_HDRBrightOffset, r_HDRBrightThreshold, r_HDRBrightLevel, r_HDREyeAdaptationFactor, r_HDREyeAdaptationBase.

Programma di installazione Lumberyard

  • Il testo di benvenuto nella prima pagina è stato aggiornato in modo da semplificare l'identificazione delle aspettative a livello di interazioni.

  • Il pulsante Close (Chiudi) nella prima pagina è stato rinominato in Cancel (Annulla).

Lumberyard Setup Assistant (Assistente configurazione Lumberyard)

  • La finestra Lumberyard Setup Assistant (Assistente configurazione Lumberyard) (Assistente configurazione Lumberyard) ora viene aggiornata automaticamente in caso di modifica della directory di terze parti. In passato, Lumberyard Setup Assistant (Assistente configurazione Lumberyard) (Assistente configurazione Lumberyard) richiedeva l'aggiornamento manuale per rilevare una modifica apportata al percorso della directory di terze parti e al software installato.

  • Lumberyard Setup Assistant (Assistente configurazione Lumberyard) ora si chiude automaticamente se si apre Project Configurator (Configuratore progetto) o Lumberyard Editor (Editor Lumberyard) dalla pagina Summary (Riepilogo).

  • Ora puoi selezionare il testo nelle descrizioni dei software. In questo modo vengono semplificate le procedure di Copia/Incolla delle istruzioni e di creazione dei percorsi delle directory.

  • Il nuovo testo descrittivo spiega che il programma di installazione di Microsoft Foundation Class (MFC) non funziona se Visual Studio è installato senza MFC.

  • Vari aggiornamenti dell'interfaccia utente includono lo spostamento del pulsante Browse (Sfoglia) nella descrizione del software, la rimozione del pulsante Refresh (Aggiorna) dalla pagina Get started (Nozioni di base) e la visualizzazione di un segno di spunta verde e dello stato Found (Trovato) per il software opzionale installato correttamente.

Mobile

  • HLSLCrossCompiler è stato aggiornato per la compilazione in Visual Studio 2015.

  • Le prestazioni di rendering sono state migliorate mediante l'incremento della frequenza dei fotogrammi del 15%.

  • È stata aggiunta la compressione ASTC (Adaptive Scalable Texture Compression), che garantisce un maggiore controllo dello spazio e delle qualità dell'applicazione e una migliore qualità complessiva a una percentuale di compressione superiore se confrontata ad altri formati compressi.

  • È stata rimossa la ricerca ricorsiva di SDK nella funzionalità Lumberyard Setup Assistant (Assistente configurazione Lumberyard) (Assistente configurazione Lumberyard) per Android. Assicurati di eseguire di nuovo Lumberyard Setup Assistant (Assistente configurazione Lumberyard) dopo l'installazione di Lumberyard 1.3 per garantire la corretta configurazione dei percorsi.

Reti

  • La configurazione di rete (ad esempio Port, DisconnectDetection e ConnectionTimeout) ora è esposta ai nodi del flusso.

  • Il pacchetto gem Multiplayer ora include la funzionalità richiesta per Amazon GameLift. Non utilizzare sia il pacchetto gem Multiplayer che il pacchetto gem GameLift.

Project Configurator (Configuratore progetto)

  • Project Configurator (Configuratore progetto) ora richiama l'interfaccia a riga di comando mediante lmbr.exe per la gestione di progetti e pacchetti gem.

  • La barra di scorrimento non torna più automaticamente all'inizio dell'elenco quando selezioni un pacchetto gem.

  • Vari aggiornamenti dell'interfaccia utente includono la conversione del pulsante Enable Gem (Abilita pacchetto gem) in un collegamento, l'aggiornamento delle immagini di default per i pacchetti gem e l'aggiornamento del testo delle descrizioni e dei pulsanti a livello di Project Configurator (Configuratore progetto).

UI Editor (Editor IU)

  • Al grafico dei flussi sono stati aggiunti i nodi UI:Canvas:GetEnabled e UI:Canvas:SetEnabled, che possono essere utilizzati per abilitare e disabilitare un canvas. Questi nodi consentono il caricamento, ma non la visualizzazione o la simulazione, di un canvas.

  • I valori di ancoraggio sono stati modificati in modo da essere visualizzati come percentuali nel riquadro Properties (Proprietà) e nel viewport.

  • Il funzionamento del set di impostazioni relativo all'ancoraggio è stato modificato in modo tale che vengano adeguati anche il punto pivot e gli offset. Quando i punti di ancoraggio sono combinati insieme, il punto di pivot cambia in base ai punti di ancoraggio, gli offset si adeguano in modo che il punto pivot si trovi sui punti di ancoraggio; l'altezza e la larghezza dell'elemento vengono mantenuti invariati. Quando i punti di ancoraggio non sono combinati, il punto pivot viene impostato su 0,5 e gli offset si adeguano al valore 0.

  • Il funzionamento dei componenti è stato aggiornato in modo da visualizzare i componenti non validi come disabilitati nel menu Add Component (Aggiungi componente). In passato, i componenti non validi venivano rimossi.

  • È stato aggiunto il supporto per le opzioni paste as sibling (Incolla come elemento di pari livello) e paste as child (Incolla come elemento figlio). È stata aggiunta l'opzione paste as child (Incolla come elemento figlio) ai menu contestuali e ai menu di modifica in modo che sia visibile quando un elemento è selezionato. L'opzione paste (Incolla) è stata rinominata in paste as sibling (Incolla come elemento figlio). L'opzione è visibile quando un elemento è selezionato.

  • È stato aggiunto il supporto per la modifica dei punti pivot, offset e punti di ancoraggio in più elementi selezionati.

  • Gli elementi delle barre degli strumenti sono stati riordinati in un'unica barra degli strumenti fissa e sono stati aggiunti pulsanti per la modalità per il viewport.

  • Il widget Anchors (Punti di ancoraggio) è stato aggiornato nelle proprietà Transform2D (Trasformazione 2D) in modo da visualizzare i set di impostazioni integrati nel riquadro Properties (Proprietà) anziché visualizzarli in una finestra di dialogo popup.

  • La proprietà Pivot è stata aggiornata nel componente Transform2D (Trasformazione 2D) in modo da utilizzare un widget che visualizza i nove set di impostazioni più comunemente utilizzati.

  • L'icona New Element (Nuovo elemento) della barra degli strumenti è stata aggiornata in modo da aggiungere un elemento di primo livello anziché un elemento figlio dell'elemento selezionato.

  • Il comando del menu contestuale del nuovo elemento è stato modificato in modo da aggiungere un elemento in corrispondenza del punto in cui fai clic con il pulsante destro del mouse.

  • È stato aggiunto l'accesso a documentazione, tutorial e forum di Lumberyard dal menu Help (Aiuto) di UI Editor (Editor IU). L'operazione Give Us Feedback (Inviaci un feedback) visualizza una finestra di dialogo contenente un collegamento all'indirizzo e-mail per inviare il feedback.

  • Il comando Save As Prefab (Salva come prefab) è stato spostato dal menu Edit (Modifica) al menu File.

  • Il comando Open... (Apri...) nel menu File è stato rinominato in Open Canvas... (Apri canvas...).

Sistema di compilazione Waf

  • È stato aggiornato il sistema in modo tale che Waf build system (Sistema creazione Waf) utilizzi contenuti associati a QT:

    • I file di intestazione che devono essere elaborati dallo strumento MOC ora vengono rilevati da un processo di analisi del codice. In passato, i file di intestazione che dovevano essere elaborati dallo strumento MOC venivano specificati come una parola chiave denominata qt_to_moc.

    • Il modello di file MOC ora è moc_filename.cpp (in precedenza era filename.moc).

    • Poiché i file MOC vengono generati nella cartella intermedia basata su varianti, devi utilizzare il percorso completo relativo alla radice del progetto. Ad esempio, il progetto Editor (disponibile nella directory \dev\Code\Sandbox\Editor\QtUI) contiene un file di intestazione denominato ColorButton.h che deve essere elaborato dallo strumento MOC. Nell'origine di QtUI\ColorButton.cpp, il file viene incluso utilizzando il percorso relativo del progetto, ovvero #include QtUI/ColorButton.moc.

    • L'elaborazione QRC ora è inclusa in un'origine esistente anziché generare un file di intestazione. Qualsiasi file QRC elaborato ora viene considerato un'unità di compilazione propria, senza la necessità di includerlo in un'altra unità di elaborazione.

    • Anche se è rimasta per lo più invariata, l'elaborazione dei file dell'interfaccia utente ora richiede l'utilizzo del percorso relativo di un progetto (analogamente ai file MOC).

    • I file di QT Linguist (.ts) non sono supportati.

  • È stata aggiunta un'opzione di profiling alle build Waf (lmbr_waf), che consente di determinare dove si verificano le ottimizzazioni nella build.

  • Le funzioni Path e Settings sono state rimosse da tutti i file wscript. La soluzione Waf originale inseriva un metodo Path e Settings globale in ciascun file wscript. Ciò causava problemi di allineamento durante il debug dei file wscript negli ambienti di sviluppo integrati in Python. La rimozione delle funzioni Path e Settings può contribuire alla risoluzione dei problemi di allineamento. L'eccezione è rappresentata dal file wscript radice, che inserisce i metodi necessari per caricare ed eseguire i file wscript come file .json.

Varie

  • Sono stati aggiunti controlli di filtro al debugger e alla funzionalità Asset Processor (Elaboratore asset) (Elaboratore asset) per consentire il controllo dell'ambiente dietro al firewall LAN e per impedire agli utenti con accesso alla rete LAN di controllare l'editor in remoto.

  • È stato aggiunto un file di specifiche game.json (disponibile nella directory \dev\_WAF_\specs) che è possibile utilizzare solo per compilare il gioco. Per ulteriori informazioni, consulta Compilazione del progetto di gioco.

  • Il flusso di lavoro per la creazione di pacchetti gem con i plugin dell'editor è stato migliorato mediante l'aggiunta di un campo EditorTargets (Destinazioni editor) ai file .json dei pacchetti gem. Ciò consente di dichiarare nelle specifiche destinazioni aggiuntive in cui visualizzare l'editor.

  • Le prestazioni di Asset Processor (Elaboratore asset) sono state migliorate grazie al fatto che ora tutti i processi vengono creati prima del salvataggio dei risultati nel database SQLLITE. Lumberyard Editor (Editor Lumberyard) ora visualizza il conteggio dei processi in sospeso durante l'avvio in modo da consentirti di vedere in modo semplice e rapido le attività rimanenti prima che l'editor possa continuare.

  • È stata semplificata la procedura di recupero del foglio di stile Qt espanso compilato generato dalla funzionalità Lumberyard Editor (Editor Lumberyard) (Editor Lumberyard) durante il caricamento o l'aggiornamento del foglio di stile stesso. Il foglio di stile viene scritto nella home directory e consente di visualizzare i widget e le interfacce utente in Qt Creator o Qt Designer mediante la specifica degli argomenti della riga di comando (-stylesheet PATH_TO_FILE.qss).

  • È stato migliorato il rilevamento delle occorrenze delle operazioni tramite mouse durante la manipolazione delle curve nell'editor Time of Day (Ora del giorno).

  • I cataloghi AZCore ora sono obsoleti.

  • I file TransformComponent.cpp e TransformComponent.h sono stati spostati da AzCore ad AzFramework.

  • HttpRequestManager ora utilizza AZStd::thread anziché CrySimpleThread.

  • Il parametro isEntityId è stato aggiunto al funtore della funzione di callback per ReplaceEntityIdsAndEntityRefs.

  • L'impostazione di default di incredibuild_max_cores è stata aggiornata al valore 128, che consente di migliorare le prestazioni di compilazione di Incredibuild.

  • È stata aggiunta una notifica della funzionalità Lumberyard Editor (Editor Lumberyard) (Editor Lumberyard) per i moduli di sola lettura quando cerchi di eliminare un modulo del grafico dei flussi. La notifica richiede inoltre l'estrazione se il modulo è sottoposto al controllo della versione o la rimozione del flag di sola lettura. Se risulta impossibile eliminare il modulo, verrà visualizzata una notifica di operazione non riuscita.

  • È stata aggiunta la seguente macro da utilizzare assieme alle implementazioni di default delle funzioni DLL di inizializzazione/annullamento dell'inizializzazione: AZ_DECLARE_MODULE_INITIALIZATION.

  • È stata aggiunta la seguente macro da utilizzare quando il file DLL include AZ::Module: AZ_DECLARE_MODULE_CLASS.

  • È stato aggiunto il file lmbr.exe per la gestione di progetti e pacchetti gem dalla GUI o riga di comando di Project Configurator (Configuratore progetto). Ciò include la creazione di progetti, l'impostazione di progetti attivi, l'abilitazione o disabilitazione di pacchetti gem, nonché la creazione di pacchetti gem. Per un elenco di comandi, immetti lmbr.exe -help in una finestra a riga di comando.

  • È stato aggiornato il funzionamento dell'operazione di push per le sezioni in modo che non venga più eseguito il push di tutti i livelli provvisori della gerarchia.

  • È stato bloccato l'uso di funzionalità legacy non compatibili nell'editor di entità per le entità AZ.

  • Dall'editor in modalità AI (Intelligenza artificiale) o Physics (Fisica) è stata la possibilità di modificare le entità componente. Inoltre, la griglia delle proprietà è stata disabilitata e non è più possibile utilizzare tutti gli oggetti gizmo (a esclusione dell'oggetto gizmo di selezione) dell'editor. Puoi comunque modificare le entità modalità AI (Intelligenza artificiale) o Physics (Fisica). Tuttavia, se durante la transizione sono presenti più entità legacy o entità componente selezionate, tutti gli oggetti gizmo verranno convertiti in oggetti gizmo di selezione. Puoi effettuare solo selezioni singole o selezioni multiple di entità legacy e modificarle in base alle esigenze.