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Risolvi i problemi di integrazione del Web Application Firewall
Questa sezione descrive le possibili soluzioni per i problemi relativi all'integrazione AWS WAF con Transfer Family.
Argomenti
Risolvi i problemi del blocco del traffico legittimo da parte di WAF
Descrizione
Dopo la configurazione AWS WAF con l'endpoint Transfer Family, gli utenti legittimi non sono in grado di connettersi o riscontrano errori di connessione intermittenti. Potresti vedere le risposte HTTP 403 (Forbidden) nei tuoi log.
Causa
AWS WAF Le tue regole potrebbero essere troppo restrittive o configurate in modo errato, causando falsi positivi che bloccano il traffico legittimo. Le cause più comuni includono:
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regole basate su IP che bloccano inavvertitamente le reti aziendali o VPNs
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Regole basate sulle tariffe con soglie troppo basse per i normali schemi di traffico
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Gruppi di regole gestiti eccessivamente aggressivi per il tuo caso d'uso
Soluzione
Per risolvere i problemi relativi ai falsi positivi:
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Abilita AWS WAF la registrazione per identificare quali regole attivano i blocchi. Per istruzioni, consulta Registrazione del traffico ACL AWS WAF web.
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Esamina i log per identificare gli schemi nelle richieste bloccate.
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Modifica le tue regole in questo modo:
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Aggiungere indirizzi IP o intervalli a una lista consentita
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Aumento dei limiti di velocità per le regole basate sulle tariffe
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Impostazione di regole specifiche sulla modalità Count anziché sulla modalità Block per monitorare senza bloccare
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Creazione di eccezioni per regole specifiche utilizzando le esclusioni dei gruppi di regole
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Verifica la configurazione aggiornata con un campione rappresentativo di traffico legittimo prima della distribuzione completa.
Risolvi i problemi di integrazione WAF con provider di identità personalizzati
Descrizione
Dopo la configurazione AWS WAF con il server Transfer Family che utilizza un provider di identità personalizzato, l'autenticazione fallisce o gli utenti riscontrano problemi di autenticazione intermittenti.
Causa
Quando si utilizza un provider di identità personalizzato con API Gateway, AWS WAF le regole possono interferire con le chiamate API tra Transfer Family e il provider di identità. Ciò può accadere perché AWS WAF sta ispezionando e potenzialmente bloccando il traffico API in base ai relativi set di regole.
Soluzione
Per risolvere i problemi relativi AWS WAF ai provider di identità personalizzati:
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Assicurati che la AWS WAF configurazione includa eccezioni per gli endpoint API Gateway utilizzati dal tuo provider di identità personalizzato.
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Aggiungi il responsabile del servizio Transfer Family (transfer.amazonaws.com) a una lista consentita nelle tue regole. AWS WAF
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Se utilizzi gruppi di regole gestiti, esaminali per individuare le regole che potrebbero influire sui flussi di autenticazione delle API e valuta la possibilità di disabilitare tali regole specifiche.
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Testa il tuo provider di identità utilizzando direttamente l'operazione
TestIdentityProvider
API per verificare che funzioni correttamente senza AWS WAF interferenze.