Risoluzione dei problemi relativi alle app Web - AWS Transfer Family

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Risoluzione dei problemi relativi alle app Web

Nota

Questi suggerimenti per la risoluzione dei problemi sono rivolti all'amministratore dell'app Web piuttosto che all'utente finale. Per gli utenti finali, in caso di problemi, contattate l'amministratore dell'app web. Tutte le tue istanze riportate nei paragrafi seguenti si riferiscono all'amministratore dell'app Web.

Risolvi gli errori di rete

Descrizione

L'utente finale visualizza un banner di rete (Network Error) al caricamento dell'endpoint dell'app Web.

Causa

I problemi più comuni sono i seguenti:

  • L'amministratore non ha assegnato l'utente che sta tentando di accedere alla nuova applicazione.

  • L'amministratore non ha aggiunto le azioni necessarie ai tuoi ruoli IAM.

  • Viene visualizzato un elenco di S3 Access Grants assegnati al tuo utente, ma CORS non è configurato correttamente per il tuo bucket o i bucket Amazon S3.

Soluzione

Risolvi i problemi relativi alla mancata visualizzazione del bucket configurato

Descrizione

Sembra che tutto sia configurato correttamente, ma il bucket Amazon S3 non viene visualizzato nell'app Web.

Causa

Una possibile causa è che il bucket Amazon S3 non si trova nello stesso account dell'app Web.

Soluzione

Assicurati che il bucket Amazon S3 si trovi nello stesso account dell'app Web. I bucket tra più account non sono attualmente supportati.

Risolvi gli errori relativi agli URL personalizzati

Descrizione

Quando l'utente finale accede all'app Web, riceve il messaggio di errore Autorizzazione fallita: codice di autorizzazione mancante.

Causa

Se hai utilizzato CloudFront direttamente, anziché il AWS CloudFormation modello fornito, probabilmente hai configurato erroneamente la policy di richiesta di origine per non inoltrare le stringhe di query.

Soluzione

Aggiorna la politica di richiesta di origine per inoltrare le stringhe di query e i cookie all'origine.

Descrizione

Quando l'utente finale tenta di accedere a un'app web Transfer Family, riceve una risposta 404.

Causa

Se hai utilizzato CloudFront direttamente, anziché il AWS CloudFormation modello fornito, probabilmente hai configurato erroneamente la politica della cache per includere l'Hostintestazione nella chiave della cache o hai configurato erroneamente la politica di richiesta di origine per inoltrare l'intestazione. Host

Soluzione

  • Assicurati che la tua politica sulla cache non includa l'Hostintestazione nella chiave della cache

  • Assicurati che la tua policy di richiesta di origine non inoltri l'Hostintestazione.

Risolvi errori vari

Descrizione

L'utente finale non può accedere o non può visualizzare bucket o file oppure viene visualizzato un altro errore.

Causa

Una possibile causa è che l'ARN dell'istanza IAM Identity Center non corrisponde al valore dell'ARN delle sovvenzioni o dell'ARN dell'istanza IAM Identity Center dell'app Web IAM Identity Center.

Soluzione

Controlla i seguenti elementi per vedere se corrispondono.

  • In IAM Identity Center, accedi a Impostazioni e visualizza l'ARN dell'istanza.

    arn:aws:sso:::instance/ssoins-instance-identifier
  • In Amazon S3, accedi a Access Grants e visualizza l'ARN dell'istanza IAM Identity Center.

    arn:aws:sso::account-id:application/ssoins-instance-identifier/apl-1234567890abcdef0
  • In Transfer Family, accedi alla pagina dei dettagli della tua app Web e visualizza l'ARN dell'istanza.

    arn:aws:sso:::instance/ssoins-instance-identifier

Il instance-identifier valore deve essere lo stesso in tutte e tre queste posizioni.