Risoluzione dei problemi AWS Client VPN: l'accesso a un sistema peeredVPC, ad Amazon S3 o a Internet è intermittente - AWS Client VPN

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Risoluzione dei problemi AWS Client VPN: l'accesso a un sistema peeredVPC, ad Amazon S3 o a Internet è intermittente

Problema

Ho problemi di connettività intermittenti durante la connessione a un sistema peered, ad Amazon VPC S3 o a Internet, ma l'accesso alle sottoreti associate non ne risente. Per risolvere i problemi di connettività devo eseguire la disconnessione e la riconnessione.

Causa

I client si connettono a un endpoint Client VPN in base all'algoritmo round-robin. DNS Ciò significa che il traffico può essere instradato attraverso una qualsiasi delle sottoreti associate quando stabiliscono una connessione. Di conseguenza, problemi di connettività si possono verificare se i client si trovano in una sottorete associata che non dispone delle voci route richieste.

Soluzione

Verifica che l'VPNendpoint Client abbia le stesse voci di percorso con destinazioni per ogni rete associata. Ciò garantisce che i client possano accedere a tutte le route a prescindere dalla sottorete associata attraverso la quale viene instradato il traffico.

Ad esempio, supponiamo che l'VPNendpoint Client abbia tre sottoreti associate (subnet A, B e C) e che desideri abilitare l'accesso a Internet per i tuoi clienti. A tale scopo, è necessario aggiungere tre route 0.0.0.0/0, una per ogni sottorete associata:

  • Route 1: 0.0.0.0/0 per sottorete A

  • Route 2: 0.0.0.0/0 per sottorete B

  • Route 3: 0.0.0.0/0 per sottorete C