AWS CLI のバージョンについて - AWS Command Line Interface

Python 2.7、3.4、および 3.5 は、AWS CLI バージョン 1 に対して非推奨です。詳細については、「AWS CLI バージョンについて」の AWS CLI バージョン 1 セクションを参照してください。

AWS CLI のバージョンについて

AWS CLI には 2 つのバージョンがあります。このガイドの情報は、特に明記しない限り、両方のバージョンに該当します。現在インストールされているバージョンを確認するには、シェルで aws --version コマンドを実行します。戻り値は、インストール済みの現在のバージョンを示します。次の例は、実行中のバージョンが 2.1.29 であることを示しています。

$ aws --version aws-cli/2.1.29 Python/3.7.4 Linux/4.14.133-113.105.amzn2.x86_64 botocore/2.0.0

メンテナンスとサポート情報については、「AWS SDK とツールのメンテナンスポリシー」を参照してください。

AWS CLI バージョン 2

AWS CLI CLI バージョン 2 は、AWS CLI CLI の最新メジャーバージョンであり、最新機能をすべてサポートしています。バージョン 2 で導入された一部の機能は、バージョン 1 との下位互換性がないため、これらの機能にアクセスするには、アップグレードする必要があります。バージョン 1 には、スクリプトを変更することが必要となる場合がある「互換性を損なう」変更があります。バージョン 2 の変更点の一覧については、「破壊的変更 - AWS CLI バージョン 1 からバージョン 2 への移行」をご参照ください。

AWS CLI CLI バージョン 2 は、バンドルされたンストーラーとしてのみインストールできます。パッケージマネージャーに含まれている場合もありますが、これらは によって作成または管理されていないサポート対象外の非公式パッケージですAWS このガイドに記載されている公式の AWS CLI ディストリビューションポイントからのみ AWS をインストールすることを推奨します。

AWS CLI CLI バージョン 2 をインストールするには、「AWS CLI バージョン 2 のインストール、更新、アンインストール」を参照してください。

バージョン履歴については、GitHub の AWS CLI CLI バージョン 2 の更新履歴を参照してください。

‭AWS CLI バージョン 1

警告

Python 2.7 は、2020 年 1 月 1 日に Python Software Foundation によって非推奨になりました。今後、AWS CLI バージョン 1 を使用しているお客様は、Python 3.6 以上の Python 3 の使用に移行する必要があります。2021 年 7 月 15 日をもって、Python 2.7 のサポートが ‭AWS CLI‬ バージョン 1 の新しいバージョンで非推奨になります。2021 年 2 月 1 日から、Python 3.4 および 3.5 は非推奨となります。

以前のバージョンの Python で引き続き AWS CLI CLI バージョン 1 を使用するには、以下の Python のバージョンサポートマトリックスをご参照ください。

Python のインストール手順については、Python の Beginner Guide の「Downloading Python」ページをご参照ください。

AWS CLI CLI バージョン 1 はオリジナルの AWS CLI CLI であり、引き続きサポートしています。ただし、‭AWS CLI‬ CLI バージョン 2 で導入された主な新機能は、‭AWS CLI‬ バージョン 1 にバックポートされない場合があります。これらの機能を使用するには、AWS CLI CLI バージョン 2 をインストールする必要があります。

AWS CLI CLI バージョン 1 は Python SDK を使用して構築されるため、互換性のあるバージョンの Python をインストールする必要があります。

Python バージョンのサポートマトリックス
AWS CLI バージョン サポートされている Python のバージョン
2021 年 7 月 15 日以降のバージョン Python 3.6 以上
1.19.0 — 最新 Python 2.7 以上、Python 3.6 以上
1.17 — 1.18.x Python 2.7 以上、Python 3.4 以上
1.0 — 1.16.x Python 2.6 以上、Python 3.3 以上

AWS CLI CLI バージョン 1 をインストールするには、「AWS CLI バージョン 1 のインストール、更新、アンインストール」を参照してください。

バージョン履歴については、GitHub の AWS CLI CLI バージョン 1 の更新履歴を参照してください。