ec2-managedinstance-applications-required - AWS Config

翻訳は機械翻訳により提供されています。提供された翻訳内容と英語版の間で齟齬、不一致または矛盾がある場合、英語版が優先します。

ec2-managedinstance-applications-required

Checks if all of the specified applications are installed on the instance. オプションで、使用可能な最小バージョンを指定します。また、そのプラットフォームを実行中のインスタンスのみにルールを適用するプラットフォームを指定できます。

注記

SSM エージェントが EC2 インスタンスで実行されていることを確認し、SSM エージェントを設定します。

Identifier: EC2_MANAGEDINSTANCE_APPLICATIONS_REQUIRED

Trigger type: 設定変更

AWS Region: All supported AWS regions

パラメータ:

applicationNames
タイプ: CSV

アプリケーション名のカンマ区切りリスト。Optionally, specify versions appended with ':' (for example, 'Chrome:0.5.3, Firefox').

注記

The application names must be an exact match. たとえば、Linux で firefox または Amazon Linux で firefox-compat を使用します。In addition, AWS Config does not currently support wildcards for the applicationNames parameter (for example, firefox*).

platformType (Optional)
タイプ: 文字列

Platform type (for example, 'Linux' or 'Windows').

AWS CloudFormation テンプレート

To create AWS Config managed rules with AWS CloudFormation templates, see Creating AWS Config Managed Rules With AWS CloudFormation Templates.