GetLayerVersionPolicy - AWS Lambda

GetLayerVersionPolicy

AWS Lambda レイヤーのバージョンの許可ポリシーを返します。詳細については、「AddLayerVersionPermission」を参照してください。

リクエストの構文

GET /2018-10-31/layers/LayerName/versions/VersionNumber/policy HTTP/1.1

URI リクエストパラメータ

リクエストでは、次の URI パラメータを使用します。

LayerName

レイヤーの名前または Amazon リソースネーム (ARN)。

長さの制限: 最小長は 1 です。最大長は 140 です。

パターン: (arn:[a-zA-Z0-9-]+:lambda:[a-zA-Z0-9-]+:\d{12}:layer:[a-zA-Z0-9-_]+)|[a-zA-Z0-9-_]+

必須 : はい

VersionNumber

バージョン番号。

必須: はい

リクエストボディ

リクエストにリクエスト本文がありません。

レスポンスの構文

HTTP/1.1 200 Content-type: application/json { "Policy": "string", "RevisionId": "string" }

レスポンス要素

アクションが成功すると、サービスは HTTP 200 レスポンスを返します。

サービスから以下のデータが JSON 形式で返されます。

Policy

ポリシードキュメント。

タイプ: 文字列

RevisionId

ポリシーの現在のリビジョンにおける一意の識別子。

タイプ: 文字列

エラー

InvalidParameterValueException

リクエストに含まれているパラメータの 1 つが無効です。

HTTP ステータスコード: 400

ResourceNotFoundException

リクエストで指定されたリソースは存在しません。

HTTP ステータスコード: 404

ServiceException

AWS Lambda サービスで内部エラーが発生しました。

HTTP ステータスコード: 500

TooManyRequestsException

リクエストスループット制限を超えました。

HTTP ステータスコード: 429

以下の資料も参照してください。

言語固有の AWS SDK のいずれかでこの API を使用する方法の詳細については、次を参照してください: