Class: Aws::AmplifyBackend::Types::CreateBackendAuthPasswordPolicyConfig

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-amplifybackend/lib/aws-sdk-amplifybackend/types.rb

Overview

Note:

When making an API call, you may pass CreateBackendAuthPasswordPolicyConfig data as a hash:

{
  additional_constraints: ["REQUIRE_DIGIT"], # accepts REQUIRE_DIGIT, REQUIRE_LOWERCASE, REQUIRE_SYMBOL, REQUIRE_UPPERCASE
  minimum_length: 1.0, # required
}

The password policy configuration for the backend to your Amplify project.

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#additional_constraintsArray<String>

Additional constraints for the password used to access the backend of your Amplify project.

Returns:

  • (Array<String>)


1059
1060
1061
1062
1063
1064
# File 'gems/aws-sdk-amplifybackend/lib/aws-sdk-amplifybackend/types.rb', line 1059

class CreateBackendAuthPasswordPolicyConfig < Struct.new(
  :additional_constraints,
  :minimum_length)
  SENSITIVE = []
  include Aws::Structure
end

#minimum_lengthFloat

The minimum length of the password used to access the backend of your Amplify project.

Returns:

  • (Float)


1059
1060
1061
1062
1063
1064
# File 'gems/aws-sdk-amplifybackend/lib/aws-sdk-amplifybackend/types.rb', line 1059

class CreateBackendAuthPasswordPolicyConfig < Struct.new(
  :additional_constraints,
  :minimum_length)
  SENSITIVE = []
  include Aws::Structure
end