Class: Aws::ApiGatewayV2::Types::UpdateApiInput

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb

Overview

Represents the input parameters for an UpdateApi request.

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#api_key_selection_expressionString

An API key selection expression. Supported only for WebSocket APIs. See API Key Selection Expressions.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#cors_configurationTypes::Cors

A CORS configuration. Supported only for HTTP APIs.

Returns:



6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#credentials_arnString

This property is part of quick create. It specifies the credentials required for the integration, if any. For a Lambda integration, three options are available. To specify an IAM Role for API Gateway to assume, use the role's Amazon Resource Name (ARN). To require that the caller's identity be passed through from the request, specify arn:aws:iam:::user/. To use resource-based permissions on supported AWS services, specify null. Currently, this property is not used for HTTP integrations. If provided, this value replaces the credentials associated with the quick create integration. Supported only for HTTP APIs.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#descriptionString

The description of the API.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#disable_execute_api_endpointBoolean

Returns:

  • (Boolean)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#disable_schema_validationBoolean

Avoid validating models when creating a deployment. Supported only for WebSocket APIs.

Returns:

  • (Boolean)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#nameString

The name of the API.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#route_keyString

This property is part of quick create. If not specified, the route created using quick create is kept. Otherwise, this value replaces the route key of the quick create route. Additional routes may still be added after the API is updated. Supported only for HTTP APIs.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#route_selection_expressionString

The route selection expression for the API. For HTTP APIs, the routeSelectionExpression must be ${request.method\} ${request.path\}. If not provided, this will be the default for HTTP APIs. This property is required for WebSocket APIs.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#targetString

This property is part of quick create. For HTTP integrations, specify a fully qualified URL. For Lambda integrations, specify a function ARN. The type of the integration will be HTTP_PROXY or AWS_PROXY, respectively. The value provided updates the integration URI and integration type. You can update a quick-created target, but you can't remove it from an API. Supported only for HTTP APIs.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end

#versionString

A version identifier for the API.

Returns:

  • (String)


6552
6553
6554
6555
6556
6557
6558
6559
6560
6561
6562
6563
6564
6565
6566
# File 'gems/aws-sdk-apigatewayv2/lib/aws-sdk-apigatewayv2/types.rb', line 6552

class UpdateApiInput < Struct.new(
  :api_key_selection_expression,
  :cors_configuration,
  :credentials_arn,
  :description,
  :disable_schema_validation,
  :disable_execute_api_endpoint,
  :name,
  :route_key,
  :route_selection_expression,
  :target,
  :version)
  SENSITIVE = []
  include Aws::Structure
end