Class: Aws::IoT::Types::VersionConflictException

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-iot/lib/aws-sdk-iot/types.rb

Overview

An exception thrown when the version of an entity specified with the expectedVersion parameter does not match the latest version in the system.

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#messageString

The message for the exception.

Returns:

  • (String)


20285
20286
20287
20288
20289
# File 'gems/aws-sdk-iot/lib/aws-sdk-iot/types.rb', line 20285

class VersionConflictException < Struct.new(
  :message)
  SENSITIVE = []
  include Aws::Structure
end