Class: Aws::RDS::Types::DescribeDBEngineVersionsMessage

Inherits:
Struct
  • Object
show all
Defined in:
gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb

Overview

Note:

When making an API call, you may pass DescribeDBEngineVersionsMessage data as a hash:

{
  engine: "String",
  engine_version: "String",
  db_parameter_group_family: "String",
  filters: [
    {
      name: "String", # required
      values: ["String"], # required
    },
  ],
  max_records: 1,
  marker: "String",
  default_only: false,
  list_supported_character_sets: false,
  list_supported_timezones: false,
  include_all: false,
}

Constant Summary collapse

SENSITIVE =
[]

Instance Attribute Summary collapse

Instance Attribute Details

#db_parameter_group_familyString

The name of a specific DB parameter group family to return details for.

Constraints:

  • If supplied, must match an existing DBParameterGroupFamily.

^

Returns:

  • (String)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#default_onlyBoolean

A value that indicates whether only the default version of the specified engine or engine and major version combination is returned.

Returns:

  • (Boolean)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#engineString

The database engine to return.

Valid Values:

  • aurora (for MySQL 5.6-compatible Aurora)

  • aurora-mysql (for MySQL 5.7-compatible and MySQL 8.0-compatible Aurora)

  • aurora-postgresql

  • mariadb

  • mysql

  • oracle-ee

  • oracle-ee-cdb

  • oracle-se2

  • oracle-se2-cdb

  • postgres

  • sqlserver-ee

  • sqlserver-se

  • sqlserver-ex

  • sqlserver-web

Returns:

  • (String)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#engine_versionString

The database engine version to return.

Example: 5.1.49

Returns:

  • (String)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#filtersArray<Types::Filter>

This parameter isn't currently supported.

Returns:



10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#include_allBoolean

A value that indicates whether to include engine versions that aren't available in the list. The default is to list only available engine versions.

Returns:

  • (Boolean)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#list_supported_character_setsBoolean

A value that indicates whether to list the supported character sets for each engine version.

If this parameter is enabled and the requested engine supports the CharacterSetName parameter for CreateDBInstance, the response includes a list of supported character sets for each engine version.

For RDS Custom, the default is not to list supported character sets. If you set ListSupportedCharacterSets to true, RDS Custom returns no results.

Returns:

  • (Boolean)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#list_supported_timezonesBoolean

A value that indicates whether to list the supported time zones for each engine version.

If this parameter is enabled and the requested engine supports the TimeZone parameter for CreateDBInstance, the response includes a list of supported time zones for each engine version.

For RDS Custom, the default is not to list supported time zones. If you set ListSupportedTimezones to true, RDS Custom returns no results.

Returns:

  • (Boolean)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#markerString

An optional pagination token provided by a previous request. If this parameter is specified, the response includes only records beyond the marker, up to the value specified by MaxRecords.

Returns:

  • (String)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end

#max_recordsInteger

The maximum number of records to include in the response. If more than the MaxRecords value is available, a pagination token called a marker is included in the response so you can retrieve the remaining results.

Default: 100

Constraints: Minimum 20, maximum 100.

Returns:

  • (Integer)


10830
10831
10832
10833
10834
10835
10836
10837
10838
10839
10840
10841
10842
10843
# File 'gems/aws-sdk-rds/lib/aws-sdk-rds/types.rb', line 10830

class DescribeDBEngineVersionsMessage < Struct.new(
  :engine,
  :engine_version,
  :db_parameter_group_family,
  :filters,
  :max_records,
  :marker,
  :default_only,
  :list_supported_character_sets,
  :list_supported_timezones,
  :include_all)
  SENSITIVE = []
  include Aws::Structure
end