pgtle.set_default_version - Amazon Aurora

pgtle.set_default_version

set_default_version 함수를 사용하면 TLE 확장의 default_version을 지정할 수 있습니다. 이 함수를 사용하여 업그레이드 경로를 정의하고 해당 버전을 TLE 확장의 기본값으로 지정할 수 있습니다. 데이터베이스 사용자가 CREATE EXTENSIONALTER EXTENSION ... UPDATE 명령에서 TLE 확장을 지정하면 해당 버전의 TLE 확장이 해당 사용자의 데이터베이스에 생성됩니다.

이 함수는 성공 시 true를 반환합니다. name 인수에 지정된 TLE 확장자가 없는 경우에는 함수가 오류를 반환합니다. 마찬가지로 TLE 확장의 version이 존재하지 않으면 오류가 반환됩니다.

함수 프로토타입

pgtle.set_default_version(name text, version text)

역할

pgtle_admin

인수

  • name - TLE 확장의 이름입니다. 이 값은 CREATE EXTENSION 호출에 사용됩니다.

  • version - 기본값을 설정할 TLE 확장의 버전입니다.

출력

  • true - 기본 버전 설정에 성공하면 함수가 true를 반환합니다.

  • ERROR - 지정된 이름 또는 버전의 TLE 확장이 존재하지 않는 경우 오류 메시지를 반환합니다.

사용 예

SELECT * FROM pgtle.set_default_version('my-extension', '1.1');