DynamoDB Encryption Client 파이톤 가죽 - Amazon DynamoDB Encryption Client

문서의 영문과 번역 사이에 충돌이 있는 경우에는 영문 버전을 따릅니다. 번역 버전은 기계 번역을 사용하여 제공합니다.

DynamoDB Encryption Client 파이톤 가죽

이 항목에서는 DynamoDB Encryption Client Python 용. 다음에서 코드를 찾을 수 있습니다. aws-디나모드-암호화-피톤 GitHub의 리포지토리(완성되고 테스트된 리포지토리 포함) 샘플 코드 를 시작하는 데 도움이 됩니다.

Prerequisites

를 설치하기 전에 Amazon DynamoDB Encryption Client Python의 경우 다음 전제 조건을 충족해야 합니다.

지원되는 Python 버전

이 라이브러리를 사용하려면 Python 2.7 또는 Python 3.4 이상이 필요합니다. Python을 다운로드하려면 다음을 참조하십시오. 파이톤 다운로드.

Python용 pip 설치 도구

Python 2.7.9 이상 또는 Python 3.4 이상이 있다면 pip가 이미 설치되어 있으며, 원할 경우 업그레이드할 수 있습니다. pip 업그레이드 또는 설치에 대한 자세한 내용은 를 참조하십시오. 설치 에서 파이프 문서.

Installation

다음 예제와 같이 pip를 사용하여 Python용 Amazon DynamoDB Encryption Client를 설치합니다.

최신 버전을 설치하려면
pip install dynamodb-encryption-sdk

pip를 사용하여 패키지를 설치 및 업그레이드하는 방법에 대한 자세한 내용은 패키지 설치를 참조하십시오.

이 DynamoDB Encryption Client를 사용하려면 모든 플랫폼에 암호화 라이브러리가 있어야 합니다. 모든 버전 파이프 설치 및 구축 암호화 Windows 의 라이브러리. 파이프 8.1 이상 설치 및 구축 암호화 Linux에서. 이전 버전을 사용하는 경우 파이프 Linux 환경에는 암호화 라이브러리의 경우 를 설치해야 합니다. 자세한 내용은 을 참조하십시오. Linux에서 암호화 구축.

GitHub의 aws-dynamodb-encryption-python 리포지토리에서 DynamoDB Encryption Client의 최신 개발 버전을 다운로드할 수 있습니다.

를 설치한 후 DynamoDB Encryption Client이 가이드의 Python 코드 예를 보면서 시작하십시오.