호환 가능한 대체 CNI 플러그 인 - Amazon EKS

호환 가능한 대체 CNI 플러그 인

Amazon EKS는 공식적으로 Amazon VPC CNI plugin for Kubernetes만 지원합니다. Amazon EKS는 업스트림 Kubernetes를 실행하고 Kubernetes 인증을 받았으므로 클러스터의 Amazon EC2 노드에 대체 CNI 플러그인을 설치할 수 있습니다. 클러스터에 대체 CNI 플러그인이 있는 경우 해당 클러스터는 Fargate 노드에 대한 대체 CNI 플러그인을 설치하지 못합니다. Amazon EKS용 Amazon VPC CNI 플러그인은 이미 Fargate 노드에 있지만 Fargate 노드와 함께 사용할 수 있는 유일한 플러그인입니다. 프로덕션 환경에서 대체 CNI 플러그 인을 사용하려는 경우 상용 지원을 받거나 오픈 소스 CNI 플러그 인 프로젝트를 문제 해결하고 수정을 제공할 수 있는 전문 지식을 내부적으로 보유하는 것이 좋습니다.

Amazon EKS는 호환 가능한 대체 CNI 플러그 인을 지원하는 파트너 네트워크와 관계를 유지합니다. 지원되는 Kubernetes 버전, 자격 요건 및 수행된 테스트에 대한 자세한 내용은 다음 파트너의 설명서를 참조하세요.

파트너

제품

설명서

Tigera

Calico

설치 지침

Isovalent

Cilium

설치 지침

Weaveworks

Weave Net

설치 지침

VMware

Antrea

설치 지침

Amazon EKS는 모든 사용 사례를 포괄하는 다양한 옵션을 제공하는 것을 목표로 합니다. 여기에 나열되지 않은 상업적으로 지원되는 Kubernetes CNI 플러그인을 개발하는 경우 자세한 내용은 파트너 팀(aws-container-partners@amazon.com)으로 문의하세요.