RStudio 시작하기 - Amazon Lightsail for Research

RStudio 시작하기

이 자습서에서는 Amazon Lightsail for Research에서 RStudio 가상 컴퓨터를 관리하고 사용하는 방법을 안내합니다.

참고

Lightsail for Research 및 RStudio를 시작하기 위한 심층 자습서가 AWS 퍼블릭 부문 블로그에 게시되어 있습니다. 자세한 내용은 Amazon Lightsail for Research 시작하기: RStudio를 사용한 자습서를 참조하세요.

1단계: 필수 구성 요소 완성

아직 생성하지 않은 경우 RStudio 애플리케이션을 사용하여 가상 컴퓨터를 생성합니다. 자세한 내용은 가상 컴퓨터 생성 섹션을 참조하세요.

새 가상 컴퓨터를 설치하고 실행한 후 이 자습서의 4단계를 계속 진행합니다.

2단계: (옵션) 스토리지 스페이스 추가

가상 컴퓨터는 시스템 디스크와 함께 제공됩니다. 그러나 스토리지 요구 사항이 변경되면 가상 컴퓨터에 추가 디스크를 연결하여 스토리지 스페이스를 늘릴 수 있습니다.

작업 파일을 연결된 디스크에 저장할 수도 있습니다. 그런 다음 디스크를 분리하고 다른 가상 컴퓨터에 연결하여 한 컴퓨터에서 다른 컴퓨터로 파일을 빠르게 이동할 수 있습니다.

또는 작업 파일이 있는 연결된 디스크의 스냅샷을 만든 다음 스냅샷에서 복제 디스크를 만들 수 있습니다. 그런 다음 새 복제 디스크를 다른 컴퓨터에 연결하여 여러 가상 컴퓨터에 작업을 복제할 수 있습니다. 자세한 정보는 디스크 생성가상 컴퓨터에 디스크 연결 섹션을 참조하세요.

참고

콘솔을 사용하여 가상 컴퓨터에 디스크를 연결하면 Lightsail for Research가 자동으로 디스크를 포맷하고 마운트합니다. 이 프로세스는 몇 분 정도 걸리므로 사용하기 전에 디스크가 Mounted 마운팅 상태에 도달했는지 확인해야 합니다. 기본적으로 Lightsail for Research는 디스크를 /home/lightsail-user/<disk-name> 디렉터리에 마운트합니다. <disk-name>은(는) 디스크에 지정한 이름입니다.

3단계: 파일 업로드 및 다운로드

RStudio 가상 컴퓨터에 파일을 업로드하고 가상 컴퓨터에서 파일을 다운로드할 수 있습니다. 이렇게 하려면 다음 단계를 완료합니다.

  1. Amazon Lightsail‏에서 키 페어를 구합니다. 자세한 내용은 가상 컴퓨터용 키 페어 가져오기 섹션을 참조하세요.

  2. 키 페어를 확보한 후에는 SCP(Secure Copy) 유틸리티를 사용하여 연결을 설정할 수 있습니다. SCP를 사용하면 명령 프롬프트 또는 터미널을 사용하여 파일을 업로드하고 다운로드할 수 있습니다. 자세한 내용은 Secure Copy를 사용하여 파일을 가상 컴퓨터로 전송합니다. 섹션을 참조하세요.

  3. (옵션) 키 페어를 사용하여 SSH를 통해 가상 컴퓨터에 연결할 수도 있습니다. 자세한 내용은 보안 셸을 사용하여 가상 컴퓨터에 연결 섹션을 참조하세요.

    참고

    브라우저 기반 NICE DCV 클라이언트를 사용하여 가상 컴퓨터의 명령줄 인터페이스에 액세스하고 파일을 전송할 수도 있습니다. NICE DCV는 Lightsail for Research 콘솔에서 사용할 수 있습니다. 자세한 정보는 가상 컴퓨터 애플리케이션 실행가상 컴퓨터의 운영 체제에 액세스 섹션을 참조하세요.

4단계: RStudio 애플리케이션 시작

다음 절차를 완료하여 새 가상 컴퓨터에서 RStudio 애플리케이션을 시작합니다.

중요

운영 체제 또는 RStudio 애플리케이션을 업데이트하라는 메시지가 표시되더라도 업데이트하지 마십시오. 대신 해당 프롬프트를 닫거나 무시하는 옵션을 선택합니다. 또한 /home/lightsail-admin/ 디렉터리에 있는 파일은 수정하지 마세요. 이러한 작업으로 인해 가상 컴퓨터를 사용할 수 없게 될 수 있습니다.

  1. Lightsail for Research 콘솔에 로그인합니다.

  2. 계정에서 사용할 수 있는 가상 컴퓨터를 보려면 탐색 창에서 가상 컴퓨터를 선택합니다.

  3. 가상 컴퓨터 페이지에서 가상 컴퓨터를 찾고 다음 옵션 중 하나를 선택하여 가상 컴퓨터에 연결합니다.

    1. (권장) RStudio 애플리케이션을 집중 모드로 실행하려면 애플리케이션 시작을 선택합니다. 최근에 가상 컴퓨터에 연결하지 않은 경우 Lightsail for Research에서 세션을 준비할 때까지 몇 분 정도 기다려야 할 수 있습니다.

    2. 컴퓨터의 드롭다운 메뉴를 선택한 다음 운영 체제 액세스를 선택하여 가상 컴퓨터의 데스크톱에 접근합니다. 운영 체제에 다른 애플리케이션을 설치하려면 이렇게 하세요.

    Lightsail for Research는 몇 가지 명령을 실행하여 원격 디스플레이 프로토콜 연결을 시작합니다. 잠시 후 가상 컴퓨터에 가상 데스크톱 연결이 설정된 새 브라우저 탭 창이 열립니다. 애플리케이션 실행 옵션을 선택한 경우 이 절차의 다음 단계를 계속 진행하여 RStudio 애플리케이션에서 파일을 엽니다. 운영 체제 액세스 옵션을 선택한 경우 Ubuntu 데스크톱을 통해 다른 애플리케이션을 열 수 있습니다.

    참고

    브라우저에서 클립보드 공유를 승인하라는 메시지가 표시될 수 있습니다. 이렇게 하면 로컬 컴퓨터와 가상 컴퓨터 간에 복사하여 붙여넣을 수 있습니다.

    Ubuntu에서 초기 설정을 묻는 메시지가 표시될 수도 있습니다. 지시에 따라 설정을 완료하고 운영 체제를 사용할 수 있습니다.

  4. RStudio 애플리케이션이 열립니다.

    
                            RStudio 애플리케이션.
  5. RStudio에서 프로젝트를 열려면 파일 메뉴를 선택한 다음 프로젝트 열기를 선택합니다. 프로젝트 파일이 저장된 디렉터리 또는 폴더를 탐색합니다. 그런 후 파일을 선택하여 엽니다.

    연결된 디스크에 프로젝트 파일을 업로드한 경우 디스크가 마운트된 디렉터리를 찾습니다. 기본적으로 Lightsail for Research는 디스크를 /home/lightsail-user/<disk-name> 디렉터리에 마운트합니다. <disk-name>은(는) 디스크에 지정한 이름입니다. 다음 예제에서 MyRstudioDisk 디렉터리는 마운트된 디스크를 나타내며, Projects 하위 디렉터리에는 RStudio 프로젝트 파일이 들어 있습니다.

    
                            RStudio 프로젝트 파일의 디렉터리입니다.

    다음 예제에서는 MyRstudioProject.Rproj 프로젝트 파일을 열었습니다.

    
                            열린 RStudio 프로젝트.

    RStudio를 시작하는 방법에 대한 자세한 내용은 이 자습서의 5단계: Plesk 설명서 읽기 섹션을 참조하세요.

5단계: Plesk 설명서 읽기

RStudio 애플리케이션은 포괄적인 설명서 패키지와 함께 번들로 제공됩니다. RStudio 학습을 시작하려면 다음 예제와 같이 RStudio의 도움말 탭에 액세스하는 것이 좋습니다.


                    RStudio 애플리케이션의 도움말 탭

다음과 같은 RStudio 온라인 리소스를 사용할 수 있습니다.

6단계: (옵션) 사용량 및 비용 모니터링

Lightsail for Research 리소스의 월별 누계 비용 및 사용량 추정치는 Lightsail for Research 콘솔의.다음 영역에 표시됩니다.

  1. Lightsail for Research 콘솔의 탐색 창에서 가상 컴퓨터를 선택합니다. 실행 중인 각 가상 컴퓨터 아래에 가상 컴퓨터의 월 누계 예상 비용이 나열됩니다.

  2. 가상 컴퓨터의 CPU 사용률을 보려면 가상 컴퓨터의 이름을 선택한 다음 대시보드 탭을 선택합니다.

  3. 모든 Lightsail for Research 리소스의 월간 누계 비용 및 예상 사용량을 보려면 탐색 창에서 사용량을 선택합니다.

7단계: (옵션) 비용 관리 규칙 생성

비용 관리 규칙을 생성하여 가상 컴퓨터의 사용량과 비용을 관리합니다. 일정 기간 동안 CPU 사용률이 지정된 비율에 도달하면 실행 중인 컴퓨터를 중지하는 유휴 상태의 가상 컴퓨터 중지 규칙을 만들 수 있습니다. 예를 들어, 30분 동안 CPU 사용률이 5% 이하인 경우 특정 컴퓨터를 자동으로 중지하는 규칙을 만들 수 있습니다. 이는 컴퓨터가 유휴 상태이고 Lightsail for Research에서 컴퓨터를 중지하여 유휴 리소스에 대한 요금이 발생하지 않음을 의미합니다.

중요

유휴 상태인 가상 컴퓨터를 중지하는 규칙을 만들기 전에 며칠 동안 해당 컴퓨터의 CPU 사용률을 모니터링하는 것이 좋습니다. 가상 컴퓨터의 부하가 서로 다를 때의 CPU 사용률을 기록합니다. 예를 들어, 코드를 컴파일하고, 작업을 처리하고, 유휴 상태인 경우가 있습니다. 이렇게 하면 규칙의 정확한 임계값을 결정하는 데 도움이 됩니다. 자세한 내용은 이 자습서의 6단계: (옵션) 사용량 및 비용 모니터링 섹션을 참조하세요.

CPU 사용률 임계값이 워크로드보다 높은 규칙을 만들면 규칙으로 인해 가상 컴퓨터가 연속적으로 중지될 수 있습니다. 예를 들어, 규칙에 의해 중지된 후 바로 가상 컴퓨터를 시작하면 규칙이 다시 활성화되고 컴퓨터가 다시 중지됩니다.

비용 관리 규칙의 생성 및 관리에 대한 자세한 지침은 다음 가이드에서 확인할 수 있습니다.

8단계: (옵션) 스냅샷 생성

스냅샷은 데이터의 특점 시점 복사본입니다. 가상 컴퓨터의 스냅샷을 생성하고 이를 기준으로 사용하여 새 컴퓨터를 생성하거나 데이터 백업을 할 수 있습니다. 스냅샷은 스냅샷을 생성한 시점부터 컴퓨터를 복원하는 데 필요한 모든 데이터를 포함합니다.

스냅샷 생성 및 관리에 대한 자세한 지침은 다음 가이드에서 확인할 수 있습니다.

9단계: (옵션) 가상 컴퓨터 중지 또는 삭제

이 자습서용으로 생성한 가상 컴퓨터 작업을 마친 후에는 가성 컴퓨터를 삭제할 수 있습니다. 이렇게 하면 필요하지 않은 가상 컴퓨터에 대한 요금이 더 이상 부과되지 않습니다.

가상 컴퓨터를 삭제해도 관련 스냅샷이나 연결된 디스크는 삭제되지 않습니다. 스냅샷과 디스크를 생성한 경우 해당 스냅샷과 디스크를 수동으로 삭제하여 요금이 부과되지 않도록 해야 합니다.

나중에 사용할 수 있도록 가상 컴퓨터를 저장하되 표준 시간당 요금으로 요금이 부과되지 않도록 하려면 가상 컴퓨터를 삭제하는 대신 중지하면 됩니다. 그런 다음 나중에 다시 시작할 수 있습니다. 자세한 내용은 가상 컴퓨터 세부 정보 보기 섹션을 참조하세요. 요금에 대한 자세한 정보는 Lightsail for Research 요금 섹션을 참조하세요.

중요

Lightsail for Research 리소스 삭제는 영구적인 작업입니다. 삭제된 데이터는 복구할 수 없습니다. 나중에 데이터가 필요할 수 있는 경우 삭제하기 전에 가상 컴퓨터의 스냅샷을 생성합니다. 자세한 내용은 스냅샷 생성을 참조하세요..

  1. Lightsail for Research 콘솔에 로그인합니다.

  2. 탐색 창에서 가상 컴퓨터를 선택합니다.

  3. 삭제할 가상 컴퓨터를 선택합니다.

  4. 작업을 선택한 다음 가상 컴퓨터 삭제를 선택합니다.

  5. 텍스트 블록에 확인을 입력합니다. 그런 다음 가상 컴퓨터 삭제를 선택합니다