KVM에서 AL2023 실행을 위한 요구 사항 - Amazon Linux 2023

기계 번역으로 제공되는 번역입니다. 제공된 번역과 원본 영어의 내용이 상충하는 경우에는 영어 버전이 우선합니다.

KVM에서 AL2023 실행을 위한 요구 사항

이 섹션에서는 KVM에서 AL2023 실행을 위한 요구 사항을 설명합니다. AL2023 KVM 이미지는 aarch64x86-64 아키텍처에서 모두 사용할 수 있습니다. 이러한 요구 사항은 KVM 이미지의 AL2023 시스템 요구 사항 기본에 추가됩니다.

KVM에서 AL2023 실행을 위한 KVM 호스트 요구 사항

KVM 이미지는 현재 이 Ubuntu 버전에서 제공하는 qemu 버전이 있는 Ubuntu 22.04.3 LTS를 실행하는 호스트에서 시스템 6.2+dfsg-2ubuntu6.15 유형을 사용하여 검증됩니다. q35

KVM 기반 AL2023 기기 지원

AL2023 KVM 이미지(aarch64x86-64 모두)로 테스트된 qemu 장치 모델은 다음과 같습니다.
  • virtio-blk (virtio 블록 디바이스)

  • virtio-scsi (디스크 장치가 있는 virtio SCSI 컨트롤러)

  • virtio-net (virtio 네트워크 디바이스)

  • ahci (가상 CD-ROM 드라이브에만 사용 가능)

  • usb-storage (over xhci)

AL2023 KVM 이미지 검증에서 사용할 수 있지만 많이 사용되지는 않는 추가 qemu 장치 모델은 다음과 같습니다.
  • x86-64 VGA (qemu VGA)만 해당

  • virtio-rng (가상 난수 생성기)

  • 레거시 AT 키보드 및 PS/2 마우스 디바이스

  • 레거시 시리얼 디바이스

KVM의 부팅 모드 (UEFI및BIOS) AL2023 지원

x86-64 이미지는 레거시 BIOS 및 UEFI 부팅 모드에서 테스트했습니다. aarch64 이미지는 UEFI 부팅 모드에서 테스트했습니다.

참고

기본적으로 UEFI 부팅 모드를 사용할 때 일부 가상 컴퓨터 관리자는 보안 부팅을 지원하는 Microsoft 보안 부팅 키를 VM에 제공합니다. 이 구성으로는 AL2023 부팅은 불가능합니다.

AL2023 부트 로더는 Microsoft의 서명을 받지 않았으므로 가상 머신은 UEFI 키 없이 프로비저닝하거나 보안 부팅을 위한 AL2023 키를 사용하여 프로비저닝해야 합니다.

중요

KVM이미지에 대한 보안 부팅 지원은 아직 검증되지 않았습니다.

KVM에서 AL2023 실행 시 제한 사항

KVM에서 AL2023 실행에는 몇 가지 알려진 제한 사항이 있습니다.

참고

나열된 지원되지 않는 기능 중 일부를 구현하는 코드가 AL2023 내에 존재하여 제대로 작동할 수 있습니다. 지원되지 않는 기능 목록은 현재 작업에 의존해야 할 기능과 Amazon Linux 팀이 향후 업데이트의 일부로 사용할 수 있는 작업에 대해 정보에 입각한 결정을 내릴 수 있도록 하기 위한 것입니다.

KVM에서 AL2023 실행과 관련된 알려진 제한 사항
  • KVM 게스트 에이전트는 현재 패키지로 제공되거나 지원되지 않습니다.

  • CPU, 메모리 또는 기타 디바이스 유형의 핫 플러그 및 언플러그는 지원되지 않습니다.

  • VM 하이버네이션은 지원되지 않습니다.

  • VM 마이그레이션은 지원되지 않습니다.

  • PCI 패스스루 또는 USB 패스스루와 같은 디바이스 패스스루는 지원되지 않습니다.