macOS 문제 해결 - AWS 클라이언트 VPN

기계 번역으로 제공되는 번역입니다. 제공된 번역과 원본 영어의 내용이 상충하는 경우에는 영어 버전이 우선합니다.

macOS 문제 해결

다음 섹션에는 macOS 클라이언트를 사용할 때 발생할 수 있는 로깅 및 문제에 대한 정보가 포함되어 있습니다. 최신 버전의 클라이언트를 실행하고 있는지 확인합니다.

AWS 제공된 클라이언트

AWS 제공된 클라이언트는 이벤트 로그를 생성하여 컴퓨터의 다음 위치에 저장합니다.

/Users/username/.config/AWSVPNClient/logs

다음과 같은 유형의 로그를 사용할 수 있습니다.

  • 애플리케이션 로그: 애플리케이션에 대한 정보를 포함합니다. 이러한 로그 앞에 'aws_vpn_client_'가 붙습니다.

  • OpenVPN 로그: OpenVPN 프로세스에 대한 정보를 포함합니다. 이러한 로그 앞에 'ovpn_aws_vpn_client_'가 붙습니다.

AWS 제공된 클라이언트는 클라이언트 데몬을 사용하여 루트 작업을 수행합니다. 데몬 로그는 컴퓨터의 다음 위치에 저장됩니다.

/tmp/AcvcHelperErrLog.txt /tmp/AcvcHelperOutLog.txt

AWS 제공된 클라이언트는 컴퓨터의 다음 위치에 구성 파일을 저장합니다.

/Users/username/.config/AWSVPNClient/OpenVpnConfigs

클라이언트가 연결할 수 없습니다.

문제

AWS 제공된 클라이언트는 Client VPN 엔드포인트에 연결할 수 없습니다.

원인

이 문제의 원인은 다음 중 하나일 수 있습니다.

  • 다른 OpenVPN 프로세스가 컴퓨터에서 이미 실행 중이므로 클라이언트가 연결되지 않습니다.

  • 구성 파일(.ovpn)이 잘못되었습니다.

Solution

컴퓨터에서 실행 중인 다른 OpenVPN 애플리케이션이 있는지 확인합니다. 있는 경우 이러한 프로세스를 중지하거나 종료하고 Client VPN 엔드포인트에 연결을 다시 시도합니다. OpenVPN 로그에서 오류를 확인하고 Client VPN 관리자에게 다음 정보를 확인하도록 요청합니다.

클라이언트가 다시 연결 중 상태로 멈췄습니다.

문제

AWS 제공된 클라이언트가 Client VPN 엔드포인트에 연결을 시도하지만 재연결 상태에서 멈췄습니다.

원인

이 문제의 원인은 다음 중 하나일 수 있습니다.

  • 컴퓨터가 인터넷에 연결되어 있지 않습니다.

  • DNS 호스트 이름이 IP 주소로 확인되지 않습니다.

  • OpenVPN 프로세스가 엔드포인트에 연결을 무기한으로 시도하고 있습니다.

Solution

컴퓨터가 인터넷에 연결되어 있는지 확인합니다. Client VPN 관리자에게 구성 파일의 remote 지시문이 유효한 IP 주소로 확인되는지 문의합니다. VPN Client 창에서 연결 끊기를 선택하여 VPN 세션 연결을 끊고 다시 연결해 볼 수도 있습니다. AWS

클라이언트가 프로필을 만들 수 없습니다.

문제

AWS 제공 클라이언트를 사용하여 프로파일을 생성할 때 다음 오류가 발생합니다.

The config should have either cert and key or auth-user-pass specified.
원인

Client VPN 엔드포인트가 상호 인증을 사용하는 경우 구성(.ovpn) 파일에 클라이언트 인증서와 키가 포함되지 않습니다.

Solution

Client VPN 관리자가 클라이언트 인증서와 키를 구성 파일에 추가하는지 확인합니다. 자세한 내용은 AWS Client VPN 관리자 안내서클라이언트 구성 내보내기를 참조하세요.

도우미 도구 필요 오류

문제

VPN 연결을 시도할 때 다음 오류가 발생합니다.

AWS VPN Client Helper Tool is required to establish the connection.
Solution

AWS re:Post의 다음 문서를 참조하십시오. AWS VPN 클라이언트 — 도우미 도구 필요 오류

Tunnelblick

다음 문제 해결 정보는 macOS High Sierra 10.13.6 기반 Tunnelblick 소프트웨어의 버전 3.7.8(빌드 5180)에서 테스트되었습니다.

프라이빗 구성의 구성 파일은 컴퓨터의 다음 위치에 저장됩니다.

/Users/username/Library/Application Support/Tunnelblick/Configurations

공유 구성에 대한 구성 파일은 컴퓨터의 다음 위치에 저장됩니다.

/Library/Application Support/Tunnelblick/Shared

연결 로그는 컴퓨터의 다음 위치에 저장됩니다.

/Library/Application Support/Tunnelblick/Logs

로그 세부 수준을 높이려면 Tunnelblick 애플리케이션을 열고 설정을 선택한 다음 VPN 로그 수준 값을 조정합니다.

암호 알고리즘 'AES-256-GCM'을 찾을 수 없습니다.

문제

연결이 실패하고 로그에 다음 오류가 반환됩니다.

2019-04-11 09:37:14 Cipher algorithm 'AES-256-GCM' not found 2019-04-11 09:37:14 Exiting due to fatal error
원인

애플리케이션은 암호 알고리즘 AES-256-GCM을 지원하지 않는 OpenVPN 버전을 사용하고 있습니다.

Solution

다음을 수행하여 호환되는 OpenVPN 버전을 선택합니다.

  1. Tunnelblick 애플리케이션을 엽니다.

  2. 설정을 선택합니다.

  3. OpenVPN 버전의 경우 2.4.6 - OpenSSL version is v1.0.2q를 선택합니다.

연결 응답이 중지되고 재설정됨

문제

연결이 실패하고 로그에 다음 오류가 반환됩니다.

MANAGEMENT: >STATE:1559117927,WAIT,,,,,, MANAGEMENT: >STATE:1559117928,AUTH,,,,,, TLS: Initial packet from [AF_INET]3.217.107.5:443, sid=df19e70f a992cda3 VERIFY OK: depth=1, CN=server-certificate VERIFY KU OK Validating certificate extended key usage Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication VERIFY EKU OK VERIFY OK: depth=0, CN=server-cvpn Connection reset, restarting [0] SIGUSR1[soft,connection-reset] received, process restarting
원인

클라이언트 인증서가 취소되었습니다. 인증을 시도한 후 연결 응답이 중지되고 결국 서버 측에서 재설정됩니다.

Solution

Client VPN 관리자에게 새 구성 파일을 요청합니다.

확장 키 사용(EKU)

문제

연결이 실패하고 로그에 다음 오류가 반환됩니다.

TLS: Initial packet from [AF_INET]50.19.205.135:443, sid=29f2c917 4856ad34 VERIFY OK: depth=2, O=Digital Signature Trust Co., CN=DST Root CA X3 VERIFY OK: depth=1, C=US, O=Let's Encrypt, CN=Let's Encrypt Authority X3 VERIFY KU OK Validating certificate extended key usage ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication VERIFY EKU OK VERIFY OK: depth=0, CN=cvpn-lab.myrandomnotes.com (http://cvpn-lab.myrandomnotes.com/) Connection reset, restarting [0] SIGUSR1[soft,connection-reset] received, process restarting MANAGEMENT: >STATE:1559138717,RECONNECTING,connection-reset,,,,,
원인

서버 인증에 성공했습니다. 그러나 클라이언트 인증서에 서버 인증에 사용할 수 있는 확장 키 사용(EKU) 필드가 있기 때문에 클라이언트 인증이 실패합니다.

Solution

올바른 클라이언트 인증서와 키를 사용하고 있는지 확인합니다. 필요한 경우 Client VPN 관리자에게 확인합니다. 이 오류는 클라이언트 인증서가 아닌 서버 인증서를 사용하여 Client VPN 엔드포인트에 연결하는 경우에 발생할 수 있습니다.

만료된 인증서

문제

서버 인증은 성공하지만 다음 오류와 함께 클라이언트 인증이 실패합니다.

WARNING: “Connection reset, restarting [0] , SIGUSR1[soft,connection-reset] received, process restarting”
원인

클라이언트 인증서 유효성이 만료되었습니다.

Solution

Client VPN 관리자에게 새 클라이언트 인증서를 요청합니다.

OpenVPN

다음 문제 해결 정보는 macOS High Sierra 10.13.6 기반 OpenVPN Connect Client 소프트웨어의 버전 2.7.1.100에서 테스트되었습니다.

구성 파일은 컴퓨터의 다음 위치에 저장됩니다.

/Library/Application Support/OpenVPN/profile

연결 로그는 컴퓨터의 다음 위치에 저장됩니다.

Library/Application Support/OpenVPN/log/connection_name.log

DNS를 확인할 수 없습니다.

문제

다음 오류로 인해 연결이 실패합니다.

Mon Jul 15 13:07:17 2019 Transport Error: DNS resolve error on 'cvpn-endpoint-1234.prod.clientvpn.us-east-1.amazonaws.com' for UDP session: Host not found (authoritative) Mon Jul 15 13:07:17 2019 Client terminated, restarting in 2000 ms... Mon Jul 15 13:07:18 2019 CONNECTION_TIMEOUT [FATAL-ERR] Mon Jul 15 13:07:18 2019 DISCONNECTED Mon Jul 15 13:07:18 2019 >FATAL:CONNECTION_TIMEOUT
원인

OpenVPN 연결이 Client VPN DNS 이름을 확인할 수 없습니다.

Solution

AWS Client VPN 관리자 안내서Client VPN 엔드포인트 DNS 이름을 확인할 수 없음에 대한 해결 방법을 참조하세요.