Using Keyboard Shortcuts - Lumberyard User Guide

Using Keyboard Shortcuts

Open 3D Engine (O3DE), the successor to Lumberyard, is now available in Developer Preview. Download O3DE or visit the AWS Game Tech blog to learn more.

Lumberyard supports the following keyboard shortcuts.

File Menu
Keyboard shortcut Function
Ctrl+O Open a level
Ctrl+S Save the level
Ctrl+Alt+F Restore the saved state
Ctrl+Alt+H Save the current state
Ctrl+Shift+S Save the selected object
Edit Menu
Keyboard shortcut Function
G Toggle snap-to-grid
Ctrl+D Duplicate the selected object
Ctrl+Z Undo the last operation
Ctrl+Shift+Z Redo the last operation
Ctrl+Shift+Space Lock the selection
Game Menu
Keyboard shortcut Function
Ctrl+E Export the level
Ctrl+G Enter game mode (Esc to exit)
Ctrl+P Enable AI or physics
Tools Menu
Keyboard shortcut Function
M Open the Material Editor
` Open the console window
[ Increase the brush radius size
] Decrease the brush radius size
Shift+[ Decrease the hardness shape of the fall-off curve between the inner and outer radius of the brush
Shift+] Increase the hardness shape of the fall-off curve between the inner and outer radius of the brush
Select Toolbar
Keyboard shortcut Function
1 Select the object
2 Select and move the object
3 Select and rotate the object
4 Select and scale the object
5 Select the terrain area
Hide Toolbar
Keyboard shortcut Function
F Freeze the selected object
H Hide the selected object
Ctrl+F Unfreeze all objects
Ctrl+H Unhide all hidden objects
Constraint Toolbar
Keyboard shortcut Function
Ctrl+1 Follow the terrain
Ctrl+2 Lock on the xy-plane
Ctrl+3 Lock on the x-axis
Ctrl+4 Lock on the y-axis
Ctrl+5 Lock on the z-axis
Perspective Viewport
Keyboard shortcut Function
W Move forward in the viewport
A Move backward in the viewport
S Move left in the viewport
D Move right in the viewport
Q Move up in the viewport
E Move down in the viewport
Z Focus the camera to the selected object in the viewport
F3 Toggle the wireframe view
Alt+middle mouse button Rotate around the selected object
Alt+right click Zoom in and out
Ctrl+F1 (or F2, F3, F4, F5, F6, F7, F8, F9, F10, F11, F12) Save the viewport location
Shift+F1 (or F2, F3, F4, F5, F6, F7, F8, F9, F10, F11, F12) Move to the saved viewport location
Shift+Spacebar Show or hide helpers